Digital Art Zone

 
   
2 of 2
2
Argh! Weird green overlay on renders!!
Posted: 20 March 2014 04:19 PM   [ Ignore ]   [ # 16 ]
Administrator
Avatar
RankRankRankRank
Total Posts:  16477
Joined  2009-01-22

I completely spaced on this being a shader only issue. I had a friend that just went through heck because the new GPU Driver killed or error-ed almost every program they were using. It just stuck in my head I guess. It has to be in the shader itself I agree…

 Signature 

Exile, Drows Walk: A Tale of Jaderail starts here. Free pulp fiction at its Fantasy best, Updated 2/3/14.
Proud Member of the Bald Wizards Club My stuff at DeviantArt

Profile
 
 
Posted: 20 March 2014 05:32 PM   [ Ignore ]   [ # 17 ]
Member
Avatar
Rank
Total Posts:  236
Joined  2010-09-24

Hi guys. Thanks for responding!

The scenes are set up very simply. Everything is given the pwtoon shader as a base. outline of 80 t0 120. No inner line. bump off, things like that. uberenvironment, ambience only or directional shadows. One distant light and then a spotlight from the camera, wherever the camera may be. When rending, I put the render engine to cartoon under 3delight. It just used to render better that way.

I should reiterate that this particular scene is the same scene I’ve been using a while. The first example is how it USED to render. The second sample is what I’m getting now with no settings changed at all aside from a DAZ upgrade. I’ve been having to carry on anyway with these godawful blue splotches and my pages look TERRIBLE. Those blue lines create postwork messes I can’t correct without just throwing DAZ out the window and going back to drawing by hand.

I also built a whole new scene from scratch. Everything renders fine… until I put in the pwshader.

I use other toon shaders, and results are nice. Interestingly if I use the pwcomic shader, no blue splotches. It seems to be pretty specific to the settings I’ve been using all this time that never were an issue before.

So although I’d like to say, sure, setting issue. There’s this history of my settings being perfect…. (sighs) And I’ve poked and prodded, played, rebuilt, and have run out of time.

Profile
 
 
Posted: 20 March 2014 06:15 PM   [ Ignore ]   [ # 18 ]
Administrator
Avatar
RankRankRankRank
Total Posts:  16477
Joined  2009-01-22

Well that says to me it is in the pwToon shader but I did a pwToon with your settings and the DS Toon render option and still did not get the blue error… I admit I used a light set and not the default camera head lamp. Maybe that is the cause…I’ll check it on my PC now using just the head lamp.

 Signature 

Exile, Drows Walk: A Tale of Jaderail starts here. Free pulp fiction at its Fantasy best, Updated 2/3/14.
Proud Member of the Bald Wizards Club My stuff at DeviantArt

Profile
 
 
Posted: 20 March 2014 06:24 PM   [ Ignore ]   [ # 19 ]
Administrator
Avatar
RankRankRankRank
Total Posts:  16477
Joined  2009-01-22

I might be missing a step… But doing pwToon then the Default pwToon Neutral so I can set the inner edges off and then the DS Toon Render option I’m still not getting a blue shadow thing.
Could you walk me through your steps… I did the Ignore maps and all that…

 Signature 

Exile, Drows Walk: A Tale of Jaderail starts here. Free pulp fiction at its Fantasy best, Updated 2/3/14.
Proud Member of the Bald Wizards Club My stuff at DeviantArt

Profile
 
 
Posted: 20 March 2014 07:02 PM   [ Ignore ]   [ # 20 ]
Member
Avatar
Rank
Total Posts:  236
Joined  2010-09-24

WEll before I walk you through, I can say frustratingly (and interestingly) when I set it to render to a window as opposed to a file *and* I only have one or two objects in the picture the blue usually goes away. Which swings me to a hardware issue. Pwtoon makes my computer really think. Maybe I have a bad ram chip or even (gulp) a virus that’s eating things in the background. Or, it really could have been those stupid unwanted updates. Time for some serious computer maintenance if work will let me.

In the meantime, this is how I do it.

I get my character in.
Select, surface, pswtoon base, ignore maps.
In surface settings, all I change are:
bump and displace to 0
scroll to bottom: interior line off
outline color 000, width 80 or more. The width doesn’t matter, really. I just like to try to have thick lines.
rim color mode: difference, which is default. colors I leave at default. I’ve noticed when I change the rim color mode (I change it to add for black clothing) the blue will go away in those areas sometimes.

Lighting:
uberenvironment2, ambiance only or directional shadows.
1 lonely sun. 80%. shadows raytraced.
1 spotlight with your camera, 30% or so. Diffuse only. Or on, but no shadows.

And that’s it.

This may be a blessing in disguise.  This has shoved me into experimenting with the free acdztoon shaders (what with me wanting to get this done and all). They do a much crisper toon look, although the shadows leave a little to be desired right now. If I can get the shadows dark I may not use pwtoon as much anymore. Pwtoon is great for some things but there are times I’ve found it too shiny. But! One thing atta time.

Profile
 
 
Posted: 20 March 2014 07:05 PM   [ Ignore ]   [ # 21 ]
Administrator
Avatar
RankRankRankRank
Total Posts:  16477
Joined  2009-01-22

KK. Will follow this and see what we see…

 Signature 

Exile, Drows Walk: A Tale of Jaderail starts here. Free pulp fiction at its Fantasy best, Updated 2/3/14.
Proud Member of the Bald Wizards Club My stuff at DeviantArt

Profile
 
 
Posted: 20 March 2014 07:15 PM   [ Ignore ]   [ # 22 ]
Administrator
Avatar
RankRankRankRank
Total Posts:  16477
Joined  2009-01-22

Okay Got it. I get the BLUE green effect now. And guess what adds it? UE2. Any setting, Ambient or other… No UE2 light and no bad shadow effect… I hope this helps you some…

 Signature 

Exile, Drows Walk: A Tale of Jaderail starts here. Free pulp fiction at its Fantasy best, Updated 2/3/14.
Proud Member of the Bald Wizards Club My stuff at DeviantArt

Profile
 
 
Posted: 03 April 2014 03:04 PM   [ Ignore ]   [ # 23 ]
Member
Avatar
Rank
Total Posts:  236
Joined  2010-09-24

I never knew you replied. I’m sorry. I didn’t get a notice.

I’ve found that when I add too many lights I get the effect, but if I have only one light I don’t.

Except I used to be able to have all sorts of complex lighting.

I just reinstalled my Windows from scratch as I was having other problems, however, and now I must start a whole new thread on a whole new problem. I’m beginning to think me and DAZ are never going to see eye to eye.

Profile
 
 
   
2 of 2
2