Digital Art Zone

 
     
Problem with animation easing
Posted: 10 July 2012 04:39 AM   [ Ignore ]
New Member
Total Posts:  2
Joined  2012-07-10

Hi, I’m working on a scene where there are a number of different animated elements: the camera, a few planes etc, but for some reason the easing between each key frame is weird…

For example, say I want a plane to take off, if I set the key frame of the plane on the ground at 0 and then move the y-coordinates at frame 60, instead of creating a smooth path, the plane follows a curve and dips into the ground. Then if I want it to continue straight, it slows down and speeds up again, making movement unrealistic. This also means the planes and camera are impossible to sync.

When I open a new file and try the same animation it’s exactly how I want it and I don’t get any weird behaviour between key frames. I’m wondering if I’ve accidentally changed a setting on the file I’m working on. This happens when animating any object but only in that file. I can’t start again, unfortunately.

Can someone please help? I can’t find information about this anywhere!

Thank you,
E

Profile
 
 
Posted: 10 July 2012 05:04 AM   [ Ignore ]   [ # 1 ]
Power Member
Avatar
RankRankRank
Total Posts:  1585
Joined  2007-12-10

Have you altered any of the settings in the Advanced Motion Lab?

What I usually do is decide the overall start point and end point for the object, then create key frames for each and then add other relevant keyframes where they are required.


Also, if you go to the create tab, in the menu down the left, there is a section called ‘Paths’
Try the one called “Smooth Plane Flightpath” and see if that works or if it does anything unexpected.

Hope this helps.

 Signature 

I’ve got nothing of my own to promote, no models, no tutorials, no website, nothin’, nada, nill, nowt.

Profile
 
 
Posted: 10 July 2012 05:10 AM   [ Ignore ]   [ # 2 ]
Power Member
Avatar
RankRankRank
Total Posts:  1585
Joined  2007-12-10

One more thing: If you select the camera (the little inverted triangle down at the bottom right from the drop down list of objects in your scene), then click the little ‘A’ in the camera’s sub menu, then click on the ‘Linking’ tab, you can set the camera to automatically track the object you want it to follow.

 Signature 

I’ve got nothing of my own to promote, no models, no tutorials, no website, nothin’, nada, nill, nowt.

Profile
 
 
Posted: 10 July 2012 05:17 AM   [ Ignore ]   [ # 3 ]
Administrator
Avatar
RankRankRankRank
Total Posts:  15642
Joined  2003-10-09

This is where I once again curse the fact that we are limited with what we can access in the old archived forums.

There was a very long and invloved thread there about animation, and probalby lots of good tips and tricks, but of course no images

http://forumarchive.daz3d.com/viewtopic.php?t=166965

 Signature 

Chohole’s Space        Neil’Vs Freebies and stuff        L Summer Bryce Rendering Challenge        August Freebie Challenge
My DAZ 3D Gallery    11915

Profile
 
 
Posted: 10 July 2012 05:21 AM   [ Ignore ]   [ # 4 ]
Active Member
Avatar
RankRank
Total Posts:  640
Joined  2010-02-18

Have you tried deleting the keyframes’s flightpath (movement) for the objects that you are working on. It will be a pain to apply it to each object, however, in deleting all you do is select the object in question (it’ll be as a red mesh), hold down the shift key, and then click on the minus button (on the right side of keyframe key button). This completely deletes the whole flightpath for the object in question, where you can then retry, recast it again.


Obviously, before attempting the above, save the current file as a different Bryce file; so’s that if anything goes wrong with it, you can always go back to your original file. Sorry I couldn’t have been more helpful.


Jay

Profile
 
 
Posted: 10 July 2012 04:08 PM   [ Ignore ]   [ # 5 ]
Member
Avatar
Rank
Total Posts:  247
Joined  2005-09-28
npalomaresmoral - 10 July 2012 04:39 AM

Hi, I’m working on a scene where there are a number of different animated elements: the camera, a few planes etc, but for some reason the easing between each key frame is weird…


Even without looking at your file… I know. Bryce does weird things with keyframe easing. In fact, ‘easing’ is often the opposite of what happens. I frequently encounter unfeasible acceleration rather than easing…


Jamahoney’s on the right track, but his solution might be a little more overkill than you need. Your problem is you’ve added a third keyframe in your trajectory. It’s probably located right at the beginning or end of your 2-point trajectory: one of those key-frames is actually TWO keyframes side-by-side.


If you plot a two-point trajectory, you get linear motion. That’s inescapable in Bryce. Two keyframes = straight line. You can vary the acceleration that can happen along that line, but it stays a straight line.


You’ve got a curve. That means you’ve got at least 3 keyframes on the line, the middle one of which is not in the same line of motion as the outside two.


Select the plane. Use the Previous Keyframe button in the animation transport controls ( <| ) to go to your first keyframe. Click the Next Keyframe button until you locate a point in time where the time scrubber doesn’t appear to move (but in reality, is probably 1 or two frames further along from the last keyframe). When you’re positioned on the hidden keyframe, press the Key-minus button.


For future reference: I suggest going the Edit Attributes… > Animation tab of all moving objects and set every radio button to full visibility all the time, with the ribbon view on. It will help in animation diagnostics, and unless the animation is incredibly complex, not that intrusive.

Also, more on deleting keyframes here:

http://www.youtube.com/watch?v=_xq-3yNP8rY

Click my .sig below for some Bryce animation tutorials.

-Oro

 

 Signature 

Oroboros Presents… KEY-FLAME: Bryce Animation Tutorials

Profile
 
 
Posted: 10 July 2012 05:49 PM   [ Ignore ]   [ # 6 ]
Active Member
Avatar
RankRank
Total Posts:  640
Joined  2010-02-18

@npalomaresmoral
The fact that you’re having this problem with all objects, I wonder has the particular file become corrupt somehow along the way. Else, would it be some kind of grouping issue integrated with, say, individual parts within the objects in question.


On your speed issue: I’ve always had problems with speeds of objects in Bryce, too, and unless I create even movements of the objects along with evenly-spaced scrubber movements, the end flightpath has nearly always some speeding not bargained for in it. Creating or deleting additional tick marks for keyframes (e.g. drag scrubber, then click (+) or (-) button found on either side of the Key button…etc.,) along the flightpath can sometimes rectify (if not using the Create Path option, too), but more than likely if it isn’t planned carefully at the start for, say, special areas that one really wants to move slow or fast, the final animation won’t always go the way one wants it to.


Your best option, however, is to listen to whatever Oroboros tells you do as his animation experience, for me anyway, has always been of great help.


Jay

Profile
 
 
Posted: 10 July 2012 08:14 PM   [ Ignore ]   [ # 7 ]
Member
Avatar
Rank
Total Posts:  247
Joined  2005-09-28

[quote author=“Jamahoney”]The fact that you’re having this problem with all objects, I wonder has the particular file become corrupt somehow along the way.


It’s highly unlikely this is the result of file corruption JH, but I agree with your latter speculation: when multiple objects are affected, grouping, parenting and tracking eccentricities could be the cause.


However, it’s more likely to be that the designer selected all objects at some point and either accidentally gave them a nudge in Auto-Key mode, or tapped the Key-plus button, which sets a keyframe on all objects selected.


It’s hard to diagnose until you switch on all the trajectory toys in the Animation tab. Even acceleration issues can be revealed when you View as Ribbon: tightly spaced rungs indicate deceleration, wide-spaced rungs indicate acceleration.

Your best option, however, is to listen to whatever Oroboros tells you


PAY ME OBNOXIOUS AMOUNTS OF CASH!

 

 Signature 

Oroboros Presents… KEY-FLAME: Bryce Animation Tutorials

Profile
 
 
Posted: 11 July 2012 03:47 AM   [ Ignore ]   [ # 8 ]
Active Member
Avatar
RankRank
Total Posts:  640
Joined  2010-02-18

PAY ME OBNOXIOUS AMOUNTS OF CASH!

For goodness sake, Oroboros, I’m only saying what you told me (on threat) to say…hahaaa. Spare your blushes wink


@npalomaresmoral
Just another thought: is the problem showing up in an actual animation render, or just in the mesh(s) animation through the normal Camera View – you don’t say. It would be handy to hear from you!


Jay

Profile
 
 
Posted: 13 July 2012 08:11 AM   [ Ignore ]   [ # 9 ]
Member
Avatar
Rank
Total Posts:  103
Joined  2011-02-06

maybe you’ll find some tips here ?

http://www.robinwood.com/Catalog/Technical/BryceTuts/BryceClasses/IBryce1/IBryceLesson1-1.html

 Signature 

“If the facts don’t fit the theory, change the facts..” LOL
( Albert Einstein )

Profile
 
 
Posted: 14 July 2012 07:22 AM   [ Ignore ]   [ # 10 ]
New Member
Total Posts:  2
Joined  2012-07-10

Thank you an immense amount for all the feedback! I have been working all week & haven’t had a chance to work on the project. I’m on it now so I’ll let you know how I get on. Thanks again.

Profile