Digital Art Zone

 
     
GPU Slower Than Integrated
Posted: 05 July 2012 09:29 AM   [ Ignore ]
New Member
Total Posts:  7
Joined  2011-02-20

I just installed an Nvidia GeForce 550 Ti graphics card for my system, was running integrated graphics from my AMD processor before.
And now DAZ previews are actually lagging, whereas they didn’t when I used integrated graphics. It’s not enough to hamper my use of the program, but it’s strange.

What I’ve noticed is that I don’t hear the hum of the graphics card fan. Also, Daz is now using more memory with the same models. I’ve never noticed CPU usage before, but now it just hovers around 29%.

Has anyone else noticed a decrease in performance when switching to a graphics card? Using Daz Studio 3.

Profile
 
 
Posted: 05 July 2012 09:41 AM   [ Ignore ]   [ # 1 ]
Power Member
Avatar
RankRankRank
Total Posts:  2303
Joined  2010-12-18

Never seen a decrease when putting in a dedicated card. Do you have some 3D benchmark programs you can use to determine that it is running properly? If you are getting an improvement in those, then it *should* transfer over to DS.


I would first rule out if the hardware is faulty, then you can see if it is software related.


And are you giving that card enough power? Check that all the connections are plugged in, but also do you have a power supply powerful enough to feed it correctly.

 

 Signature 

My deviantArt Pinup Gallery

Profile
 
 
Posted: 05 July 2012 11:33 AM   [ Ignore ]   [ # 2 ]
New Member
Total Posts:  7
Joined  2011-02-20

Hm. I’ll try running a benchmark software besides MSI, which marks it as 5.8 (up from 3.8) for 3D graphics. I also see a massive improvement in gaming, in which I can run at max quality with no lag in Tribes:Ascend. (1280x1024)

I’d like to note that OpenGL renders are also faster, the previews are the only slow/laggy aspect.

Profile
 
 
Posted: 05 July 2012 12:18 PM   [ Ignore ]   [ # 3 ]
Power Member
Avatar
RankRankRank
Total Posts:  2303
Joined  2010-12-18

based on what you have said I think we can safely say its not a hardware issue then. So the next question is drivers, do you have the most up to date drivers? ANd exactly which version of studio are you using?

 Signature 

My deviantArt Pinup Gallery

Profile
 
 
Posted: 05 July 2012 12:53 PM   [ Ignore ]   [ # 4 ]
New Member
Total Posts:  7
Joined  2011-02-20

Hm. Just updated my graphics card driver.

Bit hesitant on upgrading to DS4 as it was pretty slow previously, but now DS3 has the same lag in preview.
3.1.2.31 (32bit), Can’t find downloads for DS3 anymore.
4.0.3.9 (64bit)

Profile
 
 
Posted: 05 July 2012 12:57 PM   [ Ignore ]   [ # 5 ]
Power Member
Avatar
RankRankRank
Total Posts:  2303
Joined  2010-12-18

Well seems like you did everything right :( Sorry I’m out of suggestions (not sure I really had any)

 Signature 

My deviantArt Pinup Gallery

Profile
 
 
Posted: 05 July 2012 01:05 PM   [ Ignore ]   [ # 6 ]
Member
Avatar
Rank
Total Posts:  238
Joined  2006-01-21

Hi,

Possibly Studio is using a higher texture resolution in preview now because it can. That may explain the higher memory load, which will also cause a higher CPU load causing the slowdown.

Does DS have an option to manually limit the texture size? Try turning it down if it does. (I’m doing a render now so I can’t check it)

Another possiblity is that you have the quality settings of your card set to ‘highest’ globally. You may need to set it to be managed by the application.

 Signature 

http://roguepilot.deviantart.com/
http://www.renderosity.com/mod/gallery/browse.php?username=RoguePilot
http://www.ShareCG.com/pf/full_uploads.php?pf_user_name=RoguePilot

Profile
 
 
Posted: 05 July 2012 01:47 PM   [ Ignore ]   [ # 7 ]
New Member
Total Posts:  7
Joined  2011-02-20

Don’t know if there’s a way to limit the texture size. Might be because I’m bad at navigating menus. Set the OpenGL Texture slider to Performance.
What I notice is that the edges of the preview look a bit more blocky/jaggy, while the older one looks smoother. Which is really weird.
http://imgur.com/tzHkT The smaller image is actually the one with the new graphics card.

Nvidia Control Panel doesn’t seem to have a quality setting for each application. Tried the overall settings of “Let the application decide” and “Performance” restarting Daz every time. No significant change.
I’d switch back to the integrated card to check the difference, but I’m not sure how to do that.

Actually, I don’t notice any change with any of the settings after adjustments. It’s still slow and the edges are jagged.

Profile
 
 
Posted: 05 July 2012 01:55 PM   [ Ignore ]   [ # 8 ]
Power Member
Avatar
RankRankRank
Total Posts:  2303
Joined  2010-12-18
Darksircam - 05 July 2012 01:47 PM

I’d switch back to the integrated card to check the difference, but I’m not sure how to do that.

Typically you’d want to uninstall/reinstall drivers since the intergrated card uses different ones than your current card.


You’d also want to physically open up and take out the card just to reinstall later.

 

So you may not want to devote the time to it.

 

 Signature 

My deviantArt Pinup Gallery

Profile
 
 
Posted: 05 July 2012 03:47 PM   [ Ignore ]   [ # 9 ]
New Member
Total Posts:  7
Joined  2011-02-20

Hm. Problem seemed to be with the original Windows driver. I installed a driver from the Nvidia site afterward, and they may have conflicted. Gah… I forgot to remove the driver before installing the new one.

I now hear the low hum of the GPU fan. That is good. Didn’t notice it when running Daz before.

If you found a way to reduce texture size that would be appreciated though.

Profile