Digital Art Zone

 
     
FBX “Round tripping” unworkable fix
Posted: 26 June 2012 07:58 PM   [ Ignore ]
New Member
Total Posts:  25
Joined  2004-12-12

I’m about to throw in the towel with DAZ and trying to bring animations in as I keep coming up against problems.

I thought my fbx > bvh fix worked but besides the first model I tried, turning off limits no longer seems to have any effect.

I have inserted a new genesis character into the scene, turned limits off using the Edit menu (the only place I can find anything to do with limits) and then import my bvh (making sure that the import does not use limits). 

Every time the limits interferes with the animation coming in properly.

I thought I had yet another work around by using the one genesis character that actually turned limits off and just saving my other characters as character presets.  On the surface this seemed to work, the animation imported correctly, the character shape was the same… and then I realised half of the face poses no longer worked so the whole step was a waste of time.

DS is truly becoming more trouble than its worth; where the time you spend trying to use the available models is exceeded by the time required to get things to work properly with DZ and even to get DZ to do what it is supposed to.

Profile
 
 
Posted: 27 June 2012 06:37 AM   [ Ignore ]   [ # 1 ]
Member
Rank
Total Posts:  178
Joined  2010-12-30

The other place to turn off limits is in the parameters pane.

It’s a pain in the but to do it joint by joint but there is a way around that…

Go into the scene pane , select the genesis figure, use the menu in the pane top right hand corner, select Expand>Expand from Selection.

Next step is to select the hip joint, scroll down and shit-select the Left Pectoral Joint.

Now that you have all the joints selected go to the Parameters Pane where all 70 joint should be selected.

You still have to go into each parameters Parameter Setting to switch off the limits but you will affect all 70 joints at one go.

If you save a scene with this figure you should save the “Respect Limits = No” as well.

 Signature 

“Aut viam inveniam aut faciam”

Profile
 
 
Posted: 27 June 2012 11:16 AM   [ Ignore ]   [ # 2 ]
Member
Rank
Total Posts:  92
Joined  2010-12-31

So I am guessing what you are seeing is something like the following:
- Export something out of DAZ
- Animate that something using IK or some solver based system such as MotionBuilder.
- Export that out of whatever program and import it into Studio.
- The animations based on IK often “twist” the joints, while Genesis joints have strict limits on several of its joints, especially twist.

I know in MotionBuilder you can setup limits in there to keep the values more sane, but that even in MotionBuilder the limits can severly confuse the IK solver and plotter.

Profile