Aggravating DS 4.6 bug

CMacksCMacks Posts: 80
edited December 1969 in Daz Studio Discussion

This happens regularly: I'm in DS 4.6 happily using G2F, mesh smoothing is working fine. I'll go to drag a slider and all of a sudden, the interface slows down (becomes momentarily unresponsive), smoothing stops working (as does clothing collision), and ctrl-Z (for undo) stops working properly. The only recourse is to quit DS and return. Is this happening for other people? I'm on Mac 10.8.4 with 16 Gb RAM...

Comments

  • VaskaniaVaskania Posts: 5,113
    edited December 1969

    Do you have interactive update on? Same section as smoothing.

  • jestmartjestmart Posts: 1,819
    edited December 1969

    You should turn smoothing off until you are ready to render, collision calculation is a processor intensive function.

  • CMacksCMacks Posts: 80
    edited December 1969

    Vaskania and jestmart, thanks for the replies. What you write probably has something to do with it, but my main point is that something is crashing (the smoothing process?) and slowing down the program, forcing me to restart DS. Before the "crash" the smoothing and collision detection is working fine. I have a fast, quad core system with lots of RAM, so my guess is there's a bug in DS4.6 that needs to be addressed. Now, if I only knew how one reports bugs nowadays...

  • Canary3dCanary3d Posts: 1,469
    edited December 1969

    I'd suggest updating your video card driver - when you're moving stuff around it's using OpenGL to draw your preview window, and if there's a memory or resource leak in your OGL driver that could cause a crash. It's one possibility, anyway.

  • CMacksCMacks Posts: 80
    edited December 1969

    Canary3d said:
    I'd suggest updating your video card driver - when you're moving stuff around it's using OpenGL to draw your preview window, and if there's a memory or resource leak in your OGL driver that could cause a crash. It's one possibility, anyway.

    Unfortunately, can't really do that on the Mac... The video driver updates get bundled in other system updates.

  • CypherFOXCypherFOX Posts: 2,368
    edited December 1969

    Greetings,
    Yes, this happens to me too. The worst part is the Undo stack getting completely hosed. :( I'm not sure the undo breakage has anything to do with Smoothing, but I have both problems separately.

    -- Morgan

  • CMacksCMacks Posts: 80
    edited December 1969

    Cypherfox said:
    Greetings,
    Yes, this happens to me too. The worst part is the Undo stack getting completely hosed. :( I'm not sure the undo breakage has anything to do with Smoothing, but I have both problems separately.

    -- Morgan

    Glad to hear I'm not hallucinating. How do we report this as a bug? I understand bugs.daz3d.com is no longer the way to go...

  • CypherFOXCypherFOX Posts: 2,368
    edited December 1969

    Greetings,
    bugs.daz3d.com redirects to the support site, and you file a support ticket to the technical support folks, I think.

    Or something like that. I've reported a few bugs, mostly crashers with the beta. Not sure if I've done it right, but it gets there eventually via the support report process.

    If you can consistently reproduce it, that's best. If it's a 'sometimes this happens' thing, it's really hard for them to prioritize it. (MPTNMI - Mysterious Problems Than Need Massive Investigations)

    -- Morgan

  • deepsixdeepsix Posts: 16
    edited December 1969

    I get this bug too but only very occasionally.

    Possibly happens when there is a lot of collision and tweaking going on but I have not tried to re-create it.

    Turning ON "Interactive Update" seems to get it working again but it makes working on things incredibly slow, and turning OFF reverts to broken.

    So if you want to get that last render done before quitting, turn Interactive Update on then render then save whatever and restart.

  • JaderailJaderail Posts: 0
    edited December 1969

    If you watch the lower right of your screen there is a collisions progress bar that will pop and run. Here is the issue, you need to STOP what you are doing until that bar runs. If you keep doing anything at all you can crash the collisions calculation engine and that can crash DAZ Studio. As noted before the fix is to turn collisions OFF until you are ready to render.

  • deepsixdeepsix Posts: 16
    edited December 1969

    Jaderail said:
    If you watch the lower right of your screen there is a collisions progress bar that will pop and run. Here is the issue, you need to STOP what you are doing until that bar runs. If you keep doing anything at all you can crash the collisions calculation engine and that can crash DAZ Studio. As noted before the fix is to turn collisions OFF until you are ready to render.

    Jaderail - sorry to not be clear previously, but in my manifestation (and I am suspecting CMacks also) there is no more progress bar, and there is no more collision calculation resulting. ie. it's died somehow. (until Interactive Update is switched on - but even then there is no progress bar still - just good/normal smoothing & collision results that appear in the camera window after a few calculation seconds)

  • JaderailJaderail Posts: 0
    edited December 1969

    Well on a good PC the calculations should run very fast so a few seconds is good. It may be a Layout issue as to why you do not get the Bar I use a custom version of City Limits. But If it is calculating fully and then Still crashes that is a issue. Even my Power PC will hang and or Slow during heavy calculations which can on my system also take a few seconds with a heavy scene loaded. But I'm not getting a Hang crash afterwards.

Sign In or Register to comment.
Rocket Fuel