Digital Art Zone

 
   
1 of 2
1
planet surface texture seam
Posted: 23 June 2012 09:58 AM   [ Ignore ]
Member
Rank
Total Posts:  43
Joined  2012-06-14

I created a sphere and added a “Venus surface” texture. The results really impressed me (I’m just beginning), but I’m curious about the seam. Is there a way to get rid of it?

The map is a rectangle, and the sphere is, well, a sphere. I assume I need to convert the map in some way?

The map in question is: http://www.max3dnn.narod.ru/textures/venus_map.jpg

Thanks!

Profile
 
 
Posted: 23 June 2012 11:27 AM   [ Ignore ]   [ # 1 ]
Member
Avatar
Rank
Total Posts:  210
Joined  2003-10-09

Try setting the mapping mode to Cylindrical - should fix the seam problem but will distort the poles.

Image Attachments
venus_cyl.jpg
Profile
 
 
Posted: 23 June 2012 12:29 PM   [ Ignore ]   [ # 2 ]
Member
Rank
Total Posts:  43
Joined  2012-06-14

Nice - I had added a cloud layer and using your suggestion really makes it pop. Thank you.

Image Attachments
venus_test2.png
Profile
 
 
Posted: 23 June 2012 06:14 PM   [ Ignore ]   [ # 3 ]
Member
Avatar
Rank
Total Posts:  210
Joined  2003-10-09

Looking good!. Glad it worked…

Profile
 
 
Posted: 24 June 2012 01:06 AM   [ Ignore ]   [ # 4 ]
Addict
Avatar
RankRankRankRank
Total Posts:  3560
Joined  2004-10-01

If you have a rectangular map with aspect ratio 2:1, this is usually a spherical projection (like a world map). You would map it Spherical around a sphere to get it without distortions and seam. Unfortunately, sometimes you get a one pixel wide equator line, which is a known and reported bug. You can use Parametric in this case, the map is offset by 90 degrees, just rotate sphere by X -90° to adjust. Cylindrical is ok, there is no seam but it is vertically distorted.


And yes, it looks good. This is the false-colour radar map of Venus, if I’m not mistaken. Here, nobody notices the distortion.

Image Attachments
mapping.jpg
 Signature 

**  [ Stuff by David Brinnen and myself**  [ My DAZ 3D Gallery**  [ My Website**  OPC 4565 **

Profile
 
 
Posted: 24 June 2012 11:58 AM   [ Ignore ]   [ # 5 ]
Member
Rank
Total Posts:  43
Joined  2012-06-14

Thanks very much. Horo - it started as Venus, but I composited Mars with it and then added a bit of water.

Since I’m not working with recognizable land masses, distortion isn’t a problem. It was the seam that was the problem. I’ve now used the cylinder for both the surface and cloud layers and am quite pleased. wink

I do seem to have another issue, this time with lighting. I used Sky Lab to place the “sun” and it seems I’m getting some extra light from somewhere (see attached).

I noticed it was there from the very beginning and I thought it was caused by the “default” light. But it seems to be more than that.

Image Attachments
my_planet_light.jpg
Profile
 
 
Posted: 24 June 2012 12:38 PM   [ Ignore ]   [ # 6 ]
Addict
Avatar
RankRankRankRank
Total Posts:  3560
Joined  2004-10-01

Make sure you have Ambient off for the material on the planet.

 Signature 

**  [ Stuff by David Brinnen and myself**  [ My DAZ 3D Gallery**  [ My Website**  OPC 4565 **

Profile
 
 
Posted: 25 June 2012 10:12 AM   [ Ignore ]   [ # 7 ]
Member
Rank
Total Posts:  43
Joined  2012-06-14

I have ambient set to “0”.

Planet surface settings are all “0” except for “DIFFUSION” which is set to 100
Cloud settings are all “0” except “DIFFUSION” (100) and “TRANSPARENCY” which I’ve set to 50 and then 100.

In the original, setting TRANSPARENT to 100 resulted in the black areas of the cloud jpg becoming transparent.
In the second attempt, setting TRANSPARENT to 100 resulted in the entire cloud jpg becoming transparent.

In the attached pic, 1 and 2 are Planet attempt1 with the cloud layer set at 50 and 100 Transparency, resp. 3 and 4 are from my Planet attempt 2 once again with Transparency set to 50 and 100 resp. The sun is in a different position and the two planet projects are at different angles, etc. but the textures should be exactly the same in each.

So why the different results?

Image Attachments
planet_diffs.jpg
Profile
 
 
Posted: 25 June 2012 11:32 AM   [ Ignore ]   [ # 8 ]
Addict
Avatar
RankRankRankRank
Total Posts:  3560
Joined  2004-10-01

Maybe the sun is set to visible - at least picture 4 looks as if it were. How about haze?

 Signature 

**  [ Stuff by David Brinnen and myself**  [ My DAZ 3D Gallery**  [ My Website**  OPC 4565 **

Profile
 
 
Posted: 25 June 2012 02:53 PM   [ Ignore ]   [ # 9 ]
Member
Rank
Total Posts:  43
Joined  2012-06-14

Yes, sun is visible - when I switch off the sun I get only a black disk - I don’t think that’s the issue.

Okay, I started from scratch again - created a new document, deleted the ground plane, changed background to starfield (turned off the stars), added a sphere, added a “Mars” texture, moved sun to some location. Results looks as I’d expect.

Added a new sphere, larger than the first. Changed texture to cloud type “Pink Mist”. The results are interesting - this should be a clue as to what’s going on I hope.

I tried “Purple Haze” instead of “Pink Mist” and the clouds go away completely. Hmm, many of the included cloud patterns don’t show - that’s weird.

Image Attachments
mars_pink.jpg
Profile
 
 
Posted: 25 June 2012 10:52 PM   [ Ignore ]   [ # 10 ]
New Member
Avatar
Total Posts:  17
Joined  2003-10-09

khobar95,

Good work!
A very nice atmosphere effect can be had by using the the settings below.
Duplicate the planet sphere and increase its size to about 101%.
Change the new sphere’s material settings to the ones shown below.
By the way,  the planet’s material is mapped in parametric mode.
Bryce isn’t too good at making very fine starfields, but that’s ok.  It’s more fun to look online and find some high resolution scans of deep space skies.  Then apply that texture to a giant sphere that encloses your planet (and camera) and light it creatively.  Or use the sun and set it to cast no shadows so that it can shine through your “space sky” sphere.

 

Image Attachments
EbenforDAZ.jpg
Profile
 
 
Posted: 26 June 2012 01:30 AM   [ Ignore ]   [ # 11 ]
Active Member
Avatar
RankRank
Total Posts:  732
Joined  2006-05-26
khobar95 - 24 June 2012 11:58 AM

Thanks very much. Horo - it started as Venus, but I composited Mars with it and then added a bit of water.

Since I’m not working with recognizable land masses, distortion isn’t a problem. It was the seam that was the problem. I’ve now used the cylinder for both the surface and cloud layers and am quite pleased. wink

I do seem to have another issue, this time with lighting. I used Sky Lab to place the “sun” and it seems I’m getting some extra light from somewhere (see attached).

I noticed it was there from the very beginning and I thought it was caused by the “default” light. But it seems to be more than that.




What you are seeing is the curvature of the sphere the clouds are drawn upon. You have created a second sphere on top of the planetary surface that is being used for clouds. It allows light to pass easily from one side to the other because it is not solid like the planet surface sphere is. So in theory what you are seeing is correct. The answer is to make the larger sphere slightly smaller. This way the planet will occlude more of the clouds from sunlight.

The real cloud layers of Earth apparently hug the surface much tighter than we imagine when building our scenes.

 Signature 

Please view my Daz3d User Gallery
http://www.daz3d.com/gallery/#users/465/

Profile
 
 
Posted: 27 June 2012 09:04 AM   [ Ignore ]   [ # 12 ]
Member
Rank
Total Posts:  43
Joined  2012-06-14

Thank you all for the comments. I very much appreciate them.

After much experimenting I believe that at least part of the problem is with how Bryce handles transparency of the second sphere, or how I telling Bryce to handle it.

For the below picture I used Earth. The cloud layer is using transparency set to 100 (otherwise I don’t see any of the planet layer beneath). Note that my cloud layer is just a NASA jpeg image downloaded from the net. There is no extra light - it’s coming from the “sun”.

Image Attachments
planet_cloud_light.jpg
Profile
 
 
Posted: 27 June 2012 09:09 AM   [ Ignore ]   [ # 13 ]
Active Member
Avatar
RankRank
Total Posts:  732
Joined  2006-05-26

I wish I was home right now, I have made planets several times and found solutions to these issues. Make sure shadow casting is enabled for the cloud sphere, and also make sure sure the clouds are not set to “additive” or “light.” I will pop in later with more info. But rest assured, what you need is possible, very possible. You will get the shading you are looking for.

 Signature 

Please view my Daz3d User Gallery
http://www.daz3d.com/gallery/#users/465/

Profile
 
 
Posted: 27 June 2012 09:43 AM   [ Ignore ]   [ # 14 ]
Member
Rank
Total Posts:  43
Joined  2012-06-14
ManOfSteel - 25 June 2012 10:52 PM

khobar95,

Good work!
A very nice atmosphere effect can be had by using the the settings below.
Duplicate the planet sphere and increase its size to about 101%.
Change the new sphere’s material settings to the ones shown below.
By the way,  the planet’s material is mapped in parametric mode.
Bryce isn’t too good at making very fine starfields, but that’s ok.  It’s more fun to look online and find some high resolution scans of deep space skies.  Then apply that texture to a giant sphere that encloses your planet (and camera) and light it creatively.  Or use the sun and set it to cast no shadows so that it can shine through your “space sky” sphere.

 

Thank you. I like the idea of the giant sphere for the space sky - interesting.

I’m getting completely different results from you using your settings. I get no visible cloud layer. ????

Are you using any material for the cloud layer?

Profile
 
 
Posted: 27 June 2012 10:08 AM   [ Ignore ]   [ # 15 ]
Member
Rank
Total Posts:  43
Joined  2012-06-14
Rashad Carter - 27 June 2012 09:09 AM

I wish I was home right now, I have made planets several times and found solutions to these issues. Make sure shadow casting is enabled for the cloud sphere, and also make sure sure the clouds are not set to “additive” or “light.” I will pop in later with more info. But rest assured, what you need is possible, very possible. You will get the shading you are looking for.

Thank you. I just hope I’m not doing something really silly. wink

Profile
 
 
   
1 of 2
1