Is something wrong with my render settings?

Wilkes AnimationsWilkes Animations Posts: 27
edited December 1969 in The Commons

Hi,

I'm rendering a scene with some lighting and the lighting fades out over distance like a light normally would. E.g the further away the light is, the fainter the light is.

However when it gets fainter it gets faint in these blocks and not in a smooth gradient. If you look at the picture hopefully it will make sense.

Many thanks for your help guys! You're constantly awesome!

Nathan

TopView_0001.jpg
1920 x 1080 - 303K

Comments

  • Wilkes AnimationsWilkes Animations Posts: 27
    edited December 1969

    P.S. Lighting is not finished yet

  • Richard HaseltineRichard Haseltine Posts: 19,956
    edited December 1969

    The banding looks like a shadow-bias issue - it may be too low, so that surfaces (sometimes) shadow themselves. Try raising the shadow bias a bit (it's an offset, in cm, so don't go overboard or items will seem to float). If you are using depth-mapped shadows switching to ray-traced will probably help - the resolution of DSMs is fixed and is too low for large environments.

  • LycanthropeXLycanthropeX Posts: 2,202
    edited December 1969

    it helps if you tell us what program you are using. Just for future reference when asking a question, include if you are using Studio, Poser, Carrara, Bryce etc, that way the community can better answer your question. Some times a fix for Studio won't be the same for Poser etc

    anyway, Richard is probably right, so give that a try

  • SzarkSzark Posts: 8,796
    edited July 2013

    If this is Daz Studio I am guessing it could be the shading rate, what is it set to. 1.00? If that is the case drop it down to 0.20.

    Yes it could also be Sahdow Bias. I find a value of 0.10 works for the most part.

    Post edited by Szark on
  • Wilkes AnimationsWilkes Animations Posts: 27
    edited December 1969

    The banding looks like a shadow-bias issue - it may be too low, so that surfaces (sometimes) shadow themselves. Try raising the shadow bias a bit (it's an offset, in cm, so don't go overboard or items will seem to float). If you are using depth-mapped shadows switching to ray-traced will probably help - the resolution of DSMs is fixed and is too low for large environments.

    Cheers Richard! Yeah I've done it and it's worked pretty well, just gotta make sure once I put the other lights in that it doesn't mess it up! Thanks!

  • Wilkes AnimationsWilkes Animations Posts: 27
    edited December 1969

    Szark said:
    If this is Daz Studio I am guessing it could be the shading rate, what is it set to. 1.00? If that is the case drop it down to 0.20.

    Yes it could also be Sahdow Bias. I find a value of 0.10 works for the most part.

    It's poser and the shading rate is already at 0

  • Richard HaseltineRichard Haseltine Posts: 19,956
    edited December 1969

    Szark said:
    If this is Daz Studio I am guessing it could be the shading rate, what is it set to. 1.00? If that is the case drop it down to 0.20.

    Yes it could also be Sahdow Bias. I find a value of 0.10 works for the most part.

    It's poser and the shading rate is already at 0

    In Poser you can edit the resolution of shadow maps, they are a parameter on the light. That won't affect the banding but it can help the smoothness of shadow edges.

Sign In or Register to comment.
Rocket Fuel