Digital Art Zone

 
   
5 of 5
5
List of Shader Mixer Tutorials and Recipes WIP please be patient as I update the list…thanks!
Posted: 23 January 2014 03:31 PM   [ Ignore ]   [ # 61 ]
Active Member
Avatar
RankRank
Total Posts:  965
Joined  2005-03-26

My current challenge (if anyone can solve it) is to tile an image’s Alpha channel when loaded with a PNG.  No success so far.  Any suggestions or help would be appreciated.

 Signature 

My dA gallery
For God’s sake!  Gallifrey Stands!

And God still reigns.

Profile
 
 
Posted: 23 January 2014 04:58 PM   [ Ignore ]   [ # 62 ]
Administrator
Avatar
RankRankRankRank
Total Posts:  13943
Joined  2003-10-09

If you are wanting to tile the alpha differently from the main image I think you’d need two image bricks, and feed different s,t values to each.

 Signature 

DAZ Studio Frequently Asked Questions

Index of free DAZ Studio scripts and plugins list

Profile
 
 
Posted: 23 January 2014 05:27 PM   [ Ignore ]   [ # 63 ]
Active Member
Avatar
RankRank
Total Posts:  965
Joined  2005-03-26

That’s just it:  I want it to tile at all.  No matter what I’ve tried, including sending it into other S/T tileable bricks (Checkers, et cetera), teh Alpha channel refuses to tile.  I was hoping to do lace and lattices with single, tileable PNGs, but absolutely nothing induces the alpha channels to tile.  I can halve, triple, or rotate the color channels and the alpha stays obstinately put!

 Signature 

My dA gallery
For God’s sake!  Gallifrey Stands!

And God still reigns.

Profile
 
 
Posted: 23 January 2014 05:36 PM   [ Ignore ]   [ # 64 ]
Active Member
Avatar
RankRank
Total Posts:  904
Joined  2007-01-04

The problem Richard is that the Alpha output from an Image brick doesn’t tile, the S & T only works on the color output.


X-Post

 Signature 

**shuffles of with a new headache** tongue wink

Profile
 
 
Posted: 23 January 2014 06:01 PM   [ Ignore ]   [ # 65 ]
Member
Rank
Total Posts:  209
Joined  2012-07-28

It tiles if you plug image alpha into surface brick opacity, not material brick opacity. Well, sort off, there was image at the middle and tiled ones together, like its displaying both tiled and non tiled image.

But you can ignore image alpha. Plug in image color into both diffuse and opacity color of material brick and it should work with alpha channel .png. Besides, if you put .png with alpha channel into opacity strength channel of the DAZ studio default shader (surface) it will work for tiling and opacity.

Edit: Hmm, it looks like alpha channel from.png I used was treated in DS as black color. If i put it in diffuse color, what is invisible renders black, which in opacity strength, ofc, renders invisible.

Profile
 
 
Posted: 24 January 2014 08:09 AM   [ Ignore ]   [ # 66 ]
Active Member
Avatar
RankRank
Total Posts:  965
Joined  2005-03-26

Let me try one or two of those solutions:  I was hoping to make it work out of just one node, but if I can’t, I’ll see what improvements I can undertake.

 Signature 

My dA gallery
For God’s sake!  Gallifrey Stands!

And God still reigns.

Profile
 
 
Posted: 24 January 2014 08:57 AM   [ Ignore ]   [ # 67 ]
Administrator
Avatar
RankRankRankRank
Total Posts:  13943
Joined  2003-10-09

That sounds like a bug report waiting to happen, then - I would expect the alpha to tile as the image tiled unless overridden.

 Signature 

DAZ Studio Frequently Asked Questions

Index of free DAZ Studio scripts and plugins list

Profile
 
 
Posted: 24 January 2014 09:27 AM   [ Ignore ]   [ # 68 ]
Member
Rank
Total Posts:  209
Joined  2012-07-28

I was playing some more with setup on the image. It depends on how the .png was made. There are 2 options when .png with alpha channel is exported from Gimp, Save background color and Save color values for transparent pixels. If those are active and deleted color was white, than it doesnt work, its not transparent. If those are active and deleted color was black, than it works, its transparent. If those are not active, than it works with white color being deleted as well and it works with that image in opacity strength of standard DS shader.

Image Attachments
Clip2.jpg
Profile
 
 
Posted: 24 January 2014 09:57 AM   [ Ignore ]   [ # 69 ]
Active Member
Avatar
RankRank
Total Posts:  965
Joined  2005-03-26

I’ve been using PNG-saved renders straight from DS4.

 Signature 

My dA gallery
For God’s sake!  Gallifrey Stands!

And God still reigns.

Profile
 
 
Posted: 16 February 2014 09:50 AM   [ Ignore ]   [ # 70 ]
New Member
Total Posts:  2
Joined  2008-04-16

Hi,

it seems “forumarchive…” is offline for days now.
Does somebody know if the information of the mentioned thread:

“Global illumination thread contains many different recipes (In my opinion the best thread I have found so far.)”
http://forumarchive.daz3d.com/viewtopic.php?t=114436&start=0&postdays=0&postorder=asc&highlight;=&sid=96d5eb909871445f0cb10923b2c07ebe

Is available somewhere else?

By the way I am new to DS but used to Poser and Lightwave.

Thanks for help.

Profile
 
 
Posted: 21 February 2014 08:19 PM   [ Ignore ]   [ # 71 ]
Power Member
Avatar
RankRankRank
Total Posts:  2228
Joined  2005-09-05
madno - 16 February 2014 09:50 AM

Hi,

it seems “forumarchive…” is offline for days now.
Does somebody know if the information of the mentioned thread:

“Global illumination thread contains many different recipes (In my opinion the best thread I have found so far.)”
http://forumarchive.daz3d.com/viewtopic.php?t=114436&start=0&postdays=0&postorder=asc&highlight;=&sid=96d5eb909871445f0cb10923b2c07ebe

Is available somewhere else?

By the way I am new to DS but used to Poser and Lightwave.

Thanks for help.

I thought I had sent parts of it to onenote but unfortunately can’t locate them so looks like I didn’t. I had planned on writing proper tutorials for parts of that thread just haven’t had chance to get to it. I hope DAZ gets the archived forum back up…

 Signature 

Shadermixer tutorials and recipes
My ShareCG Gallery
Shadermixer Documents

Profile
 
 
Posted: 22 February 2014 01:34 AM   [ Ignore ]   [ # 72 ]
Active Member
Avatar
RankRank
Total Posts:  965
Joined  2005-03-26

I sent in the bug report, along with screencaptures.  I haven’t heard back since they acknowledged that last note, though.  It’s been a couple of weeks.

Who, me? Impatient?  Well, um ... actually yes.  I am.
(The settings shown in the shader screenshot do not reflect all settings tested.)

Image Attachments
Problem_#0.jpgProblem_#3.jpgProblem_#1.jpg
 Signature 

My dA gallery
For God’s sake!  Gallifrey Stands!

And God still reigns.

Profile
 
 
   
5 of 5
5