Digital Art Zone

 
     
Smoother crashing Daz
Posted: 19 June 2012 02:05 AM   [ Ignore ]
Active Member
RankRank
Total Posts:  334
Joined  2011-12-14

I’ve mentioned this on the newbies thread, but it might be more appropriate here, as this is specific to Daz.
When I start the smoothing/collision option on clothes the progress bar stays at zero, then the program vanishes as if it’s been shut down with no warning. Up until now I’ve used smoothing with these items with no problem, this trouble just started out of the blue the other day.

On one occasion a bug report box appeared, when I tried to save it I got a “Not Responding” message and then the bug box crashed.

Can anyone help me?

Profile
 
 
Posted: 19 June 2012 02:42 AM   [ Ignore ]   [ # 1 ]
Active Member
Avatar
RankRank
Total Posts:  479
Joined  2010-06-18

Haven’t seen your other posts on this…but let’s get started with some info first wink

What’s your system specs and OS and DS version your using?

Are these Genesis Clothes, Auto-Fitted Gen4, or is this on Gen4 Clothes on a Gen4 figure?

Have you tried with other clothing?

How many scene items do you have Smoothing applied to?

Have you change any of the settings in the Mesh Smoothing parameters since the last time it did work?

Is Interactive Update turned on in the Mesh Smoothing parameters? if so turn it off and try again

When DS crashes did you check to see if there was still a DS process running?

This info will help others in trying to solve your problem

Profile
 
 
Posted: 19 June 2012 03:14 AM   [ Ignore ]   [ # 2 ]
Active Member
RankRank
Total Posts:  334
Joined  2011-12-14

Ok, I’ll try my best to answer your questions (but I’m not very good with the more technical stuff).

I’m using windows vista on an old laptop with a mere 2 gb ram (not much for this sort of software I know, but it’s managed ok with it up to now, though struggles at times).

Daz version 4.0.3.19 standard 32 bit.  I’d rather not have to install another version if at all possible. I don’t think my poor old computer could handle any more features.

The figure is the normal genesis that came with Daz, the item hasbeen autofitted and was intended for M4. I think I’ve used smoothnig on this item before without trouble (though I’m not sure). There was only one item being smoothed.

I don’t think I’ve altered settings in smoothing, but don’t know how to check this without activating the smoothing and therefore crashing Daz.

I’ve never turned on interactive update as I don’t really know what it does.

I’ve just tried smoothing with a different item on genesis (a V4 autofitted jacket) and it worked fine. Could this be an item specific problem, I wonder? If so, is there some way of finding out/fixing it?

Profile
 
 
Posted: 19 June 2012 03:28 AM   [ Ignore ]   [ # 3 ]
Active Member
RankRank
Total Posts:  334
Joined  2011-12-14

Quick update. Tried another M4 item and smoothing. But the figure and the item both vanished, although DAZ didn’t crash. According to the scene tab the figure and item are both still there, but for some reason they’ve turned invisible.

Profile
 
 
Posted: 19 June 2012 03:44 AM   [ Ignore ]   [ # 4 ]
Active Member
Avatar
RankRank
Total Posts:  479
Joined  2010-06-18

Ok that should help alot…let’s see…


Well first off 2 gb of ram is just about the bare minimum and smoothing does use processor cycles and ram to perform the calculations.

Also .19 is an older version, the last version for DS4 is 4.0.3.47 but I do understand were your coming from. I don’t recall what bugs were in .19 though.


Yes you would need to be able to apply smoothing in order to adjust any of the settings and if its crashing upon adding the modifier I would think that you are running out of system resources before it can complete the process (someone correct me if I’m mistaken smile )


It could also be the particular item your using. If it has a high poly count that could cause your computer to run out of resources to perform the smoothing calculations. You can check this by changing your viewport view to wire shaded.


Since it worked on a different clothes item, try any others you have and see if they work or not. Could just be that one item.


BTW what item is it? If I have it I could check it out… raspberry

Profile
 
 
Posted: 19 June 2012 03:46 AM   [ Ignore ]   [ # 5 ]
Active Member
Avatar
RankRank
Total Posts:  479
Joined  2010-06-18
SteveM17 - 19 June 2012 03:28 AM

Quick update. Tried another M4 item and smoothing. But the figure and the item both vanished, although DAZ didn’t crash. According to the scene tab the figure and item are both still there, but for some reason they’ve turned invisible.


That’s weird… big surprise


Haven’t had that happen before…

Profile
 
 
Posted: 19 June 2012 03:55 AM   [ Ignore ]   [ # 6 ]
Active Member
Avatar
RankRank
Total Posts:  479
Joined  2010-06-18

Try turning their visibility off and back on in the scene tab ( the little eye icon) and see if they re-appear


Or switch to a different view port, I don’t know which layout you are using so it may not be available.

Profile
 
 
Posted: 19 June 2012 04:28 AM   [ Ignore ]   [ # 7 ]
Active Member
RankRank
Total Posts:  334
Joined  2011-12-14

The item is a trench coat for M4 by Sickle Yield, which I probably got from ShareCG or Renderosity, as that’s where I’ve got most of my stuff. It autofits onto Genesis just fine, the little progress bar at the bottom zooms along no problem. But after the initial fit, any extra smoothing I attemp is halted and Daz crashes.

As for resources, I attempted the smoothing and kept an eye on windows task manager, the CPU usage (if that’s the right thing to look at) varied between 50% to 95%. But that has often been the case when using Daz, in fact I’m sure many times it’s been at 100% without crashing, just taking it’s time instead. To see if my resources are having trouble i tried a quick render: one figure, two props, three lights (one of which was casting deep mapped shadows) at detail level two (open gl with shadows, a fairly basic setting and the one I usually use). The render worked OK, and took about fourteen seconds. Does this mean my resources are OK?

I noticed in task manager that under processes it say “67”. I have absolutely no idea if that makes a diference or not.

Profile
 
 
Posted: 19 June 2012 07:42 AM   [ Ignore ]   [ # 8 ]
Power Member
Avatar
RankRankRank
Total Posts:  1308
Joined  2006-03-14

Which version of DS4 are you using?  There were some “known issues” with Smoothing and several of SickleYield’s items. This issue was fixed in the 4.5.x line.

 Signature 

My Tutorials and Freebies Index

Profile
 
 
Posted: 19 June 2012 12:42 PM   [ Ignore ]   [ # 9 ]
Power Member
Avatar
RankRankRank
Total Posts:  1308
Joined  2006-03-14

CORRECTION:  I just re-read the bug report after Richard prompted me.  This is not fixed in 4.5.x as it was determined to be a mesh issue, not an issue with the Smoothing Modifier process.

 Signature 

My Tutorials and Freebies Index

Profile
 
 
Posted: 20 June 2012 02:06 AM   [ Ignore ]   [ # 10 ]
Active Member
RankRank
Total Posts:  334
Joined  2011-12-14

I’m using Daz version 4.0.3.19 standard 32 bit.

If this is an item related problem, then that will not be a problem, I just won’t use smoothing on it. As long as smoothing/collsion works on other stuff, I can always find an altrnative. It’s a shame about the trench coat, though, because apart from the smoothing issue it’s a very good freebie. Is there a list of “problem” items anywhere?

Profile