RuntimeError: Bad magic number in .pyc file in talk designer

zananeichanzananeichan Posts: 0
edited June 2012 in New Users

I get a RuntimeError: Bad magic number in .pyc file in talk designer http://www.daz3d.com/shop/talk-designer-assistant-for-poser-8/ , which i just got from the shop today and it does not work... or do i need to use an older version of poser ?

Untitled.png
1366 x 768 - 698K
Post edited by zananeichan on

Comments

  • Richard HaseltineRichard Haseltine Posts: 19,889
    edited December 1969

    Unfortunately the latest version of Poser uses an updated Python engine, and as a result compiled Python scripts (.pyc) aren't running, with the Magic Number error. With luck all that's needed is a recompile from the original script, though I believe some scripts need more work than that; in any event if you've only just purchased and downloaded that obviously isn't yet done. I would suggest opening a support ticket, asking if there's a status update, and if need be asking for a refund.

  • zananeichanzananeichan Posts: 0
    edited December 1969

    Unfortunately the latest version of Poser uses an updated Python engine, and as a result compiled Python scripts (.pyc) aren't running, with the Magic Number error. With luck all that's needed is a recompile from the original script, though I believe some scripts need more work than that; in any event if you've only just purchased and downloaded that obviously isn't yet done. I would suggest opening a support ticket, asking if there's a status update, and if need be asking for a refund.

    Thank you very much for the message, how would I recompile the scripts to fix the error ? Yes i purchased it two days ago and downloaded it, how would i open a support ticket ?

  • Richard HaseltineRichard Haseltine Posts: 19,889
    edited December 1969

    Recompiling needs the original code, so it has to be done by the author.


    To open a ticket, click on Contact Us under help at the top of this page.

  • zananeichanzananeichan Posts: 0
    edited December 1969

    Recompiling needs the original code, so it has to be done by the author.


    To open a ticket, click on Contact Us under help at the top of this page.

    O.k Thank you, since |I have DAZ studio as well, can talking be done as well ?

  • Richard HaseltineRichard Haseltine Posts: 19,889
    edited December 1969

    Yes, though you need to have the 32 bit version of DS installed (the LipSync plugin doesn't work in 64 bit, fortunately you can have both 32 and 64 bit versions installed on the same machine). LipSync works from a recoding, as I recall, while Talk Designer works from a transcript - but I'm not certain of that.

  • zananeichanzananeichan Posts: 0
    edited December 1969

    Thank you very much, i have not heard any response from the creator of talk designer http://www.daz3d.com/shop/talk-designer-assistant-for-poser-8/ why dont you have it built in DAZ ? since the whole idea is to animate , and talking is very much part of humanoid entities.

  • gadgytman2011gadgytman2011 Posts: 42
    edited July 10

    Richard Haseltine said:

    Unfortunately the latest version of Poser uses an updated Python engine, and as a result compiled Python scripts (.pyc) aren't running, with the Magic Number error. With luck all that's needed is a recompile from the original script, though I believe some scripts need more work than that; in any event if you've only just purchased and downloaded that obviously isn't yet done. I would suggest opening a support ticket, asking if there's a status update, and if need be asking for a refund.

    Ok Will have the same problem with the origonal "talk designer' I use Poser 10  Will "Talk designer assistan 2" have the same issue?  I use M4's and V4's, but I want to know if it will work before spending $50

    Edited to fix quote

    Post edited by Richard Haseltine on
  • Richard HaseltineRichard Haseltine Posts: 19,889

    Richard Haseltine said:

    Unfortunately the latest version of Poser uses an updated Python engine, and as a result compiled Python scripts (.pyc) aren't running, with the Magic Number error. With luck all that's needed is a recompile from the original script, though I believe some scripts need more work than that; in any event if you've only just purchased and downloaded that obviously isn't yet done. I would suggest opening a support ticket, asking if there's a status update, and if need be asking for a refund.

    Ok Will have the same problem with the origonal "talk designer' I use Poser 10  Will "Talk designer assistan 2" have the same issue?  I use M4's and V4's, but I want to know if it will work before spending $50

    Edited to fix quote

    I don't know - I can't recall if verion 9 to version 10 caused this issue or if it was an older update only.

Sign In or Register to comment.
Rocket Fuel