Digital Art Zone

 
   
2 of 18
2
Luxus Skin Settings
Posted: 20 April 2013 09:39 PM   [ Ignore ]   [ # 16 ]
Active Member
Avatar
RankRank
Total Posts:  649
Joined  2006-11-10

I’ll run a test and see what results I get. The discrepancy is just odd.

 Signature 

Old post count: 3,394,206

Profile
 
 
Posted: 20 April 2013 11:25 PM   [ Ignore ]   [ # 17 ]
Member
Avatar
Rank
Total Posts:  180
Joined  2005-06-23

Biggest issue I’ve had with skin is trying to get better results than Luxus is getting auto-converting anything using UberSurface2. So far I haven’t been able to do that on my own even after searching for clues through multiple .lxs files. I haven’t spent a whole lot of time messing with the skin settings as I’ve been getting pretty good auto-conversions out of the box and most of my time has been concentrating on lights.

Here are a couple of very quick and very dirty test renders (I only ran them up to 10 S/p)
All settings are the same between all three tests. Texture set is elite Ariana
1st one is a Luxus auto-convert
2nd uses Slosh’s settings as given above
3rd one is the best I’ve done on my own using a mix manually applied Luxus materials (Glossy Translucent, Volume, Copy DS settings) and info I’ve gleaned from auto-converted .lxs files
I’m not very happy with it but here are the values I used
LuxRender Glossy Translucent - Diffuse Color: 255-255-255 (Diffuse Map)
LuxRender Glossy Translucent - Transmission Color: 255-255-255
LuxRender Glossy Translucent - Specular Color: 143-176-186 (Specular Map)
LuxRender Glossy Translucent - Specular IOR: 1.4
LuxRender Glossy Translucent - Specular Roughness U: 0.8
LuxRender Glossy Translucent - Specular Roughness V: 0.8
LuxRender Glossy Translucent - Absorption Color: 0-0-0
LuxRender Glossy Translucent - Absorption Depth: 0
LuxRender Glossy Translucent - Multibounce: On
LuxRender Glossy Translucent - One Sided: On
LuxRender Volume Type: Homogenous
LuxRender Volume - Refractive Index: 1.3
LuxRender Volume - Absorption Color: 23-123-255
LuxRender Volume - Absorption Scale: 2250
LuxRender Volume - Scattering Color: 64-52-45
LuxRender Volume - Scattering Scale: 4
LuxRender Mesh - Bumpmap: 1 (Bump Map)

4th pic is a finished render using Luxus auto-conversions (same as in #1 except film response is different) 525S/p

Image Attachments
ArianaCU2Test0.jpgArianaCU2Test1.jpgArianaCU2Test2.jpgArianaCU525.jpg
 Signature 

http://www.daz3d.com/shop/inaneglory

Profile
 
 
Posted: 20 April 2013 11:59 PM   [ Ignore ]   [ # 18 ]
Active Member
Avatar
RankRank
Total Posts:  649
Joined  2006-11-10

This is what I have after a few minutes. -scratches head-

Image Attachments
test.png
 Signature 

Old post count: 3,394,206

Profile
 
 
Posted: 21 April 2013 01:41 AM   [ Ignore ]   [ # 19 ]
Power Member
Avatar
RankRankRank
Total Posts:  1472
Joined  2005-03-16

This is just crazy!  I can’t understand how NO ONE has been able to duplicate my results.  Just as a suggestion, can someone try it where you reduce the Glossy-Translucent Absorption scale to 0.6 and the Volume Absorption and Volume Scatter to 100?  I have used this adjustment with some of my less “Freaky” models and it gleans better results.

Otherwise, or additionally, I am going to post my scene file to ShareCG.  Go ahead and download it and give it a try.  Just make sure that you make the adjustments to the Tone Mapping area in LuxRender.  I already have permission to share the scene file since it only references items that should already be in your runtime.  If you don’t have Andrei for Freak 5, DS will ask you to search for the textures.  Just choose a texture in your runtime as a replacement.  Also, if you don’t have Freak 5, it won’t work.

Eagerly awaiting updates….

Here is the link to the scene file:  Luxus Skin by Slosh at ShareCG.

 Signature 

My DAZ Store Page  UVSetterGen2  Free Video Tutorials    My FreeStuff at ShareCG    My Gallery on DeviantArt

Profile
 
 
Posted: 21 April 2013 02:01 AM   [ Ignore ]   [ # 20 ]
Power Member
Avatar
RankRankRank
Total Posts:  1472
Joined  2005-03-16

The problem is clearly with my PC.  I couldn’t recreate Hellboy’s python guy results, and I had really bad results using InaneGlory’s settings.  In each case, I got horribly pale, dry skin and really big displacement and bump.  I wonder what is different about my computer?  I installed the No OpenCL version of LuxRender because my video card is inferior.  What do the rest of you have?

Below is my results using InaneGlory’s custom settings.  I do see some problem, IG, with your settings that could help.  Mainly, the use of pure white and pure black in your diffuse channel and your Glossy-Trans absorption.  You will get a more fleshy appearance if you use the absorption setting.  Try a medium blue, or slightly darker but not lighter.  Lighter colors render darker and vice versa.  What I do is pick a flesh color that I like, say 255:203:170 and I subtract each value from 255.  So, I would use 0:152:185 as my absorption color.  The Abs. depth should be realistic to the size of your figure.  Like stated before in this thread, the scale goes 1 = 1 meter, or 3 feet.  The body is approximately 1/3 of that size, plus a little more.  So, setting the scale to around .34 or .38 will do nicely.  As for anything you want to use white for (like your diffuse channel) just lower it a bit, like maybe 225:225:225.  This will still keep your texture map colors, but will keep them from blowing out and being too bright when the lights hit.  Lastly, Your scattering scale is way to low in relation to your absorption scale in the volume settings.  The scattering color should be something redder, since this is the color that will scatter below the skin and is usually reddish because of the blood and muscles under your skin.  If you make these adjustments, I think you will see better results.

Oh yeah, and your bump setting is way to high.  Try something more along the lines of .002.

Image Attachments
d48.png
 Signature 

My DAZ Store Page  UVSetterGen2  Free Video Tutorials    My FreeStuff at ShareCG    My Gallery on DeviantArt

Profile
 
 
Posted: 21 April 2013 02:33 AM   [ Ignore ]   [ # 21 ]
Power Member
Avatar
RankRankRank
Total Posts:  1472
Joined  2005-03-16

I re-rendered the previous image with InaneGlory’s settings, but tweaked them with the suggestions I gave.  Here are the actual values I changed and the reasons for it.

LuxRender Glossy Translucent - Diffuse Color: 255-255-255 (Diffuse Map)
(I changed to 225:225:225)
LuxRender Glossy Translucent - Transmission Color: 255-255-255
LuxRender Glossy Translucent - Specular Color: 143-176-186 (Specular Map)
LuxRender Glossy Translucent - Specular IOR: 1.4
(changed to 1.45, more accurate for skin)
LuxRender Glossy Translucent - Specular Roughness U: 0.8
(changed to 0.4, to make shinier)
LuxRender Glossy Translucent - Specular Roughness V: 0.8
(changed to 0.4, to make shinier)
LuxRender Glossy Translucent - Absorption Color: 0-0-0
(changed to 0:50:71 for fleshier color.  Yours was actually orange)
LuxRender Glossy Translucent - Absorption Depth: 0
(changed to 0.38)
LuxRender Glossy Translucent - Multibounce: On
LuxRender Glossy Translucent - One Sided: On
LuxRender Volume Type: Homogenous
LuxRender Volume - Refractive Index: 1.3
(changed to 1.45 for human skin)
LuxRender Volume - Absorption Color: 23-123-255
(changed to 23:94:122, a fleshier color)
LuxRender Volume - Absorption Scale: 2250
(left the same)
LuxRender Volume - Scattering Color: 64-52-45
(changed to 128:64:0, which is redder, but still brown)
LuxRender Volume - Scattering Scale: 4
(changed to 100 to penetrate deeper into the large volume of 2250)
LuxRender Mesh - Bumpmap: 1 (Bump Map)
(changed to .002, Lux overdoes the transferred bump)

I feel a little odd about offering suggestions now, since it seems obvious that what clearly works for me, clearly does not work for ANYONE else.  I don’t know what to say.  Maybe we can all discover it here, together.  I will have to rethink my suggestions.

I don’t suppose anyone else who has posted here would like to send me their scene file, so I can see what their settings look like on my pc?  I have all of the Gen5 figures and most of the textures that came with the bundles.  I truly hope someone will take me up on it.  I will give you my personal email address if you PM me and you can send me your scene files.

Image Attachments
d59.png
 Signature 

My DAZ Store Page  UVSetterGen2  Free Video Tutorials    My FreeStuff at ShareCG    My Gallery on DeviantArt

Profile
 
 
Posted: 21 April 2013 02:48 AM   [ Ignore ]   [ # 22 ]
Member
Rank
Total Posts:  141
Joined  0
InaneGlory - 20 April 2013 11:25 PM

Biggest issue I’ve had with skin is trying to get better results than Luxus is getting auto-converting anything using UberSurface2. So far I haven’t been able to do that on my own even after searching for clues through multiple .lxs files. I haven’t spent a whole lot of time messing with the skin settings as I’ve been getting pretty good auto-conversions out of the box and most of my time has been concentrating on lights.

Here are a couple of very quick and very dirty test renders (I only ran them up to 10 S/p)
All settings are the same between all three tests. Texture set is elite Ariana
1st one is a Luxus auto-convert
2nd uses Slosh’s settings as given above
3rd one is the best I’ve done on my own using a mix manually applied Luxus materials (Glossy Translucent, Volume, Copy DS settings) and info I’ve gleaned from auto-converted .lxs files
I’m not very happy with it but here are the values I used
LuxRender Glossy Translucent - Diffuse Color: 255-255-255 (Diffuse Map)
LuxRender Glossy Translucent - Transmission Color: 255-255-255
LuxRender Glossy Translucent - Specular Color: 143-176-186 (Specular Map)
LuxRender Glossy Translucent - Specular IOR: 1.4
LuxRender Glossy Translucent - Specular Roughness U: 0.8
LuxRender Glossy Translucent - Specular Roughness V: 0.8
LuxRender Glossy Translucent - Absorption Color: 0-0-0
LuxRender Glossy Translucent - Absorption Depth: 0
LuxRender Glossy Translucent - Multibounce: On
LuxRender Glossy Translucent - One Sided: On
LuxRender Volume Type: Homogenous
LuxRender Volume - Refractive Index: 1.3
LuxRender Volume - Absorption Color: 23-123-255
LuxRender Volume - Absorption Scale: 2250
LuxRender Volume - Scattering Color: 64-52-45
LuxRender Volume - Scattering Scale: 4
LuxRender Mesh - Bumpmap: 1 (Bump Map)

4th pic is a finished render using Luxus auto-conversions (same as in #1 except film response is different) 525S/p

Couple of things I’ve found from my experiments:

Try darkening the diffuse to about [200 200 200] or [160 180 200] depending how pink the skin is - the glossy translucent material is energy conservative, so only lets through what doesn’t bounce off from specular and diffuse - and put the diffuse map in the translucent channel too.

Specular roughness needs to be 0.3-0.6 usually - 0.8 is heading to ‘super matte’ regions.

Volume absorption colour component of 255 means theres no absorption of that component - dropping it to 250 will put some absorption in.

Absorption scale - try values around 250-500, similar for scattering scale.

Scattering colour - a good red/orange has worked for me, again it depends on the skin map colours to some extent. Maybe [255 200 150]

Bump scale - as Slosh notes, this is in meters so a value of about 1-2mm is what’s needed.

Hope this helps some ...

Profile
 
 
Posted: 21 April 2013 02:55 AM   [ Ignore ]   [ # 23 ]
Active Member
Avatar
RankRank
Total Posts:  279
Joined  2012-03-02

Currently testing out some of these settings, mucho thanks Slosh. Just a side note it explains on the LUX wiki that you should use a multi volume integrator not single for heavy scattering.

 Signature 

http://michaelg1234.deviantart.com/

Noob with a big heart.

Profile
 
 
Posted: 21 April 2013 03:08 AM   [ Ignore ]   [ # 24 ]
Power Member
Avatar
RankRankRank
Total Posts:  1472
Joined  2005-03-16
Michael_G - 21 April 2013 02:55 AM

Currently testing out some of these settings, mucho thanks Slosh. Just a side note it explains on the LUX wiki that you should use a multi volume integrator not single for heavy scattering.

Thanks, Michael.  I do have multi volume selected on my setup, hopefully the others do as well.  Maybe we will find that to be the culprit in this mystery!

Edit:  Nope.  Just tried changing to “single” and it still renders the same for me.

 Signature 

My DAZ Store Page  UVSetterGen2  Free Video Tutorials    My FreeStuff at ShareCG    My Gallery on DeviantArt

Profile
 
 
Posted: 21 April 2013 03:59 AM   [ Ignore ]   [ # 25 ]
Active Member
Avatar
RankRank
Total Posts:  279
Joined  2012-03-02

This is what im working on right now, the texture seams are bugging the crap out of me.

Image Attachments
dublin.jpg
 Signature 

http://michaelg1234.deviantart.com/

Noob with a big heart.

Profile
 
 
Posted: 21 April 2013 04:54 AM   [ Ignore ]   [ # 26 ]
Active Member
Avatar
RankRank
Total Posts:  729
Joined  2010-12-10

This is probably a noob question, but since messing with lux glossy transparent settings, I’ve lost the UV skin/eyebrows. I’m just using skinface as a test area.

Originally I had a glass2 geoshell with the opacity turned right down, but since I’ve tried messing with the Genesis skin settings, my foot has gotten a lot closer to the monitor - arghhh.

Don’t know if you already know this Michael_G, But Sperical suggested to me in another thread to put subdivision up to 2, with regards to seams.

All I’ve produced so far using a mixture of suggested settings is:

 

Image Attachments
image-LuxSkin.png
 Signature 

My Gallery at Daz 3D
My Forum Thread

Profile
 
 
Posted: 21 April 2013 04:56 AM   [ Ignore ]   [ # 27 ]
Power Member
Avatar
RankRankRank
Total Posts:  1337
Joined  2009-01-09
InaneGlory - 20 April 2013 05:20 PM

Glossy Translucent Absorption Color and Volume Absorption Color shouldn’t be the same exact color. The first one is for light bouncing off the skin, the second for light penetrating the skin.

OK, now I’m very confused. If those colors aren’t supposed to be the same, then how do you know what should be what?

According to the information at the Luxrender wiki:

(Volumes) Absorption color: ... The absorption color determines how light is lost as it passes through the volume. This defines an attenuation rate, meaning that the color will be become more dark and saturated the farther it travels through the volume. It also means that this color control will seem to work “backwards”. If you specify the raw absorption color as red, it will remove red light, leaving you with a cyan volume….

(Glossy Translucent) Absorption Color/Depth: ... These allow you to specify the color and depth of light absorbtion by the surface coating. Note that since this is an absorption color, it will seem to work “backwards”. Setting it to blue will cause blue light to be absorbed, leaving you with a yellow-orange appearance. To defeat this option, set the color to full black (0.0). This parameter is not related to volume absorption….

According to that explanation, although they very technically do different things—reflected versus absorbed/passed-through light, although both address it in terms of what gets absorbed—they seem to require the same settings.

 Signature 

VWrangler at deviantArt (NSFW for some images; login required to view those)

Profile
 
 
Posted: 21 April 2013 05:01 AM   [ Ignore ]   [ # 28 ]
Power Member
Avatar
RankRankRank
Total Posts:  1472
Joined  2005-03-16
none01ohone - 21 April 2013 04:54 AM

This is probably a noob question, but since messing with lux glossy transparent settings, I’ve lost the UV skin/eyebrows. I’m just using skinface as a test area.

Originally I had a glass2 geoshell with the opacity turned right down, but since I’ve tried messing with the Genesis skin settings, my foot has gotten a lot closer to the monitor - arghhh.

Don’t know if you already know this Michael_G, But Sperical suggested to me in another thread to put subdivision up to 2, with regards to seams.

All I’ve produced so far using a mixture of suggested settings is:

Most likely your glossy translucent absorption scale is too high.  If you go too high, it’s like the translucent part (I think of it as an epidermis over your texture) is so thick, you can’t see the details underneath.  Like coating it with wax.  try lowering it to somewhere between .3 and .4.  I’ve gone as high as .7, which gives a very deep tan to my characters.

 Signature 

My DAZ Store Page  UVSetterGen2  Free Video Tutorials    My FreeStuff at ShareCG    My Gallery on DeviantArt

Profile
 
 
Posted: 21 April 2013 05:04 AM   [ Ignore ]   [ # 29 ]
Power Member
Avatar
RankRankRank
Total Posts:  1472
Joined  2005-03-16
Michael_G - 21 April 2013 03:59 AM

This is what im working on right now, the texture seams are bugging the crap out of me.

Do you have displacement activated?  I’ve run into the problem where the edges of the texture get displaced, especially if the original .jpg is surrounded by white.  Either lower the displacement or perhaps modify the .jpg to bleed the skin color outside of the borders or replace the white entirely with flesh tones.

 Signature 

My DAZ Store Page  UVSetterGen2  Free Video Tutorials    My FreeStuff at ShareCG    My Gallery on DeviantArt

Profile
 
 
Posted: 21 April 2013 05:05 AM   [ Ignore ]   [ # 30 ]
Active Member
Avatar
RankRank
Total Posts:  279
Joined  2012-03-02
Slosh - 21 April 2013 05:04 AM
Michael_G - 21 April 2013 03:59 AM

This is what im working on right now, the texture seams are bugging the crap out of me.

Do you have displacement activated?  I’ve run into the problem where the edges of the texture get displaced, especially if the original .jpg is surrounded by white.  Either lower the displacement or perhaps modify the .jpg to bleed the skin color outside of the borders or replace the white entirely with flesh tones.

Nope, I have custom made normal maps and all have the same settings when i created them.

 Signature 

http://michaelg1234.deviantart.com/

Noob with a big heart.

Profile
 
 
   
2 of 18
2