Digital Art Zone

 
     
How to download products I purchased?
Posted: 16 April 2013 11:06 PM   [ Ignore ]
Member
Rank
Total Posts:  120
Joined  2012-07-02

Hi,

After being away for a while, I tried to get back to this and got to my account to download products I purchased back in February.
First of all the layout of the pages are changed, secondly, maybe I am missing something, or everything….  I cannot find the download button of the stuffs/  I got to My Orders page and was only able to view the items, the easy-to-use click-and-download buttons are gone!

Then I went to Product Library, yes they are listing the items by Name, but I can only view page 1 of it, clicking and other pages or the Purchase Date button does not do anything for me.  So I can only view and download my purchases of items beginning with the letter A for One single page?

I missed the old school of downloading, but, well….  anybody please me wht should I do to download my items purchased 2 months ago?

Chris

Profile
 
 
Posted: 16 April 2013 11:25 PM   [ Ignore ]   [ # 1 ]
Administrator
Avatar
RankRankRankRank
Total Posts:  8548
Joined  2007-11-06

Try with a different browser, or download using the Install Manager.

 Signature 

PostgreSQL CMS FAQ

Product Updates: Non-Genesis/G2 DIM Zips starting July 2013
Non-Genesis Items with Metadata
Plugin Version Numbers for DS 4.5
Updated Genesis Products

Profile
 
 
Posted: 17 April 2013 12:14 AM   [ Ignore ]   [ # 2 ]
Member
Rank
Total Posts:  120
Joined  2012-07-02

Is the Install Manager inside the Daz Studio 4?  I am rendering at the moment, will check later, but I have a bad feeling about it, because nothing regarding the content library works since day 2, I wonder…

So where can I find this button for the Install Manager?

I tried closing and logging in again with other browsers, do not work.  Downloading used to be so easy, why changed it?

Profile
 
 
Posted: 17 April 2013 01:47 AM   [ Ignore ]   [ # 3 ]
Addict
Avatar
RankRankRankRank
Total Posts:  5509
Joined  2005-08-29

Download install Manager here: http://www.daz3d.com/install-manager-info

 Signature 

=============================================
My DAZ Gallery  | The adventures of Lomund
Free RPG adventures for DnD, O:FR and more: http://4eyes.code66.se
Community Volunteer

Proud member of the Bald Wizards Club
I always look on the bright side of life, ‘cause I never expected the Spanish inquisition!

Profile
 
 
Posted: 17 April 2013 02:41 AM   [ Ignore ]   [ # 4 ]
Administrator
Avatar
RankRankRankRank
Total Posts:  15746
Joined  2003-10-09

Some people have found that clearing their Browser cache will sort things out for them.  It is only a tiny minority of people who are experiencing this glitch.

If you still cannot clear the log jam do please file a support ticket to Tech support and they will get back in touch with you to try sort this out.

 Signature 

Chohole’s Space        Neil’Vs Freebies and stuff        L Summer Bryce Rendering Challenge        August Freebie Challenge
My DAZ 3D Gallery    11915

Profile
 
 
Posted: 17 April 2013 06:04 AM   [ Ignore ]   [ # 5 ]
Active Member
Avatar
RankRank
Total Posts:  822
Joined  2008-09-17

Also, make sure you do not have Javascript disabled; as the list on the Product Library page is generated by Javascript.

 Signature 

Resistance is futile.  You will be DAZzimilated


Old post count: 5719

Profile
 
 
Posted: 18 April 2013 12:37 PM   [ Ignore ]   [ # 6 ]
Member
Rank
Total Posts:  120
Joined  2012-07-02

Thanks. I installed the Install Manager, and downloaded.

Profile