Digital Art Zone

 
     
Uber Area Lights… invisible in renderyet still emit light?
Posted: 24 March 2013 03:31 PM   [ Ignore ]
Addict
Avatar
RankRankRankRank
Total Posts:  2673
Joined  2011-12-10

Is that possible to do?  Make the Area Light invisible in the render yet still have it’s light emitted?

 Signature 

My DeviantArt Galleries
My ShareCG Gallery
OPENSUBDIV Testing and Discussion
3Delight Surface and Lighting Thread

Profile
 
 
Posted: 24 March 2013 04:15 PM   [ Ignore ]   [ # 1 ]
Administrator
Avatar
RankRankRankRank
Total Posts:  15659
Joined  2003-10-09

Works for me, either with the Visible property or by setting the surface’s opacity colour to black.

 Signature 

DAZ Studio Frequently Asked Questions

Index of free DAZ Studio scripts and plugins list

Profile
 
 
Posted: 24 March 2013 04:32 PM   [ Ignore ]   [ # 2 ]
Member
Rank
Total Posts:  175
Joined  2012-08-07

Also in the surface parameters for the area light, if you turn on Fantom it will be visible in the scene but not the render.

Profile
 
 
Posted: 27 March 2013 11:39 PM   [ Ignore ]   [ # 3 ]
Member
Rank
Total Posts:  98
Joined  2006-02-02

just turn opacity to 0

Profile
 
 
Posted: 28 March 2013 06:03 AM   [ Ignore ]   [ # 4 ]
Addict
Avatar
RankRankRankRank
Total Posts:  8309
Joined  2009-05-14
bluemoon - 24 March 2013 04:32 PM

Also in the surface parameters for the area light, if you turn on Fantom it will be visible in the scene but not the render.

And the student become the teacher…love it. wink  Yep the old Fathom command, exactly. No need to mess about with other stuff. smile

 Signature 

Pete

Somethings to Consider when starting to learn CG

My Gallery

My Render Thread and Tutorials

Proud member of the Bald Wizards Club and Co-operative

Facebook

Profile
 
 
Posted: 27 May 2013 06:49 AM   [ Ignore ]   [ # 5 ]
Member
Avatar
Rank
Total Posts:  173
Joined  2003-10-09

I’ve been working a lot with area lights, and struggling with this exact issue.  Well, not exactly.  I got the object to be invisible, but then realized it was showing up in reflections.

Some things I have found

1. setting visible in render to off disables the light
2. Setting visible to off disables the light
3. Setting Ambient on significantly increases increases reflectivity of the object
4. Turning Fantom ON hides the object but does not hide its reflection
5. Turning Raytrace off hides the reflection (in an earlier test I somehow though it also disabled the light, but this result was not repeated)
6. Turning Fantom On and Raytrace Off completely hides the object and does not seem to affect the quality nor quantity of the light cast (though an earlier test seemed to suggest it did)
7. Setting Opacity color to black effectively hides the object and its reflections
8. Option 6 renders faster
9. Turning Raytrace off seems to affect the quantity of light generated when rendered with an indirect light camera set to Illuminance Sample Mode but not with UE2 set to GI Bounce, or an indirect light camera set to Light Source Sample Mode (point 9 is in question, requires more testing. It seems possible that 2D VS 3D area lights react differently under these circumstances)

 

Profile