Digital Art Zone

 
     
DAZ Studio: Framing Part of a Scene
Posted: 10 June 2012 10:01 PM   [ Ignore ]
Member
Avatar
Rank
Total Posts:  96
Joined  2003-10-09

Hi,

In DAZ Studio, is there a way of framing a part of the scene, so that the contents of the frame fill the scene ?

I am asking this because I have tried clicking the head and then clicking the Camera:Frame control, but that only centers the head and does not fill the scene with the head.

I am also asking because I know you can use the Camera:Zoom and Camera:Pan to move in on the desired part of the scene, but this is a lot of mucking around and I am looking for a quicker way.

Thanks,
Andrew

Profile
 
 
Posted: 11 June 2012 01:31 AM   [ Ignore ]   [ # 1 ]
Addict
RankRankRankRank
Total Posts:  3261
Joined  2007-06-22

If you click on the square camera control icon this will focus and zoom in on the part/item selected.

Image Attachments
viewDS4.jpg
Profile
 
 
Posted: 11 June 2012 02:17 AM   [ Ignore ]   [ # 2 ]
Member
Avatar
Rank
Total Posts:  96
Joined  2003-10-09

As I have already said, this does not work very well on the head.

Profile
 
 
Posted: 11 June 2012 04:56 AM   [ Ignore ]   [ # 3 ]
Administrator
Avatar
RankRankRankRank
Total Posts:  14430
Joined  2003-10-09

How badly is it working? I won’t zoom all the way in so that the item touches the edges of the aspect frame (which is the determining factor - if your render is set to be landscape in a portrait viewport then the frame will leave a lot of space top and bottom, and a fair bit to the sides) but it should and usually does dolly in so that the long side of the bounding box fits into the short side of the aspect frame.

 Signature 

DAZ Studio Frequently Asked Questions

Index of free DAZ Studio scripts and plugins list

Profile
 
 
Posted: 11 June 2012 10:33 AM   [ Ignore ]   [ # 4 ]
Power Member
Avatar
RankRankRank
Total Posts:  1441
Joined  2006-07-04

Also, was that a left click or a right?  One just aims the camera at the object, the other aims and zooms (don’t have DS open at the moment to check which one’s which.)

 Signature 

DAZ Gallery * * *DA Gallery

Profile
 
 
Posted: 11 June 2012 10:38 AM   [ Ignore ]   [ # 5 ]
Administrator
Avatar
RankRankRankRank
Total Posts:  16477
Joined  2009-01-22

For me left click Zooms in DS3A and DS4Pro. Right click frames only.

 Signature 

Exile, Drows Walk: A Tale of Jaderail starts here. Free pulp fiction at its Fantasy best, Updated 2/3/14.
Proud Member of the Bald Wizards Club My stuff at DeviantArt

Profile
 
 
Posted: 11 June 2012 03:42 PM   [ Ignore ]   [ # 6 ]
Member
Avatar
Rank
Total Posts:  96
Joined  2003-10-09

Sorry, but I don’t follow what anybody is saying.
The attached image is what I end up with when I left-click the head and then click Camera:Frame.

Image Attachments
DAZ_Studio_4.jpg
Profile
 
 
Posted: 11 June 2012 04:02 PM   [ Ignore ]   [ # 7 ]
Administrator
Avatar
RankRankRankRank
Total Posts:  16477
Joined  2009-01-22

What version are you running? Mine is DS4Pro v 4.0.3.47 I have not tried DS4.5, I need my Expensive plugins.

 Signature 

Exile, Drows Walk: A Tale of Jaderail starts here. Free pulp fiction at its Fantasy best, Updated 2/3/14.
Proud Member of the Bald Wizards Club My stuff at DeviantArt

Profile
 
 
Posted: 11 June 2012 04:09 PM   [ Ignore ]   [ # 8 ]
Administrator
Avatar
RankRankRankRank
Total Posts:  14430
Joined  2003-10-09

It should be tighter than that, certainly - unless you have a very narrow or low aspect frame. What are your current render dimensions?

 Signature 

DAZ Studio Frequently Asked Questions

Index of free DAZ Studio scripts and plugins list

Profile
 
 
Posted: 11 June 2012 04:10 PM   [ Ignore ]   [ # 9 ]
Power Member
Avatar
RankRankRank
Total Posts:  1441
Joined  2006-07-04

You’re taking the right steps.

I did some experimenting, and I can replicate your situation, I think.  If I’m right, one or both of these should help:

1) click on those little lines up there by “Perspective view”.  That should bring up a menu.  See if “Show Aspect Frame” is checked.  If not, check it.  This will allow you to see the area of your view port that will actually render.  The camera may be more “zoomed in” than it appears.

2) Look on your Render Settings tab, and see what your rendering dimensions are.  There are several presets available, or you can use custom to create a final render of your desired size.  A Portrait orientation (taller than wide) will zoom in closer to the head than a landscape orientation (wider than tall)

 Signature 

DAZ Gallery * * *DA Gallery

Profile
 
 
Posted: 11 June 2012 04:23 PM   [ Ignore ]   [ # 10 ]
Member
Avatar
Rank
Total Posts:  96
Joined  2003-10-09

Render Dimensions are “custom”. I could not find out how to get the specific figures.
Attached is what I get when turning on the Aspect Frame.

Image Attachments
DAZ_Studio_4.jpg
Profile
 
 
Posted: 11 June 2012 04:31 PM   [ Ignore ]   [ # 11 ]
Power Member
Avatar
RankRankRank
Total Posts:  1441
Joined  2006-07-04
mathman - 11 June 2012 04:23 PM

Render Dimensions are “custom”. I could not find out how to get the specific figures.
Attached is what I get when turning on the Aspect Frame.

That’s what I thought.  Your aspect frame is wide, which makes it appear that it’s not zooming in as far as you want.

 

If you look at the aspect frame, Genesis’ head is filling up most (though not all) of the space between the top and the bottom of the frame.

 

I’ve attached a screen shot of my own, using the active viewport (I know it says custom) with an arrow pointing to where you can type in the desired Render size.

Image Attachments
Adjust_image_here.jpg
 Signature 

DAZ Gallery * * *DA Gallery

Profile
 
 
Posted: 11 June 2012 07:18 PM   [ Ignore ]   [ # 12 ]
Power Member
Avatar
RankRankRank
Total Posts:  1040
Joined  2003-10-09

Once I’ve selected whatever it is that I want to be in the center, I left-click the frame button. Then I use the mousewheel to zoom in a little bit.

Profile
 
 
Posted: 12 June 2012 04:07 AM   [ Ignore ]   [ # 13 ]
Active Member
Avatar
RankRank
Total Posts:  658
Joined  2006-09-30

You could try selecting both eyes, then clicking the zoomy thing.


That should bring you in closer.


Apart from that - manually adjusting it is your best bet (either that or render oversized and crop in post work?).

 

 Signature 

MOO!

Profile