UV Mapping in Hex Question

FeralFeyFeralFey Posts: 2,761
edited December 1969 in Hexagon Discussion

Hey All,

I'm having an issue and I can't figure out what I'm doing wrong.

I've built numerous models in Hex and I UV map them there, but inevitably the UV map is "off" when I go to texture the map in Photoshop. If I don't compensate by filling areas outside of where I've mapped, then my model has gaps in the texture and shows the untextured grey background of my UV map when I bring it into DS. It's not very pretty, obviously, and I'd like to figure out if I'm missing something in the settings (or elsewhere) that would make the UV map actual BE spot on and not require any Photoshop contortions to get it to work.

Is there something I'm missing? If so, would one of you kind folk let me know what it is?

Thanks, in advance.


  • ds-mail_2e0cb9c256ds-mail_2e0cb9c256 Posts: 70
    edited December 1969

    Have you looked at the UV map on screen in Hex before exporting and know the UV mesh is not overlapping itself or it is distorted or not? There is a "relaxing" tool (and other tools) to adjust the map to see how it lays on the image (usually square like 1024x1024) that you paint on in Photoshop?

    Best to read up on the help file for Hex on looking at and "adjusting" the UV map before export. I am no expert so can't help more, but have done a few and it takes a few tries to learn the ins and outs of UV mapping....play with it.

  • FeralFeyFeralFey Posts: 2,761
    edited December 1969

    Hey, thanks, Doug for responding.

    Yeah, I always check the map before I export the obj, and am pretty good about making sure that the mesh isn't on top of itself before I export the map/obj. I haven't played much with the "relax" tool, so I'm not entirely sure what it does. But I am well versed in the "disassociate UV" tool.

    What the problem is is that the UV map is off by 10 pixels on the sides and significantly more either front or back (never at the same time), when I make the texture in photoshop. I was just wondering if there was a setting somewhere that I didn't know about that would fix this "drift" problem.

    I guess I'll just play a little deeper with the UV mapping tools and see if I can find something that will help. Or at the very least develop a better understanding of what the tools do. Lol.


  • RoygeeRoygee Posts: 2,220
    edited December 1969

    If you are using the map directly out of Hex, do yourself a favour and get hold of the free UV Mapper Classic. Import your UV mapped model into that and export the UV template to use in photoshop - you will have more control over the dimensions of the template - the only reason I can think of that you may have "drift" is that you are exporting the low-resolution template from Hex and expanding it in Photoshop.

  • stem_athomestem_athome Posts: 350
    edited December 1969

    The last time (which is quite a while ago) I made some texture maps to go on a model in Daz Studio, I was having the same issue. At that time, it was a problem with DS not the UV mapping (the texture maps where OK in other renderer's).

  • edited December 1969

    I'd have to see what the map looks like in Hexagon and in Photoshop to know more.

  • patience55patience55 Posts: 6,981
    edited December 1969

    Yes there does seem to be something just a little quirky with the uvmap, at least sometimes.

    I took one into Corel's PSP tonight, made a duplicate layer, cleared that and added the background colour.
    Noticed that the top layer had a very narrow white border on one side and on the bottom edge. That could certainly be what's throwing if off that pixel or two for precision texturing.

Sign In or Register to comment.