Digital Art Zone

 
     
Indirect light in Carrara 8 Pro
Posted: 17 February 2013 10:35 AM   [ Ignore ]
Member
Rank
Total Posts:  27
Joined  2008-07-12

Hello,

I have Carrara 8 Pro and am trying to render an animation with Indirect light. I have an i7 and four render nodes (i5). I tried several settings (Irradiance map settings, better quality for GI, etc.). However, rendering the animation always results in a “flickering situation”. In each frame, the indirect light bounces off differently resulting in a strange scene; it’s just like in a room with damaged light sources. Any idea?

Regards,
Thomas

Profile
 
 
Posted: 17 February 2013 10:42 AM   [ Ignore ]   [ # 1 ]
Power Member
Avatar
RankRankRank
Total Posts:  1694
Joined  0

Have you turned off Interpolation?

I saw there was a listing in the bug tracker that using a saved IRRADIANCE MAP function is not working, but I do not know the details…

 Signature 

320+ TUTORIALS for Carrara at CARRARA CAFE
C3DE - CARRARA 3D EXPO MAGAZINE - the showcase for Carrara Artists

Profile
 
 
Posted: 17 February 2013 10:45 AM   [ Ignore ]   [ # 2 ]
Member
Rank
Total Posts:  27
Joined  2008-07-12

Hello, thank you for your post. Yes, I have turned off “Interpolation.” It didn’t change anything.

Profile
 
 
Posted: 17 February 2013 11:20 AM   [ Ignore ]   [ # 3 ]
Addict
Avatar
RankRankRankRank
Total Posts:  5178
Joined  2006-08-27

You may not want to hear this, but turn of IL for animations. Learning how to set up a light rig to simulate GI is well worth the effort from both a skill set perspective and a render speed perspective. PIXAR and all the other CG studios don’t use it. They simulate it. That being said, if it’s a bug, then it should be corrected.

 Signature 

I find it somewhat liberating not to be encumbered by accuracy.

Profile
 
 
Posted: 17 February 2013 12:21 PM   [ Ignore ]   [ # 4 ]
New Member
Total Posts:  13
Joined  2010-02-05

My Daughter is having a “Pixar Movie Marathon” Birthday party and I was creating this, for fun.
http://dl.dropbox.com/u/15568105/PixarLamp_LPG_BDay2.mov
I think I am having the same issue you describe as well.  It was working well before I had IL turned on.

Profile
 
 
Posted: 17 February 2013 02:49 PM   [ Ignore ]   [ # 5 ]
Member
Avatar
Rank
Total Posts:  160
Joined  2008-12-02

                  Evilproducer is pretty on target with that advice for animations. Now Short ones like yours would be fine if that bug gets squashed , but I have almost always tried to work around it for longer animations as the time to render can be prohibitive. That said———yes it does look nice but with IL but in Carrara there has always been a price of long renders with it. Sometimes if you really need it to look a certain way you just have to pay the price . But maybe bring a few I7’s to the party. Smiles

Rich

 Signature 

Rich

Favorite items   Cararra   - Modo -    Animation Master-    Houdini

Profile
 
 
Posted: 17 February 2013 06:27 PM   [ Ignore ]   [ # 6 ]
Member
Rank
Total Posts:  27
Joined  2008-07-12

Hi,

Here is a low-res picture.
https://www.dropbox.com/s/4kz82s157f2epjg/file_animation.jpg

I wasn’t able to reproduce the result without IL. So, I would like to create the animation with IL smile

Profile
 
 
Posted: 18 February 2013 07:12 AM   [ Ignore ]   [ # 7 ]
New Member
Total Posts:  18
Joined  2005-04-02

The saved IR map is only useful for flythrough scenes where only the camera moves like architectural promos.
If you have animated objects then you will need to use direct lighting as EvilProducer said.

However….
There is a halfway house you could try which I found quiet effective.
Do a high res full GI beauty render with just the set and not the (moving) characters, then project this onto the set as a shadow catcher.
Turn down the quality for the GI and render your animated characters over the top, when I did this a few years ago I had to use Shader Plus from DCG, but maybe Daz has changed the camera mapping / shadow catching / GI since then.
Or create light rigs for each character as in regular studio animation techniques and render with direct light.
I found rendering the background out at two up gave nice crisp results.
Always use the lowest quality settings you can get away with.

Personally I’m using Blender more and more because of its CUDA support and render times at 10% of Cararras with my GPU.

Profile
 
 
Posted: 19 February 2013 01:33 PM   [ Ignore ]   [ # 8 ]
Member
Rank
Total Posts:  27
Joined  2008-07-12

Hello,

It’s the problem gillisgraphics has with its animation. In another animation with a moving character, I used an irradiance map and it worked fine (no flickering). There were some shadow problems though, but with a little effort in After Effects, it turned out to be fine. However, for this animation I have, even an irradiance map for static scenes produces flickering :(

Render time isn’t a problem. It takes for HD almost 2 days, but that’s ok.

Thanks for your efforts woodscreation, I tried multipass and other approaches but wasn’t able to find a solution that suits my needs :( / frankly speaking, it just HAVE TO WORK. What’s the point anyway?

Regards,
Thomas

Profile