Digital Art Zone

 
     
Poser help needed!
Posted: 15 February 2013 06:17 AM   [ Ignore ]
Power Member
Avatar
RankRankRank
Total Posts:  1873
Joined  0

Hi folks. I usually don’t post here, just lurk, but I have a friend who is having a problem with Poser. It is a pretty common thing I hear, so maybe some Poser expert can give us a resolve.

I do know, this issue was addressed a few years ago and a few clicks cleared up the problem, but I can’t remember how or who posted it, so here we go:

How do you fix the flipped normal problem in Poser when you import an .obj file. Over half the model is transparent. I know there is a way to do it, but I can’t remember. Any help would be greatly appreciated by many I am sure.

Anyone?

grin

Image Attachments
64Galaxie1.jpg
 Signature 

I am not this way because I am a musician, I am a musician because I am this way.

old posts: 10,322 Daz member since Build 1

Freebie Challenge Rules! - http://www.daz3d.com/forums/viewthread/286/

Profile
 
 
Posted: 15 February 2013 06:34 AM   [ Ignore ]   [ # 1 ]
Member
Avatar
Rank
Total Posts:  241
Joined  2003-10-09

Poser has a Render setting to Remove Backfacing Polys but that’s not a solution to the import problem.

 Signature 
Profile
 
 
Posted: 15 February 2013 07:47 AM   [ Ignore ]   [ # 2 ]
Addict
Avatar
RankRankRankRank
Total Posts:  2532
Joined  2004-04-25

Go into the materials room and check to see that the “make normals forward” box is checked. 

 Signature 

“...not world enough nor time…” 

Profile
 
 
Posted: 15 February 2013 12:57 PM   [ Ignore ]   [ # 3 ]
Member
Avatar
Rank
Total Posts:  241
Joined  2003-10-09
icprncss - 15 February 2013 07:47 AM

Go into the materials room and check to see that the “make normals forward” box is checked. 

That only works for rendering, the mesh still has reversed polys, that’s what is needed to correct.

 Signature 
Profile
 
 
Posted: 15 February 2013 01:44 PM   [ Ignore ]   [ # 4 ]
Addict
Avatar
RankRankRankRank
Total Posts:  2693
Joined  2009-02-24

I usually solve the problem by importing the model into a modeling application like 3D Studio and exporting it without normals. That way the polys are all double-sided and therefore are always facing the right direction regardless.

 Signature 

Find me on DeviantArt
Download my free IBL presets for Luxus
Re-upload of Cresent’s awesome pwToon shaders
Create your own Smart Content

Profile
 
 
Posted: 15 February 2013 01:55 PM   [ Ignore ]   [ # 5 ]
Addict
Avatar
RankRankRankRank
Total Posts:  2532
Joined  2004-04-25

Try importing the model into Poseray and then exporting it back out again. 

https://sites.google.com/site/poseray/

UVmapper Pro can fix normals as well.

 Signature 

“...not world enough nor time…” 

Profile
 
 
Posted: 15 February 2013 02:09 PM   [ Ignore ]   [ # 6 ]
Active Member
Avatar
RankRank
Total Posts:  615
Joined  2008-07-16

If I’m not mistaken that model comes from 3D warehouse. It looked like a SketchUp issue… Lots of people who are great modeler don’t understand the flipped normals in SU.
Open the model up in SU… Go to View> Face Style> Monochrome… You’ll see that the parts of your model that are Blueish-purple are the same parts that are reversed in Poser.
There are two ways of fixing this…. The best is to flip them manually, You will have to choose- View> Hidden Geometry and then go into the various groups that make up the model and flip the normals to the WHITE side facing out… (the problem is the part may not be “painted” on the other side)... you flip the normals by Choosing- Edit> Face (or Surfaces)> Reverse faces.
There is a script that tries to figure out what faces are flipped improperly and tries to fix it… it may be OrientFaces.rb, but I forget… Go to SketchUcation and look around in the plugins index at the plugins forum…
I have to run now, I’ll try and check back tonight and see if there is something better out there… Good luck.

Image Attachments
Picture_1.png
 Signature 

VISIT MY ShareCG FREEBIE GALLERY

Profile
 
 
Posted: 15 February 2013 02:56 PM   [ Ignore ]   [ # 7 ]
Active Member
Avatar
RankRank
Total Posts:  615
Joined  2008-07-16

There is this- Automatic Face Reverser:

http://sketchucation.com/forums/viewtopic.php?t=5333

I can’t really try it out now but I figured I’d give you a Heads up on it…

 Signature 

VISIT MY ShareCG FREEBIE GALLERY

Profile
 
 
Posted: 15 February 2013 09:37 PM   [ Ignore ]   [ # 8 ]
Power Member
Avatar
RankRankRank
Total Posts:  1873
Joined  0
lordvicore - 15 February 2013 02:09 PM

If I’m not mistaken that model comes from 3D warehouse. It looked like a SketchUp issue… Lots of people who are great modeler don’t understand the flipped normals in SU.
Open the model up in SU… Go to View> Face Style> Monochrome… You’ll see that the parts of your model that are Blueish-purple are the same parts that are reversed in Poser.
There are two ways of fixing this…. The best is to flip them manually, You will have to choose- View> Hidden Geometry and then go into the various groups that make up the model and flip the normals to the WHITE side facing out… (the problem is the part may not be “painted” on the other side)... you flip the normals by Choosing- Edit> Face (or Surfaces)> Reverse faces.
There is a script that tries to figure out what faces are flipped improperly and tries to fix it… it may be OrientFaces.rb, but I forget… Go to SketchUcation and look around in the plugins index at the plugins forum…
I have to run now, I’ll try and check back tonight and see if there is something better out there… Good luck.

I do alot of Sketchup modeling. There are tons of models with this problem. Beginners especially. They think,click, ooooo color and go with that. It works fine for SU but it won’t work when exporting. There are two sides like you said, a white one and a bluish one. Each will take a color or texture. The side that is white will dominate when exported. You also will get a surface called “Font” which will always be white. Sometimes the entire model. These are the flipped normals with the wrong side (bluish) one textured or colored. Will stay white.

One way to resolve this is to use grouping. If you make a flat plane, select it, go to edit, make group. The entire plane will then select with edges. Now texture or color it and it will export with that color or texture on both sides everytime. I group everything. Make a room, make a wall plane, cut your window or door way, now group it. Now pull out the wall for thickness. Now texture it all one color, OR, go to edit, edit group, open the group up and color inside wall part, and use a brick texture on the outside wall part. click the group off and it will hold the color and bricks in place. It can get complicated, but gets easy after you learn how to work with groups…also you can group something, like a table leg, then go to edit, copy, paste into place, and it will duplicate the leg on top of the other one, then just use the arrows on your keyboard to move them side to side or up and down. This makes a precise placement. I do this for tires on cars, you can even flip the tire in edit also.

The person who made this car must have either converted it from a .3ds file or .obj file and just didn’t know about grouping correctly. I have made hundreds of models in SU and never had a single complaint on import of the .obj files from any program user. This is the key…grouping!

Daz Studio 3.1 import and rendered:

 

 

Image Attachments
64Galaxie500_1.jpg
 Signature 

I am not this way because I am a musician, I am a musician because I am this way.

old posts: 10,322 Daz member since Build 1

Freebie Challenge Rules! - http://www.daz3d.com/forums/viewthread/286/

Profile
 
 
Posted: 15 February 2013 10:12 PM   [ Ignore ]   [ # 9 ]
Active Member
Avatar
RankRank
Total Posts:  615
Joined  2008-07-16

I was going to mention that, when you look at the model in person it appears to be a conversion issue (probably 3ds)... I tried using a couple of the plugins for face orientation and none of them really worked on this model… they would reverse some of the faces, but most remained unchanged… The original model was great, but if you look close there are lots of little gaps and stray faces here and there… but still, as is its not bad.
I forgot to mention it but, I think the reversed face transparency thing in Poser only really shows up in preview… I think it only really becomes a problem with advanced materials and image based textures where you can see the texture is reversed… like lettering. I think most simple materials render okay in Poser…
Here is another face reverser (this one by TIG) for SU if you ever need it… http://sketchucation.com/forums/viewtopic.php?t=30107

 Signature 

VISIT MY ShareCG FREEBIE GALLERY

Profile
 
 
Posted: 16 February 2013 05:27 AM   [ Ignore ]   [ # 10 ]
Power Member
Avatar
RankRankRank
Total Posts:  1873
Joined  0

I get the disappearing faces in my icon when I make a .pp2 file, but the model itself always comes up full when opened in Daz Studio, so I have never really worried about it. I just don’t do that much in Poser because it crashes everytime I try to load a character or more than one prop. So, I use it mainly for converting .obj files to .pp2 files.

grin

 Signature 

I am not this way because I am a musician, I am a musician because I am this way.

old posts: 10,322 Daz member since Build 1

Freebie Challenge Rules! - http://www.daz3d.com/forums/viewthread/286/

Profile
 
 
Posted: 16 February 2013 05:58 AM   [ Ignore ]   [ # 11 ]
Member
Avatar
Rank
Total Posts:  241
Joined  2003-10-09
music2u4u - 15 February 2013 06:17 AM

Hi folks. I usually don’t post here, just lurk, but I have a friend who is having a problem with Poser. It is a pretty common thing I hear, so maybe some Poser expert can give us a resolve.

I do know, this issue was addressed a few years ago and a few clicks cleared up the problem, but I can’t remember how or who posted it, so here we go:

How do you fix the flipped normal problem in Poser when you import an .obj file. Over half the model is transparent. I know there is a way to do it, but I can’t remember. Any help would be greatly appreciated by many I am sure.

Anyone?

grin

Maybe no one is still at DAZ now that remembers that thread. I’ve searched through the old forums but haven’t located it yet.

 Signature 
Profile
 
 
Posted: 16 February 2013 07:09 AM   [ Ignore ]   [ # 12 ]
Active Member
Avatar
RankRank
Total Posts:  822
Joined  2008-09-17

Got into the Material room & on the Poser surface node; click the Normals Forward checkbox.

Image Attachments
Image1.jpg
 Signature 

Resistance is futile.  You will be DAZzimilated


Old post count: 5719

Profile
 
 
Posted: 16 February 2013 07:16 AM   [ Ignore ]   [ # 13 ]
Member
Avatar
Rank
Total Posts:  241
Joined  2003-10-09
BWSman - 16 February 2013 07:09 AM

Got into the Material room & on the Poser surface node; click the Normals Forward checkbox.

I mentioned that in a message above. That isn’t a fix, it’s a work around.

 Signature 
Profile
 
 
Posted: 16 February 2013 07:33 AM   [ Ignore ]   [ # 14 ]
Member
Rank
Total Posts:  190
Joined  2003-10-09

In the render settings, select the Preview tab, then UNCHECK Remove Backfacing polygons. That will show the backfacing polygons
Alternatively in the group editor, you can select the group which contains the backfacing polygons and then select Reverse Group Normals. This will only work however if the entire group has reversed normals.

Profile