Preventing Morphing During Animation?

SuperGJSuperGJ Posts: 0
edited December 1969 in Daz Studio Discussion

Hello all,

I was curious, is there a way to somehow eliminate morphs from an animation? As it is now, I have a bunch of animations that I made as templates which I would like to apply to various different characters. However, when I do this, the initial beginning frame of animation is fine and has the appropriate character morphs, but each subsequent frame after that the morphs change gradually (so if the base template was of a male, and I am applying it to a female character, the female character gradually morphs into a male character over the course of the animation). I've tried copying the initial character shape and pasting it in the later keyframes, but it doesn't help.

Is there a way to prevent this morphing from occurring without having to manually redo every single animation for every single character?

Any help, tips, hints, and so forth is greatly appreciated.

Thanks!

Comments

  • wancowwancow Posts: 2,708
    edited February 2013

    okay, here's what you do with what you have now.

    Save the animation as a POSE PRESET.

    Set the ANIMATION RANGE to what it needs to be

    There is a little box icon on the right side just under the second animation range field.

    Click on this

    UNCHECK ALL

    Then click on it again

    CHECK ONLY ROTATIONS

    Save your pose preset.

    Apply that pose preset to your character in a new file.

    This should solve the issue.

    Post edited by wancow on
  • Herald of FireHerald of Fire Posts: 3,384
    edited December 1969

    Wouldn't it be easier to export the animation as a BVH and then just use that to animate your new characters?

  • wancowwancow Posts: 2,708
    edited December 1969

    OH: one more thing.

    IF you have used POSE CONTROLS, those will not be checked with rotations.

    You should go to the properties in the dialog and manually check those pose controls you have used.

  • SuperGJSuperGJ Posts: 0
    edited December 1969

    Thanks for the replies, I will give this a shot! Thanks very much :-)

  • SuperGJSuperGJ Posts: 0
    edited December 1969

    Hmm, ok so I followed the steps exactly as you laid them out. I unchecked everything and then went and manually selected only the rotation portions (and a couple of translations since I adjusted that for a few frames), and the Pose Controls. I then opened up one of my pre-existing characters and applied the newly saved pose to it. The same issue came up, where the figure gradually morphed from female to male. It's rather frustrating.

  • wancowwancow Posts: 2,708
    edited December 1969

    SuperGJ, give me a little bit to figure out what I put down wrong... :)

    I promis to have an answer for you shortly.

  • wancowwancow Posts: 2,708
    edited February 2013

    Okay, so I screwed up. But I did figure it out.

    Basically, you need to go to your TIMELINE tab. Set it up if you do not have it available.

    Look for keyframes on the timeline.

    The likelyhood is that your morph is keyed to a single frame and simply moving up. You need to find that frame where that morph arrives at 1. (or 100%), and zero that out.

    I just tried it... I'm pretty sure this is the solution... let me know.

    Oh, by the way, Shaping Morphs do NOT save to a Pose File in DS 4.5.1.56. So if you save your character to a Character Preset or Scene Subset, and call it up new, you shouldn't be having this issue.

    Post edited by wancow on
  • SuperGJSuperGJ Posts: 0
    edited December 1969

    Alright, that seems to have fixed it. I appreciate all the help Wancow :) Thanks!

  • wancowwancow Posts: 2,708
    edited December 1969

    No problem. I actually learned some things I didn't know from your question.

Sign In or Register to comment.
Rocket Fuel