Digital Art Zone

 
     
daz 4.5.1.6 pro 64 memory usage on Win 7 64
Posted: 05 January 2013 12:23 PM   [ Ignore ]
Member
Rank
Total Posts:  52
Joined  2009-07-12

I have daz 4.5.1.6 pro 64 memory usage on Win 7 64 but it doesn’t seem to want to use more than a few gigs of ram.  I have 8GB installed. and DAZ performance, I’d have thought, would improve with more memory.

I’ve run memtest and it scans all 8gb with no errors.  Vista detects all 8gb and calls 7.85 useable (I assume this is normal; some is used for addressing and so forth.)

proc is a i5-2450

Is there a trick to make DAZ page less and keep more in ram?

Profile
 
 
Posted: 05 January 2013 01:43 PM   [ Ignore ]   [ # 1 ]
Administrator
Avatar
RankRankRankRank
Total Posts:  14435
Joined  2003-10-09

DS won’t use memory for the sake of it - the amount it uses, when manipulating the scene, will reflect the geometry you have loaded and the number of textures (but it doesn’t use the full textures, depending on your settings for the preview). You will probably see a jump when you start rendering, but again it won’t just grab memory it doesn’t need for the scene it is being asked to render.

 Signature 

DAZ Studio Frequently Asked Questions

Index of free DAZ Studio scripts and plugins list

Profile
 
 
Posted: 05 January 2013 01:50 PM   [ Ignore ]   [ # 2 ]
Administrator
Avatar
RankRankRankRank
Total Posts:  16477
Joined  2009-01-22

As Richard states many things go into what it will use. Geom, textures and texture size, lighting used, Shadow setting and render Settings, then the Render size also comes into acoount. My largest render on a much the Same PC only took me to 78% of my 8Gb.

 Signature 

Exile, Drows Walk: A Tale of Jaderail starts here. Free pulp fiction at its Fantasy best, Updated 2/3/14.
Proud Member of the Bald Wizards Club My stuff at DeviantArt

Profile
 
 
Posted: 05 January 2013 01:54 PM   [ Ignore ]   [ # 3 ]
Member
Rank
Total Posts:  52
Joined  2009-07-12

but it does seem to need it.  With a scene as simple as 2 genesis(es), I get lag when just rotating the camera.

Profile
 
 
Posted: 05 January 2013 02:06 PM   [ Ignore ]   [ # 4 ]
Addict
Avatar
RankRankRankRank
Total Posts:  4545
Joined  2007-09-13

If you have memory available and DS is going to the pagefile…then that’s something to do with Windows memory management and not something DS is controlling.

In XP you could change the behavior of Windows to allow/force apps to use physical memory first…I’m not sure if that’s doable in Vista or later.  But if Studio isn’t using all the available RAM then it’s Windows memory management at fault.

If you are getting viewport lag…then that’s something else.

If ‘Display optimization’ is on, flip it to off.  Also look at things like smoothing…

What video card do you have?  AMD cards have been known to have OpenGL issues, one of which can be described as ‘lag’ in the viewport.

 Signature 

1432 old posts

My ShareCG gallery.

Just because something costs a lot, doesn’t mean it’s the best…

It just means it’s expensive.

Profile
 
 
Posted: 05 January 2013 02:35 PM   [ Ignore ]   [ # 5 ]
Member
Rank
Total Posts:  52
Joined  2009-07-12

It’s a laptop with the 2450 above.  It has integrated intel HD 3000 graphics. 

I turned ‘Display optimization’ off.

I also turned off “hardware anti-aliasing” and “backface lighting”.

“texture resources” is set to “performance”

Pixel buffer is off.

multi-threading is on.

I only use a single viewport.

It’s improved a little, but still not much.

Profile
 
 
Posted: 05 January 2013 03:48 PM   [ Ignore ]   [ # 6 ]
Addict
Avatar
RankRankRankRank
Total Posts:  4545
Joined  2007-09-13
kurthurt - 05 January 2013 02:35 PM

It’s a laptop with the 2450 above.  It has integrated intel HD 3000 graphics.

‘nuff said…OpenGL performance will NEVER be good…well, not quite never…but at least as long as it’s running Windows it won’t.  The Intel OpenGL implementation on that chipset, frankly, sucks.  Seriously, the only half-way decent OpenGL on that chipset I’ve ever seen is under Linux running the MESA drivers…and that was only ‘acceptable’, as opposed to ‘outright sucks’.

The next improvement in viewport response will come by turning off smoothing until you are ready to render. 

(No, I am not a fan of the Intel Graphics…)

 Signature 

1432 old posts

My ShareCG gallery.

Just because something costs a lot, doesn’t mean it’s the best…

It just means it’s expensive.

Profile
 
 
Posted: 07 January 2013 05:22 PM   [ Ignore ]   [ # 7 ]
Member
Rank
Total Posts:  52
Joined  2009-07-12

oic.  my mistake was assuming that it was a ram problem.  thanks.

Profile