Digital Art Zone

 
     
Artifacts on imported MDD animation
Posted: 04 January 2013 10:15 AM   [ Ignore ]
New Member
Total Posts:  5
Joined  2005-01-18

Hello,

I’ve been experimenting with creating cloth animations with Marvelous Designer and importing them into Carrara using Fenric’s MDD plugin, but I am seeing some artifacts on the imported MDD figure that are not present when I only import the obj file normally. See attached image for artifacts (MDD figure on the left, obj file on the right). Has anyone seen anything like this before?

Image Attachments
cloth_artifacts.jpg
Profile
 
 
Posted: 04 January 2013 04:29 PM   [ Ignore ]   [ # 1 ]
Active Member
Avatar
RankRank
Total Posts:  263
Joined  2009-03-09

No, I haven’t seen anything quite like that. 

Do the marks persist throughout the animation, or do they go away after the first frame?
If you apply one step of smoothing to the object, do they go away then?

 Signature 

Come visit my store!

http://www.daz3d.com/fenric
http://fenric.com/wordpress/store/

Profile
 
 
Posted: 04 January 2013 06:22 PM   [ Ignore ]   [ # 2 ]
Addict
Avatar
RankRankRankRank
Total Posts:  4545
Joined  2007-09-13

Looks like flipped normals to me…

 Signature 

1432 old posts

My ShareCG gallery.

Just because something costs a lot, doesn’t mean it’s the best…

It just means it’s expensive.

Profile
 
 
Posted: 05 January 2013 06:50 AM   [ Ignore ]   [ # 3 ]
New Member
Total Posts:  5
Joined  2005-01-18

They remain throughout the animation, and are fixed in relation to the mesh (i.e. they don’t move around). And yes, I thought too that it looked like flipped normals.

Tried loading the same file into Blender 2.49b; was kind of hard to tell because I couldn’t get the smoothing working too well, but it didn’t seem like the artifacts were present there.

Profile
 
 
Posted: 05 January 2013 09:39 AM   [ Ignore ]   [ # 4 ]
Addict
Avatar
RankRankRankRank
Total Posts:  4545
Joined  2007-09-13
Blackadder_no - 05 January 2013 06:50 AM

They remain throughout the animation, and are fixed in relation to the mesh (i.e. they don’t move around). And yes, I thought too that it looked like flipped normals.

Tried loading the same file into Blender 2.49b; was kind of hard to tell because I couldn’t get the smoothing working too well, but it didn’t seem like the artifacts were present there.

Try Blender 2.6x…it seems to handle smoothing and triangles much better….since it looks like the mesh is mostly triangles.  Also duplicate/unwelded vertices can, at least, contribute to the problem.

I’m guessing that the actual export to obj both welds and orients the normals…

Also, one of the clues that it may be normals…look closely at some of the displacement in the affected areas…it’s reversed.

 Signature 

1432 old posts

My ShareCG gallery.

Just because something costs a lot, doesn’t mean it’s the best…

It just means it’s expensive.

Profile
 
 
Posted: 06 January 2013 10:06 AM   [ Ignore ]   [ # 5 ]
Active Member
Avatar
RankRank
Total Posts:  263
Joined  2009-03-09
Blackadder_no - 05 January 2013 06:50 AM

They remain throughout the animation, and are fixed in relation to the mesh (i.e. they don’t move around). And yes, I thought too that it looked like flipped normals.

Tried loading the same file into Blender 2.49b; was kind of hard to tell because I couldn’t get the smoothing working too well, but it didn’t seem like the artifacts were present there.

I meant in Carrara: double-click the object, select all faces, and turn smoothing on.

 Signature 

Come visit my store!

http://www.daz3d.com/fenric
http://fenric.com/wordpress/store/

Profile
 
 
Posted: 07 January 2013 12:16 PM   [ Ignore ]   [ # 6 ]
New Member
Total Posts:  5
Joined  2005-01-18
Fenric - 06 January 2013 10:06 AM

I meant in Carrara: double-click the object, select all faces, and turn smoothing on.

I tried that first, but the moment I double-click the MDD object (or try entering the model room), Carrara grinds to a halt…

Profile
 
 
Posted: 07 January 2013 01:19 PM   [ Ignore ]   [ # 7 ]
Active Member
Avatar
RankRank
Total Posts:  263
Joined  2009-03-09
Blackadder_no - 07 January 2013 12:16 PM
Fenric - 06 January 2013 10:06 AM

I meant in Carrara: double-click the object, select all faces, and turn smoothing on.

I tried that first, but the moment I double-click the MDD object (or try entering the model room), Carrara grinds to a halt…

How big is that mesh?  Even Carrara doesn’t like individual objects to be much over 100,000 polygons (and even that is way too dense for a dress).

If it’s not that big, it sounds like you might have mesh errors - isolated points, “T” shaped connections, or lines that aren’t part of a polygon at all.

 

 Signature 

Come visit my store!

http://www.daz3d.com/fenric
http://fenric.com/wordpress/store/

Profile
 
 
Posted: 07 January 2013 05:38 PM   [ Ignore ]   [ # 8 ]
New Member
Total Posts:  5
Joined  2005-01-18
Fenric - 07 January 2013 01:19 PM

How big is that mesh?  Even Carrara doesn’t like individual objects to be much over 100,000 polygons (and even that is way too dense for a dress).

If it’s not that big, it sounds like you might have mesh errors - isolated points, “T” shaped connections, or lines that aren’t part of a polygon at all.

The obj file itself is about 24,000 polygons. It might have been the number of frames in the animation that it struggled with - managed to load a shorter mdd sequence. Subdividing didn’t do much either (see attached).

However, I tried exporting the same animation from Marvelous Designer as an obj sequence as well, then imported it into Carrara using the DCG importer, and everything looked fine.

Image Attachments
subdivided.jpg
Profile
 
 
Posted: 07 January 2013 07:18 PM   [ Ignore ]   [ # 9 ]
Active Member
Avatar
RankRank
Total Posts:  263
Joined  2009-03-09
Blackadder_no - 07 January 2013 05:38 PM
Fenric - 07 January 2013 01:19 PM

How big is that mesh?  Even Carrara doesn’t like individual objects to be much over 100,000 polygons (and even that is way too dense for a dress).

If it’s not that big, it sounds like you might have mesh errors - isolated points, “T” shaped connections, or lines that aren’t part of a polygon at all.

The obj file itself is about 24,000 polygons. It might have been the number of frames in the animation that it struggled with - managed to load a shorter mdd sequence. Subdividing didn’t do much either (see attached).

However, I tried exporting the same animation from Marvelous Designer as an obj sequence as well, then imported it into Carrara using the DCG importer, and everything looked fine.


If you can send a copy of the mesh to fenric (at) fenric (dot) com, I’ll look into what the problem is.

 Signature 

Come visit my store!

http://www.daz3d.com/fenric
http://fenric.com/wordpress/store/

Profile
 
 
Posted: 08 January 2013 12:14 PM   [ Ignore ]   [ # 10 ]
New Member
Total Posts:  5
Joined  2005-01-18
Fenric - 07 January 2013 07:18 PM

If you can send a copy of the mesh to fenric (at) fenric (dot) com, I’ll look into what the problem is.

Mdd and obj file sent.

Profile
 
 
Posted: 08 January 2013 01:06 PM   [ Ignore ]   [ # 11 ]
Active Member
Avatar
RankRank
Total Posts:  263
Joined  2009-03-09
Blackadder_no - 08 January 2013 12:14 PM
Fenric - 07 January 2013 07:18 PM

If you can send a copy of the mesh to fenric (at) fenric (dot) com, I’ll look into what the problem is.

Mdd and obj file sent.

There are significant areas of reversed normals in the OBJ file.  Carrara’s OBJ importer is injecting creases (the dark blue lines) into the figure, which my importer does not do.  If you remove the creases, then you get the same artifacts from an imported OBJ as the MDD importer does.

 

 

Image Attachments
objfile0.jpgobjfile.jpg
 Signature 

Come visit my store!

http://www.daz3d.com/fenric
http://fenric.com/wordpress/store/

Profile
 
 
Posted: 08 January 2013 01:13 PM   [ Ignore ]   [ # 12 ]
Active Member
Avatar
RankRank
Total Posts:  263
Joined  2009-03-09

The UV map is also out of bounds, extending far beyond the allowed range.

I tried to do “align” with UVMapper pro, but it just flipped back and forth with different areas pointing the wrong way.

You might be able to fix the artifacts by putting creases into the MDD imported object after the import.  Your model did eventually open in the vertex modeller for me, though it took a few minutes.

EDIT:  If you select all, crease edges: all, then smooth edges: less than 50 degrees, then it won’t have the weird artifacts anymore.

 Signature 

Come visit my store!

http://www.daz3d.com/fenric
http://fenric.com/wordpress/store/

Profile
 
 
Posted: 08 January 2013 09:41 PM   [ Ignore ]   [ # 13 ]
Active Member
Avatar
RankRank
Total Posts:  263
Joined  2009-03-09

I apologize for the inconvenience, but if you wish to continue discussing this issue with me, you must go to http://carraracafe.com

 Signature 

Come visit my store!

http://www.daz3d.com/fenric
http://fenric.com/wordpress/store/

Profile
 
 
Posted: 08 January 2013 11:03 PM   [ Ignore ]   [ # 14 ]
Member
Avatar
Rank
Total Posts:  215
Joined  2005-11-06

Hi Blackadder_no - if you send me the MD2 file I can try it out on my system for you and see if I get the same results. I’ve tried everything but I can’t replicate the problem you are seeing.

 Signature 

.(JavaScript must be enabled to view this email address)

My DAZ3D Store

My Personal Website

Profile