Daz Loyalty Rewards

As our thanks, please enjoy an EXTRA 00% OFF all your purchases through the end of 2016, INCLUDING NEW RELEASES!

(Discount excludes Gift Cards, applies at check-out.)

How do you apply a shader without removing the assigned maps

Zev0Zev0 Posts: 4,473
edited December 1969 in The Commons

Say I have armor loaded. It has textures. I want to load the metallic shader on it. But it eliminates the textures plugged in when applied. Is there no way to apply the shader and keep the assigned textures?

Comments

  • MattymanxMattymanx Posts: 4,291
    edited December 1969

    When applying shaders in DS, hold down the Ctrl key and double click the shader preset.

    A little window will pop up, the second option is "Map Settings" set it to Ignore and then go to the Preferences tab and select "Set Prefered Options on Accept"

    Then click accept.

  • Zev0Zev0 Posts: 4,473
    edited December 1969

    Cool. Gonna try that now. Thanks

  • Zev0Zev0 Posts: 4,473
    edited December 1969

    Worked like a charm:)

  • JoeQuickJoeQuick Posts: 977
    edited December 1969

    Mattymanx said:
    When applying shaders in DS, hold down the Ctrl key and double click the shader preset.

    A little window will pop up, the second option is "Map Settings" set it to Ignore and then go to the Preferences tab and select "Set Prefered Options on Accept"

    Then click accept.

    That'll sure speed up the process of setting up one of Stonemason's lots using the Visual Style Shaders.

  • MattymanxMattymanx Posts: 4,291
    edited December 1969

    Glad I could help! :)

  • Miss BMiss B Posts: 3,058
    edited December 1969

    Mattymanx said:
    When applying shaders in DS, hold down the Ctrl key and double click the shader preset.

    A little window will pop up, the second option is "Map Settings" set it to Ignore and then go to the Preferences tab and select "Set Prefered Options on Accept"

    Then click accept.

    Now this is good info to know. Thank you sir. This little tidbit is getting saved. ;)

  • TZORGTZORG Posts: 58
    edited December 1969

    Joequick said:
    Mattymanx said:
    When applying shaders in DS, hold down the Ctrl key and double click the shader preset.

    A little window will pop up, the second option is "Map Settings" set it to Ignore and then go to the Preferences tab and select "Set Prefered Options on Accept"

    Then click accept.

    That'll sure speed up the process of setting up one of Stonemason's lots using the Visual Style Shaders.
    It won't work with Visual Style because that's a mixer shader.

    On the old forum I suggested how to save out and edit a VS preset so that it will preserve textures though.

  • FixmypcmikeFixmypcmike Posts: 16,355
    edited December 1969

    TZORG said:
    Joequick said:
    Mattymanx said:
    When applying shaders in DS, hold down the Ctrl key and double click the shader preset.

    A little window will pop up, the second option is "Map Settings" set it to Ignore and then go to the Preferences tab and select "Set Prefered Options on Accept"

    Then click accept.

    That'll sure speed up the process of setting up one of Stonemason's lots using the Visual Style Shaders.


    It won't work with Visual Style because that's a mixer shader.

    On the old forum I suggested how to save out and edit a VS preset so that it will preserve textures though.


    Apparently in DS4.5 it does work.

  • TZORGTZORG Posts: 58
    edited June 2012

    I think that if e.g. Joequick wants to convert dzDefault shaders into a VS "equivalent," there isn't a very good way to make this automated [without editing .dsa code], because there are at least two places in VS where the diffuse color+map should be plugged (I use four) and DS couldn't really know that. I guess it can check "diffuse color" (the one that governs what the openGL shows) but that is just the light shading side.

    Post edited by TZORG on
Sign In or Register to comment.
Rocket Fuel