Area Light Help

SzarkSzark Posts: 8,796
edited December 1969 in Daz Studio Discussion

I am in the middle of doing a tutorial on Area lighting and I was always led to believe Ambient must be turned On for the light to emit. Well in DS3A 3.1.2.32 and DS4.5.1.6 this is not the case. I have tested all the presets and Base on various meshs, added other ligths etc and in every case with Ambient Turned OFF I get light.

So for you Daz Studio stalwarts out there can you, if you have time, check to see if this is the case and if so do you know when this changed?

Comments

  • frank0314frank0314 Posts: 8,790
    edited December 1969

    LOL! I thought it was always like that.

  • SzarkSzark Posts: 8,796
    edited December 1969

    This is it though Frank in early DS3 I have always had to turn ON ambient even with 0% intensity and people have confirmed this on many ocassions since. So since then I have always turned it on so I wouldn't notice the difference with that practice. Only when I forgot to Turn On ambient I noticed this so hence me asking for confirmation in case I was going mad....... or getting more some would say. ;)

  • GeddGedd Posts: 2,473
    edited December 1969

    I'm not sure what you mean by emit? Ambiance is a surface property which makes a surface project it's diffuse channel overriding and/or adding to the reflected light (or more properly lack thereof.) Not trying to tell you something you probably already know, just trying to clarify since I'm not quite sure what you are asking.

  • SzarkSzark Posts: 8,796
    edited December 2012

    Area lights can emit, project light from a given surface that has had the Area base added or an Area Light mesh preset, Plane, Disc, Tube etc. This is called Mesh Lighting as Lux and many other programs have, Daz Studio calls them Area Lights.

    You can use just the Ambient channel of a Daz Default Surface as a light source when using UberEnviroment GI Preset, see the latest New Users contest for details on that http://www.daz3d.com/forums/discussion/12654/P60/#197187

    Post edited by Szark on
  • GeddGedd Posts: 2,473
    edited December 2012

    Ok, I haven't worked with area lights in a bit... I didn't remember using the ambient channel to define the light emission for them.. that's where my confusion was. I thought area lights had a separate property for defining light emission, but it's been a while. Thanks for the link, I'll read through it when I can focus on it. This is an area I need to play more in :)

    Post edited by Gedd on
  • SzarkSzark Posts: 8,796
    edited December 1969

    I can swear down that nearly everyone talking abut Area Light said that for it to work, as in provide light, the Ambient channel of the Area light surface needed to be turned on. That is all I wanted confirming by the long term users of daz Studio as I found this not to be the case now. Plus I can put my hand on my heart and say a few years back Area lights wouldn't work until Ambient was turn on...even if you left the Ambient Intensity at 0% as long it was turn On that was enough for light..OFF meant no Light. This is why I got in to the habit of turning On ambient every-time I use Area Lighting...and hence not realising things have changed.

    So if it is true now I need to amend my tutorial to suit the current set up. With Frank's reply I will take it that this indeed is true. :)

  • GeddGedd Posts: 2,473
    edited December 1969

    Gotcha, ty for putting together the tutorial :)

  • prixatprixat Posts: 634
    edited December 1969

    Hi Szark

    You may be thinking of the bad old days when over-driving the ambient was the only way to fake area lighting.

    GI plus any standard material will do it. It doesn't even have to be an ubersurface!

    In the new area lights (DS4.5), the diffuse, ambient and opacity channels are still there but they really should not be.

    ...and setting a bright ambient can actually alter the intensity you've set, you'll get an unexpectedly bright light unless you're watching out for it. I'd recommend turning those channels off completely.

  • MachieltjeMachieltje Posts: 0
    edited December 1969

    Hi Szark

    I have been messing around with area lights recently but after all that's been said I didn't think I'd have anything useful to add but after some consideration (and some quick testing) I think I might have especially after what prixat just said.

    Now I've only been using Studio since February this year so I'm by no means an expert so I have no what the area lights were meant to do I just know what I want them to do...(I also don't know how stuff worked in the good (or bad) ole days :P as I've only ever used 4 and 4.5)

    First off: yes area lights do emit light when ambient is off or set at 0% however the area light does not light itself so if there are no other lights in the scene, without ambient, you'll have a black-hole emitting light. This might be useful in certain scenarios but in some (a lot?) of cases this is not what you're after. In those cases stetting the ambient will give your light a source.

    As an example I'll re-post an (newer version) of an image I posted earlier in an other thread here. I used two area lights there as well as an uberpoint light I might have gotten a similar effect using an other point light and a spot but I do remember messing with a spot and not being satisfied with the result. (Not sure why thought)

    In the image the flash light on the shelve initially had ambient turned off (I turned it on but forgot to turn it up :P) and the light seemed to come from nowhere so I set it a 100. Now the effect is not as convincing as it should have been but I'll have to do. I might add a "ting!" to it in post although I believe those things are frowned upon by real artists or maybe I'll get better results by slightly lowering the ambient...

    Christmas_in_Rubble_3b.jpg
    1920 x 1080 - 250K
  • SzarkSzark Posts: 8,796
    edited December 2012

    prixat said:
    Hi Szark

    You may be thinking of the bad old days when over-driving the ambient was the only way to fake area lighting.

    GI plus any standard material will do it. It doesn't even have to be an ubersurface!

    In the new area lights (DS4.5), the diffuse, ambient and opacity channels are still there but they really should not be.

    ...and setting a bright ambient can actually alter the intensity you've set, you'll get an unexpectedly bright light unless you're watching out for it. I'd recommend turning those channels off completely.

    Thanks for the reply but no I am not confused..well not about this one at least. :)

    GI and ambient surfaces, yeah I know as the link above shows. :)

    I don't know what you mean by "In the new area lights (DS4.5), the diffuse, ambient and opacity channels are still there but they really should not be".

    Increasing Ambient surfaces on a Default surface will only make a scene brighter when you use Global Illumination...I have never come across a situation where that varies.

    But we are getting away from the original question which has been answered now so thank you everyone for your input and help. :)

    Now to get this tut finished and posted.

    Post edited by Szark on
  • SzarkSzark Posts: 8,796
    edited December 1969

    Machieltje thank you for the confirmation, much appreciated...all the rest is not new to me but I thank you just the same for taking the time to post.

  • JustTheBastJustTheBast Posts: 3
    edited December 1969

    First off: yes area lights do emit light when ambient is off or set at 0% however the area light does not light itself so if there are no other lights in the scene, without ambient, you'll have a black-hole emitting light. This might be useful in certain scenarios but in some (a lot?) of cases this is not what you're after.

    That is also how I always understood it, namely that the "Ambient" channel of the surface shader does not influence the emission of the light shader, but that you usually want to use both, in order to make the surface look like a light source, as well as behave like one.

    And may I say, that's a lovely illustration, Machieltje. :)

  • prixatprixat Posts: 634
    edited December 1969

    ...the "Ambient" channel of the surface shader does not influence the emission of the light shader...

    Thats what I assumed at first.
    to get the square arealight to show up on the spheres with this setup:

    setup.png
    300 x 400 - 115K
  • prixatprixat Posts: 634
    edited December 1969

    I turned up the ambient from 0 to 100, leaving the intensity at 100.
    ...and got an image with 200% and some burnt out highlights:

    legsbright.png
    300 x 400 - 144K
  • prixatprixat Posts: 634
    edited December 1969

    a couple of ways round it, I reduced the intensity to 0 and just relied on ambient.
    (or you could reduce the overall exposure, that's labeled 'Gain' in the render settings)

    So for now 'Ambient' gets a reprieve :lol:

    If anyone has a use for diffuse or opacity in an arealight I'd like to see it. :-)

    legs.png
    300 x 400 - 149K
  • SzarkSzark Posts: 8,796
    edited December 1969

    Two images, indentical light at 100% the only diifference is one has ambient

    There is no increase of light when ambeience is engaged.

    The only time that I know of when Ambience increases light output is when GI is used.

    and last a sphere with a transmap applied

    UberAmbONFallOffONGel2.jpg
    282 x 400 - 39K
    UberAmbON.jpg
    282 x 400 - 33K
    UberAmbOFF.jpg
    282 x 400 - 32K
  • SimonJMSimonJM Posts: 2,956
    edited December 1969

    A little late to the party, but yes - I do recall that at some stage Ambient had to be set to On before the UberArea light would actually emit light. I'm not sure when that changed but seeing as the default setting after application of the shader is/was for it to be off it is a happy update in my book! :)

  • SzarkSzark Posts: 8,796
    edited December 1969

    Simon I could kiss you but I would wager you don't have the legs for it. :)

    I agree a welcome change that sneaked by me....

  • SimonJMSimonJM Posts: 2,956
    edited December 1969

    Szark said:
    Simon I could kiss you but I would wager you don't have the legs for it. :)

    I agree a welcome change that sneaked by me....

    Oh, but I do have the legs for it ... they're ruddy good at running away! :)

    I only noticed it when I did a render using UberArea lights, lit blue touch-paper and retired for the night in the certain knowledge that it would take ages to complete. When I woke it was with the jolting certainty that I'd forgotten to turn on Ambient and I'd have to cancel and restart ... imagine my bouncy happiness (also confusion!) when I noticed that the lights were lit! :)

  • prixatprixat Posts: 634
    edited December 1969

    Szark said:
    The only time that I know of when Ambience increases light output is when GI is used.

    That's the problem! It shouldn't do that. :)

  • MachieltjeMachieltje Posts: 0
    edited December 2012

    prixat said:
    a couple of ways round it, I reduced the intensity to 0 and just relied on ambient.
    (or you could reduce the overall exposure, that's labeled 'Gain' in the render settings)

    So for now 'Ambient' gets a reprieve :lol:

    If anyone has a use for diffuse or opacity in an arealight I'd like to see it. :-)


    Ha! a challenge.

    Also, shame on you for cutting the poor woman in half; there are laws against that you know...


    Edit: hrmph forgot to say what I wanted to say...

    So here goes; the burned out specular highlights may not have anything to do with light intensity (I've found that 100% for area-lights is not very bright at all) but more with specular maps or more to the point not having any...

    Post edited by Machieltje on
  • SzarkSzark Posts: 8,796
    edited December 1969

    prixat said:
    Szark said:
    The only time that I know of when Ambience increases light output is when GI is used.

    That's the problem! It shouldn't do that. :)

    I know you know more than me about all this so could you help me out by expaining why it shouldn't...pwease. :)

  • SzarkSzark Posts: 8,796
    edited December 1969

    SimonJM said:
    Szark said:
    Simon I could kiss you but I would wager you don't have the legs for it. :)

    I agree a welcome change that sneaked by me....

    Oh, but I do have the legs for it ... they're ruddy good at running away! :)

    I only noticed it when I did a render using UberArea lights, lit blue touch-paper and retired for the night in the certain knowledge that it would take ages to complete. When I woke it was with the jolting certainty that I'd forgotten to turn on Ambient and I'd have to cancel and restart ... imagine my bouncy happiness (also confusion!) when I noticed that the lights were lit! :)

    LOL

    What a nice surprise Simon...I really thought I was going more mad than I am already with this and it does surprise me that some of the other users had no idea about this. This was something I learnt in my first year.

  • JustTheBastJustTheBast Posts: 3
    edited December 1969

    prixat said:
    ...and got an image with 200% and some burnt out highlights:

    Yeah, that's what I'd expect to happen with a surface that has diffusion, specularity, and reflection tuned on. It's very easy to get over-lighting and blow-outs, when those three add up. It usually takes a bit of tweaking of the relative strength multipliers to get it to look right.

    None of that changes the fact, though, that the ambient settings of a surface shader have no influence whatsoever on the light emitted by an area-light shader attached to the same surface. They are two separate entities.

    Here's a simple test bed that shows it: a pure white plane, ball and cube, lit by a planar area light, emitting pure green light and having pure red ambient colour. If the two mixed, the scene should be lit in yellow - but it is not. Only the colour set on the light shader has any influence on the actually emitted light.

    Render_1.jpg
    1069 x 880 - 196K
  • ErdehelErdehel Posts: 190
    edited December 2012

    Thank you all for the input I found in this thread. I now have a better understanding of how area lights work. :) Gonna experiment a little bit when I get home. I usually use them to light up stuff from 3-D-C at Rendo but I get mixed results...

    Post edited by Erdehel on
  • mjc1016mjc1016 Posts: 7,922
    edited December 1969

    I'll have to check, but I think that Opacity can be used to give an 'invisible' emitter...in other words set to 0 should turn off the visibility of the item without affecting it's light output.

    Yep, exactly what it does...

    Render 1 Sphere opacity is 100%
    Render 2 Sphere opacity is 0%
    Render 3 is using the 'eye' icon to turn off the sphere' visibility...

    All three are rendered with 'low quality' render settings for maximum speed...

    ambsphere3.jpg
    800 x 1000 - 13K
    ambsphere2.jpg
    800 x 1000 - 477K
    ambsphere1.jpg
    800 x 1000 - 472K
  • BejaymacBejaymac Posts: 1,043
    edited December 1969

    mjc1016 said:
    I'll have to check, but I think that Opacity can be used to give an 'invisible' emitter...in other words set to 0 should turn off the visibility of the item without affecting it's light output.

    Yep, exactly what it does...

    Render 1 Sphere opacity is 100%
    Render 2 Sphere opacity is 0%
    Render 3 is using the 'eye' icon to turn off the sphere' visibility...

    All three are rendered with 'low quality' render settings for maximum speed...


    There's an option in the Arealight shader called "Fantom", turn it "on" in the surfaces tab and you don't have to mess about with Opacity, the pic is a quick spot render showing the Area disc lighting up Genesis, as you can see fantom is on.

    Fantom.jpg
    793 x 464 - 144K
  • mjc1016mjc1016 Posts: 7,922
    edited December 1969

    Bejaymac said:
    mjc1016 said:
    I'll have to check, but I think that Opacity can be used to give an 'invisible' emitter...in other words set to 0 should turn off the visibility of the item without affecting it's light output.

    Yep, exactly what it does...

    Render 1 Sphere opacity is 100%
    Render 2 Sphere opacity is 0%
    Render 3 is using the 'eye' icon to turn off the sphere' visibility...

    All three are rendered with 'low quality' render settings for maximum speed...


    There's an option in the Arealight shader called "Fantom", turn it "on" in the surfaces tab and you don't have to mess about with Opacity, the pic is a quick spot render showing the Area disc lighting up Genesis, as you can see fantom is on.

    Yes, Fantom works, too...but with the Opacity, you can still use maps to give a pattern to the emitter,,,just create a normal transmap and enable Ambient, with a bit of color and you have a shaped, glowing emitter...

    While not quite the same, mesh lights/area lights are loads of fun. I once modeled a light bulb, down to a simple filament. Then used that in a flashlight, with a carefully modeled parabolic reflector. Then I rendered it in Lux, with an volume defined. The reflector was set to a mirror material, the filament was a mesh light and the bulb was a glass material...and when all was said and done, it looked great...but I didn't get a chance to save the final image, as my network went down. I should go back and render that one over again...I should have the scene file somewhere, I know I've got the models.

    I wonder what it would be like doing that in DS 4.5 with UA

    altransmapped.jpg
    800 x 1000 - 63K
  • mjc1016mjc1016 Posts: 7,922
    edited December 1969

    Or something like this...

    Two area lights...one overhead and other is the 'screen' with an transmap and the ambient turned on...that's over top of a slightly large square primitive, with a slight amount of ambient strength (5%, I think) in the same green as the the light color.

    altransmapped2.jpg
    800 x 1000 - 236K
Sign In or Register to comment.
Rocket Fuel