Digital Art Zone

 
     
Clothing scale problem DS 4.5
Posted: 24 December 2012 07:05 AM   [ Ignore ]
New Member
Total Posts:  4
Joined  2010-11-07

Hi, sorry this is my first post and stuff but I got a problem and would like to ask for your help.

I mostly use Victoria 4.2 for renders, and often I have clothes that don´t fit her and have insufficient morphs to fit her. What I usually did with DS 4 Pro was scaling the clothes or only parts of it and mesh smoothing to properly fit it to the figure. This worked pretty well with DS 4 Pro.

Now a couple of days ago I installed DS 4.5.1.6 (Win 7, 64 bit) and all of a sudden I can not scale any clothes parts anymore, on clothes that are fir to V4.2. I usually select lothing parts like hips or abdomen and scale them with the parameters tab. It always worked fine with DS4 but in DS4.5 it does not. The scaling values are showed right in white color, like x > 82% but the item itself is not scaled, it keeps it´s original form and the scaling is not applied. This only happens when the clothing is “Fit to”. When the clothing is stand alone without being assigned to a figure the scaling works right. If I do that and then assign the clothing to the figure, it´s shape also resets to its original shape, but keeps the changed scale values in the parameter tab. This happens on V4 and V4.2 so that´s not the problem. It also happens when I load an old DS4 scene where everything worked fine, all the scaled clothing assigned to a figure resets to it´s original shape.

Sometimes I also use the translate function for some clothing parts, but this also stopped working. It shows the right values in the parameter tab but instead of translating the part it seems to get rotated or bend or such. I use scaling and translating quite often on clothes, and this problem really bugs me. I also tried to switch on/off the auto fit option in the preference tab of DS but it did not change anything.

Can someone please help me?

Profile
 
 
Posted: 24 December 2012 07:44 AM   [ Ignore ]   [ # 1 ]
Active Member
Avatar
RankRank
Total Posts:  932
Joined  2007-01-04

It sounds like it might be a bug in 4.5.1.6 as I don’t have that issue in the beta.

However there is no need to scale outfits to fit around morphs, since DS3 we’ve had a function called Morph Follower, it adds all active morphs in the figure to the clothing, it got renamed in DS4 to Transfer Active Morphs, if you right click either the figure or the outfit in the viewport you will see the option at the bottom of the menu.

 Signature 

**shuffles of with a new headache** tongue wink

Profile
 
 
Posted: 24 December 2012 12:31 PM   [ Ignore ]   [ # 2 ]
New Member
Total Posts:  4
Joined  2010-11-07

Thanks for the hint on this function, I was not aware of it. But it is not as accurate as scaling would be and also has no use if you want to change the size of clothing. Like shortening a skirt or making a cape longer or shorter, if those items have no morphs for it. I consider scaling and for certain clothes translating of parts essential for achiving a look that I want and/or at least for the fine tuning. Here is a pic to make clearer what my problem is.

In pic 1 you see a cut out of a render I did a while ago with DS4 Pro. The pants snug to the body, fit nice and tight as I wanted it too look. I achived this by simply scaling and translating the item and then mesh smoothing it.

Pic 2 shows the same scene without any changes, rendered with DS 4.5 for this testing purpose. As you see the pants don´t scale, they keep their original shape, even though the scale values are intact in the parameter tab.

Pic 3 shows the same scene again with the transfer morphs function you mentioned, looks better, but you see the difference. It still needs scaling for the fine tuning.

Pic 4 shows the same scene from a different angle, to show that morph transfer can not do all the work on its own. You see the problem here, to fix that I would still need to scale and translate the item.

I tried to unlock all nodes and rotation limits on the item and V4 but it makes no difference. The cloth always keeps it´s original shape.

When upgraded to DS 4.5 here is what I did. Just installed it, the old DS 4 was deinstalled. No problems occured.  Then I installed the Genesis essentials 1.6 coming with the download. Then I installed Lux renderer to my system and the just bought Reality 2.5. No problems occured, and thing work fine. That is all I did. I did not touched the database or installed or changed anything else. I´m just not able to scale “fit to” clothing items and the translating function also does not work right.

Image Attachments
test0.jpg
Profile
 
 
Posted: 10 January 2013 08:04 AM   [ Ignore ]   [ # 3 ]
New Member
Total Posts:  4
Joined  2010-11-07

Hi, I still have the problem. Maybe someone her who can confirm that it is a bug that I can not scale the hip part of clothing assigned to V4? As you see in pic 4 I posted the last time, the morph following option does not work right with all items (shoes look really weird but that´s another story). I really need to be able to scale clothes to repair such things.

It seems that the problom also occurs on build in morphs that would affect the hip section of any clothes and that it also applies to Michael 4. I was posing him and made him wear pants and a polo shirt, that created pokethroughs on the hips. The shirt has build in morphs to fit it over pants, but those only morph the abdomen section and ignore the hips.

It really seems like anything I try to change the shape of an item on the hips does not work. The hips always stay in it´s original shape. I tried with some other pants, it is the same deal. Strangely I can scale the thighs of an item but no hips. Even more strange I can translate and rotate the hips part without problems but no scaling.

Though on the chest section scaling causes an item to rotate or bend, hard to say it really looks weird. does someone else has the same problem with Daz 4.5.1.6 Pro? Can it be a bug?

Maybe it is just some really simple thing that I´m just not aware of, like the hips or so are ancored or locked from reshaping by the software itself and it can be undone somehow? I don´t find anything any where in regards to that. Am I really the only one with this problem?

Profile
 
 
Posted: 10 January 2013 09:07 AM   [ Ignore ]   [ # 4 ]
Administrator
Avatar
RankRankRankRank
Total Posts:  14720
Joined  2003-10-09

The hip has very little mesh in most figures - try using the pelvis bone instead. Though scaling a whole bone is unlikely to the ideal - look at using DForms, or using a Push modifier as alternatives.

 Signature 

DAZ Studio Frequently Asked Questions

Index of free DAZ Studio scripts and plugins list

Profile
 
 
Posted: 11 January 2013 09:40 AM   [ Ignore ]   [ # 5 ]
New Member
Total Posts:  4
Joined  2010-11-07

Hmm, thanks for mentioning D-Forms. If I apply a D-Form morph zone it magically works, with this I can scale an item by scaling the D-Former. The problem is still there but at least this work around makes me able to do pictures again.

However, if I would like to select a pelvis how would I do that? I can´t find any item like this. If I open an item with the little arrow icon I find hip, abdomen, chest and various other parts of clothing or the body but no pelvis. Is is something hidden?

Profile
 
 
Posted: 11 January 2013 03:05 PM   [ Ignore ]   [ # 6 ]
Administrator
Avatar
RankRankRankRank
Total Posts:  14720
Joined  2003-10-09

Sorry, the pelvis comment applied to Genesis - I’d forgotten you were using V4.

 Signature 

DAZ Studio Frequently Asked Questions

Index of free DAZ Studio scripts and plugins list

Profile