Digital Art Zone

 
     
UberEnvironment Grainy Shadows
Posted: 19 December 2012 07:24 PM   [ Ignore ]
Member
Avatar
Rank
Total Posts:  50
Joined  2012-02-04

Hey all. I was wondering if anyone can help me out with the grainy shading that Uberenvironment produces? I think it might be the ambient occlusion thats doing it (could be wrong) but the shading in many of my uberenvironement renders are coming out super grainy and messy.. how do I fix this?

I have tied turning the ambient occlusion samples up beyond 120, but it does not seem to eliminate the problem? Heres a cropped piece of something Im in the middle of postworking. The grainy shading Im talking about is pretty noticable along the jaw and on the dark side of the neck.

Image Attachments
shadingissue.jpg
 Signature 

Gallery: http://freelancer604.deviantart.com/

Profile
 
 
Posted: 19 December 2012 07:42 PM   [ Ignore ]   [ # 1 ]
Addict
Avatar
RankRankRankRank
Total Posts:  4545
Joined  2007-09-13

Screenshot of the UberEnvironment Settings and a screenshot of Advanced Render settings would be the easiest way to figure out what needs to be changed…

 Signature 

1432 old posts

My ShareCG gallery.

Just because something costs a lot, doesn’t mean it’s the best…

It just means it’s expensive.

Profile
 
 
Posted: 20 December 2012 01:56 PM   [ Ignore ]   [ # 2 ]
Addict
Avatar
RankRankRankRank
Total Posts:  3372
Joined  2009-08-05

I also want to know how to eliminate the noise when using the uber-environment.

 Signature 

My Daz Store
My Rendo Store

Profile
 
 
Posted: 20 December 2012 02:00 PM   [ Ignore ]   [ # 3 ]
Member
Rank
Total Posts:  112
Joined  2012-02-05

Lower the shading rate on UE2; you can go as low as 1 (you could go even lower but I’m not sure it would help) Of course there’s a down side to this as your render times will go up quite a bit…

 Signature 

My images on Deviant Art

Profile
 
 
Posted: 20 December 2012 02:03 PM   [ Ignore ]   [ # 4 ]
Member
Rank
Total Posts:  112
Joined  2012-02-05

Aslo, Freelancer I see you have at least one light set up to use deep shadow maps (the colourful render errors are a dead give away) set it to ray traced to get rid of those. ( adding even more to your render time raspberry)

 Signature 

My images on Deviant Art

Profile
 
 
Posted: 20 December 2012 11:15 PM   [ Ignore ]   [ # 5 ]
Member
Avatar
Rank
Total Posts:  50
Joined  2012-02-04
Machieltje - 20 December 2012 02:03 PM

Aslo, Freelancer I see you have at least one light set up to use deep shadow maps (the colourful render errors are a dead give away) set it to ray traced to get rid of those. ( adding even more to your render time raspberry)

Ooh so thats what causes those color dots. Its actually an issue thats been bothering me for a long while thanks!

As for the UE shading, I have the rate set to 0.2 for the image light and 1.0 for the overall render. Shadow samples at 128 for UE and 35 for the render…

 

 Signature 

Gallery: http://freelancer604.deviantart.com/

Profile
 
 
Posted: 20 December 2012 11:42 PM   [ Ignore ]   [ # 6 ]
Member
Rank
Total Posts:  75
Joined  2010-02-18

To eliminate or lower the :sharp shadow” in raytrace, you increase the shadow softness as well! I usually have my UE2 set on the 3Hi settings, with shadow samples set at 90-100, shade rate set at 2-3. Set the Environment Mode to Occlusion with soft shadows. My render shade rate is .5. My render times are usually 1-2 hour. Under the 4XHi settings with shadow samples set at 128, shade rate 1-2, Then render time increased to 8+ hours. At least that’s what I have learned anyways!  Might not be photo realistic, but a lot better results compared to some renders I have seen!

Profile
 
 
Posted: 21 December 2012 01:16 AM   [ Ignore ]   [ # 7 ]
Addict
RankRankRankRank
Total Posts:  3176
Joined  2007-06-22

Reduce your overall shading rate to 0.1 and see if that helps.

Profile
 
 
Posted: 27 April 2013 08:25 PM   [ Ignore ]   [ # 8 ]
New Member
Avatar
Total Posts:  12
Joined  2012-08-13

A thought occurred to me, but I haven’t had time to try it yet: Have you looked at the Subsurface Shading Rate setting on your skin surface?  That might be responsible for some of the grain, too, I imagine.  (I see the same thing when I use UE, but I’ve been rendering a human figure with SSS all over the place.  Like I said, haven’t tried changing it.)

I suppose the quickest way to see if it’d make a difference would be to turn SSS off entirely, wouldn’t it?  I’ll have to try that too.

Profile
 
 
Posted: 28 April 2013 06:42 AM   [ Ignore ]   [ # 9 ]
Addict
Avatar
RankRankRankRank
Total Posts:  7844
Joined  2009-05-14

Yes increasing the SSS Shading Rate to 128 will reduce the need to max out the Shading Rate in the advanced render settings when using Uber Environment 2 and in my expereince it doesn’t increase render times that much.

 Signature 

Pete

Somethings to Consider when starting to learn CG

My Gallery

My Render Thread and Tutorials

Proud member of the Bald Wizards Club and Co-operative

Profile