Digital Art Zone

 
   
1 of 2
1
Removing the grains from image
Posted: 12 December 2012 07:52 AM   [ Ignore ]
Member
Rank
Total Posts:  158
Joined  2012-01-29

How to remove the grains from an image without reducing the quality. I tried to reduce the occulsion strength to 0 but then image becomes too bright and not realastic looking. Any way to remove the grains.

Image Attachments
a1.jpg
Profile
 
 
Posted: 12 December 2012 08:11 AM   [ Ignore ]   [ # 1 ]
Power Member
Avatar
RankRankRank
Total Posts:  1336
Joined  2006-03-14

You want to make sure that your Occlusion Samples are around 128 and that your UE Shading Rate (on the Parameters Tab) for UE2 is set to 1.0.  The “4x High” setting will have it at 8.0 which is fine if their are auxiliary lights but not so great if UE2 is the primary light.

 Signature 

My Tutorials and Freebies Index

Profile
 
 
Posted: 13 December 2012 08:01 AM   [ Ignore ]   [ # 2 ]
Member
Rank
Total Posts:  158
Joined  2012-01-29

well the grains are still present though

Profile
 
 
Posted: 13 December 2012 08:14 AM   [ Ignore ]   [ # 3 ]
Addict
Avatar
RankRankRankRank
Total Posts:  4545
Joined  2007-09-13

Can you repost the pic with the specific problem areas circled?

And a screenshot of your render settings?

 Signature 

1432 old posts

My ShareCG gallery.

Just because something costs a lot, doesn’t mean it’s the best…

It just means it’s expensive.

Profile
 
 
Posted: 13 December 2012 08:29 AM   [ Ignore ]   [ # 4 ]
Member
Rank
Total Posts:  158
Joined  2012-01-29

http://www.imagebam.com/image/fabcf8225543347
Heres my render settings

As for the pic look carefully the entire pic contains small grains. Its visible at chars legs and also on the ground

Profile
 
 
Posted: 13 December 2012 09:08 AM   [ Ignore ]   [ # 5 ]
Addict
Avatar
RankRankRankRank
Total Posts:  4545
Joined  2007-09-13

Well…half or more of the problem is the settings…

3Delight likes ‘power of two’ numbers best…but whole, even numbers work fine.  Odd, fractional numbers make it ‘work harder’,

Now, for things like Pixel Samples (X,Y) 8 should be enough. Shadow Samples of 8, or 16 should for most things, be fine. Gain and Gamma should be left at default values. Pixel Filter Width…default is fine, but they MUST MATCH…and overall shading rate of above 1 is ‘draft’ mode…a shading rate of .2 is ‘acceptable’  and down to 0,01 for extremely fine, final production renders.

 Signature 

1432 old posts

My ShareCG gallery.

Just because something costs a lot, doesn’t mean it’s the best…

It just means it’s expensive.

Profile
 
 
Posted: 13 December 2012 10:05 AM   [ Ignore ]   [ # 6 ]
Member
Rank
Total Posts:  158
Joined  2012-01-29

even with ur settings grains doesnt dissappear

Profile
 
 
Posted: 13 December 2012 10:52 AM   [ Ignore ]   [ # 7 ]
Addict
Avatar
RankRankRankRank
Total Posts:  2693
Joined  2009-02-24

The graininess will depend on your Shading Rate on the render settings and the Shading Rate of any UberEnvironment lights you have in the set. The lower the better, but be warned that lowering it will also slow down render times considerably. One thing to remember is that UE lights aren’t true lights, they’re shaders. The shading rate determines how much work goes into each pixel, and with higher shading rates it effectively ‘clumps’ sets of pixels together, which is what gives you patches sometimes.

Of course, that’s a very over-simplified version. If you’re still getting patchy spots with very low shading rates then post your light configuration and maybe we can help further. It might also help to know the surface types which are most effected.

 Signature 

Find me on DeviantArt
Download my free IBL presets for Luxus
Re-upload of Cresent’s awesome pwToon shaders
Create your own Smart Content

Profile
 
 
Posted: 13 December 2012 12:03 PM   [ Ignore ]   [ # 8 ]
Member
Rank
Total Posts:  158
Joined  2012-01-29

Heres my uber settings
http://www.imagebam.com/image/ba0f53225587980

I have 1 distant light with intensity at 40

Profile
 
 
Posted: 13 December 2012 12:07 PM   [ Ignore ]   [ # 9 ]
Addict
Avatar
RankRankRankRank
Total Posts:  2693
Joined  2009-02-24

I don’t see anything in those settings which should cause the patches you’ve been getting. I assume you’re using the pre-packaged 3Delight renderer? What are the materials which are most affected?

 Signature 

Find me on DeviantArt
Download my free IBL presets for Luxus
Re-upload of Cresent’s awesome pwToon shaders
Create your own Smart Content

Profile
 
 
Posted: 13 December 2012 12:57 PM   [ Ignore ]   [ # 10 ]
Member
Rank
Total Posts:  158
Joined  2012-01-29

entire screen is affected

Profile
 
 
Posted: 13 December 2012 01:01 PM   [ Ignore ]   [ # 11 ]
Power Member
Avatar
RankRankRank
Total Posts:  1336
Joined  2006-03-14
omgwtfbbgxy - 13 December 2012 12:03 PM

Heres my uber settings
http://www.imagebam.com/image/ba0f53225587980

I have 1 distant light with intensity at 40

Do you have raytraced shadows on your distant light?

 Signature 

My Tutorials and Freebies Index

Profile
 
 
Posted: 13 December 2012 01:55 PM   [ Ignore ]   [ # 12 ]
Power Member
Avatar
RankRankRank
Total Posts:  1336
Joined  2006-03-14

This image is UE2 only.
The following settings were used:
Advanced Render Settings:
- Max Ray Trace Depth : 2
- Pixel Samples X/Y : 16
- Shadow Samples: 16
- Gain 1.00
- Gamma 1.00
- Shading Rate 0.20
UE2 Parameter Settings:
- Color: 255,255,255 w/OmKHPark_Env.tif map
- Environment Mode: Occlusion w/Directional Shadows
- Saturation : 100%
- Contrast : 100%
- Occluasion Strength : 100%
- Indirect Lighting Strength : 100%
- Occlusion Color: 0, 0, 0
- Occlusion Samples: 128
- Shadow Bias : 0.10
- Shading Rate: 0.50
- Max Error : 0.10
- Maximum Trace Distance: 150

Image Attachments
ue2-solo-raw.jpg
 Signature 

My Tutorials and Freebies Index

Profile
 
 
Posted: 13 December 2012 01:57 PM   [ Ignore ]   [ # 13 ]
Power Member
Avatar
RankRankRank
Total Posts:  1336
Joined  2006-03-14

With 1 Distant Light, aligned to match the UE2 environment sphere…
UE2 and Advanced Render Settings as above.
Distant Light Settings:
- Shadow Type: Raytraced Shadows
- Shadow Softness: 40%
- Shadow Bias: 1.00
- Illumination: On
- Color : 255, 255, 255
- Intensity: 40%

Result, a little blown out still (I’d lower the intensity on UE2 to about 60% honestly but I forgot)...

Image Attachments
ue2-distant-raw.jpg
 Signature 

My Tutorials and Freebies Index

Profile
 
 
Posted: 14 December 2012 11:27 AM   [ Ignore ]   [ # 14 ]
Member
Rank
Total Posts:  158
Joined  2012-01-29

with same settings i am getting this
.Can see the grains in the body
I am using uber env base

Image Attachments
a5.jpg
Profile
 
 
Posted: 14 December 2012 01:25 PM   [ Ignore ]   [ # 15 ]
Power Member
Avatar
RankRankRank
Total Posts:  1336
Joined  2006-03-14

Post a screencap of your advanced render settings and the parameters tab of your UE2 element please.

 Signature 

My Tutorials and Freebies Index

Profile
 
 
   
1 of 2
1