Digital Art Zone

 
     
welding adds edges
Posted: 11 December 2012 11:32 AM   [ Ignore ]
Active Member
RankRank
Total Posts:  281
Joined  0

i have created a cylinder. scaled 4 edge loops from the top, weld and i get new edges as indicated in green and some edges on top loop are unselected and some have disappeared. I havent added any geometry. What gives? Thanx in advance

Image Attachments
welding.png
Profile
 
 
Posted: 11 December 2012 12:42 PM   [ Ignore ]   [ # 1 ]
Power Member
Avatar
RankRankRank
Total Posts:  1388
Joined  2011-01-03

Can you explain everything you did. I see 20 edges around the rim on the left and only 16 edges on the right. I don’t think edges were added here.

 Signature 

- Garstor
Australian-Canadian currently trapped in Texas (maintaining sanity with doses of Carrara, LightWave and PhotoShop)

My 3D art Flickr page for final or near-final images
My 3D art Flickr page for work-in-progress or experiments

Profile
 
 
Posted: 11 December 2012 01:29 PM   [ Ignore ]   [ # 2 ]
Active Member
RankRank
Total Posts:  281
Joined  0

Thanx, what i did was just create a cylinder in the VM, selected 3 faces down all around and scaled with scale tool. thats right i lost some edges after welding and it created edges. see green on right. what am i doing wrong

Profile
 
 
Posted: 11 December 2012 03:26 PM   [ Ignore ]   [ # 3 ]
Addict
Avatar
RankRankRankRank
Total Posts:  4545
Joined  2007-09-13
dot_bat - 11 December 2012 01:29 PM

Thanx, what i did was just create a cylinder in the VM, selected 3 faces down all around and scaled with scale tool. thats right i lost some edges after welding and it created edges. see green on right. what am i doing wrong

If you had 20 edges around the top, to start with and 16 when you were done…that’s where the ‘extras’ on the rest of the item came from…those 4 ‘missing’ edges from around the top.

I’m not quite sure what you are doing wrong, but it looks like you aren’t scaling things evenly.  If you were, then it wouldn’t collapse the edges and all the vertices would still be equidistant.  When you weld (in most modellers) it collapses two ‘close’ vertices into one…and there’s usually a preset distance for this, but it doesn’t really matter.  If you scale something, unevenly, then some vertices will be closer than others and may then fall within the distance of what is counted as ‘weldable vertices’.

You are going to need to find a way to scale what you want so it scales evenly…

Here’s how I would build it in Blender, to give you some idea of what I’m talking about (making sure you keep the edge count the same).

I’d start with a circle and extrude it up several times for the ‘body’ of the item.  The, for the ‘neck’, with the edge loop still selected, I’d scale it down, before the next extrusion.  Then I’d extrude up a couple of more times.  Then I’d close off the top and bottom (a couple of different ways to do that).  But the key is, making sure that when you scale, for the neck, you do so evenly.

Image Attachments
screen44.png
 Signature 

1432 old posts

My ShareCG gallery.

Just because something costs a lot, doesn’t mean it’s the best…

It just means it’s expensive.

Profile
 
 
Posted: 11 December 2012 04:02 PM   [ Ignore ]   [ # 4 ]
Member
Avatar
Rank
Total Posts:  49
Joined  0
dot_bat - 11 December 2012 11:32 AM

i have created a cylinder. scaled 4 edge loops from the top, weld and i get new edges as indicated in green and some edges on top loop are unselected and some have disappeared. I havent added any geometry. What gives? Thanx in advance

Welding merges points, as I’m sure you know, and the function has multiple options. It the image attached, I have selected four points and have chosen to “Weld Selected Verticies” which takes all the selected points, finds their center-point and merges them into one point at that centerpoint.

It sort of looks like you tried to select the entire model and weld it? Not going to get great results with that.

Perhaps you are trying to decimate, tesselate, subdivide or triangulate your model? In the modeler view, you will find those functions under the “Model” menu.

[EDIT]: You will notice that in my example I have created four non-planar polygons - you alway want to fix that.

Image Attachments
Screen_Shot_2012-12-11_at_4.52_.31_PM_.pngScreen_Shot_2012-12-11_at_4.52_.18_PM_.png
Profile
 
 
Posted: 11 December 2012 04:06 PM   [ Ignore ]   [ # 5 ]
Active Member
RankRank
Total Posts:  281
Joined  0

I will try the extrude as you have done and redo the cylinder [pretty sure i scaled evenly but i’ll try again]. thanx for replies back later with results

Profile
 
 
Posted: 11 December 2012 04:14 PM   [ Ignore ]   [ # 6 ]
Active Member
RankRank
Total Posts:  281
Joined  0
mjc1016 - 11 December 2012 03:26 PM
dot_bat - 11 December 2012 01:29 PM

Thanx, what i did was just create a cylinder in the VM, selected 3 faces down all around and scaled with scale tool. thats right i lost some edges after welding and it created edges. see green on right. what am i doing wrong

If you had 20 edges around the top, to start with and 16 when you were done…that’s where the ‘extras’ on the rest of the item came from…those 4 ‘missing’ edges from around the top.

I’m not quite sure what you are doing wrong, but it looks like you aren’t scaling things evenly.  If you were, then it wouldn’t collapse the edges and all the vertices would still be equidistant.  When you weld (in most modellers) it collapses two ‘close’ vertices into one…and there’s usually a preset distance for this, but it doesn’t really matter.  If you scale something, unevenly, then some vertices will be closer than others and may then fall within the distance of what is counted as ‘weldable vertices’.

You are going to need to find a way to scale what you want so it scales evenly…

Here’s how I would build it in Blender, to give you some idea of what I’m talking about (making sure you keep the edge count the same).

I’d start with a circle and extrude it up several times for the ‘body’ of the item.  The, for the ‘neck’, with the edge loop still selected, I’d scale it down, before the next extrusion.  Then I’d extrude up a couple of more times.  Then I’d close off the top and bottom (a couple of different ways to do that).  But the key is, making sure that when you scale, for the neck, you do so evenly.

yes i selected the whole model and welded. i wanted to merge any duplicate vertices, no good?

Profile
 
 
Posted: 11 December 2012 05:22 PM   [ Ignore ]   [ # 7 ]
Power Member
Avatar
RankRankRank
Total Posts:  1059
Joined  2007-10-15
dot_bat - 11 December 2012 04:14 PM

yes i selected the whole model and welded. i wanted to merge any duplicate vertices, no good?

It’s fine to select the entire model and weld, as long as:

1. You have a really good reason to do it (ie, you suspect there really are unnecessary duplicate vertices), and

2. You have the tolerance set correctly

Based on what you said you did, and based on normal modelling practices, you shouldn’t need to do any welding to remove dups when you’re building a new model. Maybe if you import a trashy model, or for some other reason, but normally it shouldn’t be needed.

Doing any modelling operation that isn’t needed is just asking for trouble. If you really suspect duplicates, then make certain you have the correct tolerance setting. Otherwise you’ll weld points that you don’t want to weld.

Unfortunately, Carrara is really, really bad in providing tools and information to repair bad/duplicate/whatever points and polygons, so there’s a bit of guesswork in mesh repair. OTOH, some apps actually TELL you when you have duplicate points. What a concept, huh?  smile

Profile
 
 
Posted: 12 December 2012 04:13 PM   [ Ignore ]   [ # 8 ]
Member
Avatar
Rank
Total Posts:  49
Joined  0

I pretty much agree with JoeMama (not necessarily yo mama). As he said, if your goal is to make sure there are no duplicate points, you can use weld with the thresholds , but this seems extremely uncommon unless, like JoeMama said, you imported some trashed model. If you created it yourself, I can’t really imagine much of a reason for this.

So after you manipulated the four “edge loops” what made you think that points were duplicated to prompt you to use the Weld tool? They should have been fine.

Profile
 
 
Posted: 12 December 2012 04:32 PM   [ Ignore ]   [ # 9 ]
Active Member
RankRank
Total Posts:  281
Joined  0

After scaling i had no more continuous edge loops, welding fixed them in other models. all i did was scale 4 rows of edges. if after welding it didnt add any vertices the model should have remained the same, no?

Profile
 
 
Posted: 12 December 2012 06:15 PM   [ Ignore ]   [ # 10 ]
Member
Avatar
Rank
Total Posts:  239
Joined  2006-01-21

Simply scaling will not add any more geometry or break anything. I don’t know why you are saying it is breaking your edge loops. If you mean that the edge selection stops at the angle caused by the scaling, then that’s normal and is adjustable in the options.

I think you’re also mis-understanding what weld does.

Welding removes verteces by combining the selection into one. Some modellers default to welding within a distance tolerance, or have a separate function for cleaning up duplicates and auto welding them.

In Carrara that is all under one function as you have discovered. By choosing ‘weld all selected’ the ‘middle point’ between all points will be calculated and all the points will be combined into that. You could collapse the entire model into one point.

For cleaning up a model you must select the tolerance option based on the closest valid distance between verteces on your model, although this still respects the vertex selection so you can target it more accurately.

Edit: Sorry, I forgot that Carrara does have a ‘remove duplicate points’ and ‘merge coplanar faces’ option under the model menu. I knew I’d used it in some apps, couldn’t remember which ones.

 Signature 

http://roguepilot.deviantart.com/
http://www.renderosity.com/mod/gallery/browse.php?username=RoguePilot
http://www.ShareCG.com/pf/full_uploads.php?pf_user_name=RoguePilot

Profile