Digital Art Zone

 
   
1 of 2
1
What’s best to reduce lighting artifacts?
Posted: 29 November 2012 08:09 AM   [ Ignore ]
Addict
Avatar
RankRankRankRank
Total Posts:  2900
Joined  2009-02-24

In the example render below you’ll notice I’m getting ‘patchy’ spots very noticeably on the female’s legs. This is a simple render only using two distant lights, one of which set to use raytraced shadows and the other acting on a lower intensity to provide more ambient lighting to the scene. The original used UberEnvironment2 but proved even more patchy, even with a high quality setting.

I suppose really I have two main questions. Firstly, what could be causing this peculiarity, and secondly what can be done about it to give a smoother lighting effect? Lighting is a tricky mistress which I’m hoping to get full control over, so feel free to ‘educate’ me on its finer points as necessary.

Image Attachments
Wrong_Foot.png
 Signature 

Find me on DeviantArt
Download my free IBL presets for Luxus
Re-upload of Cresent’s awesome pwToon shaders
Create your own Smart Content

Profile
 
 
Posted: 29 November 2012 08:42 AM   [ Ignore ]   [ # 1 ]
Active Member
Avatar
RankRank
Total Posts:  722
Joined  2012-07-21

Lowering the shading rate might fix this. I usually have it at 0.1 or 0.2

 Signature 

my freebies at ShareCG
me at DeviantArt

Profile
 
 
Posted: 29 November 2012 08:48 AM   [ Ignore ]   [ # 2 ]
Power Member
Avatar
RankRankRank
Total Posts:  1336
Joined  2006-03-14

What you’re seeing is Ambient Occlusion patchiness.  This is a result of UberEnvironment settings.  Even the “high” setting isn’t great for avoiding this unless the other lights are casting the primary (raytraced) shadows.

Read more about it in my Learning UE2 thread: http://www.daz3d.com/forums/viewthread/5320/

Alternatively, adjust the Shading Rate on UE2 itself to be 1.00 (down from 8.00 on the 4x High preset) and see if that does the trick.  Go lower if not satisfied.

 

 Signature 

My Tutorials and Freebies Index

Profile
 
 
Posted: 29 November 2012 08:54 AM   [ Ignore ]   [ # 3 ]
Addict
Avatar
RankRankRankRank
Total Posts:  2900
Joined  2009-02-24

That might be true for the UberEnvironment, but the above render is just using two ‘distant’ lights and getting the same effect. No occlusion settings have been applied beyond that. I’ll have a play with the shading rate anyway, as that might help reduce the problem.

 Signature 

Find me on DeviantArt
Download my free IBL presets for Luxus
Re-upload of Cresent’s awesome pwToon shaders
Create your own Smart Content

Profile
 
 
Posted: 29 November 2012 09:12 AM   [ Ignore ]   [ # 4 ]
Addict
Avatar
RankRankRankRank
Total Posts:  7991
Joined  2009-05-14

Looks like you are using soft shadows too. Shading rate and Shadows Samples will probably fix the issue. As mentioned already try 0.20 for the Shading rate first and lower if needed. Shadow Samples 20 - 24

 Signature 

Pete

Somethings to Consider when starting to learn CG

My Gallery

My Render Thread and Tutorials

Proud member of the Bald Wizards Club and Co-operative

Profile
 
 
Posted: 29 November 2012 09:33 AM   [ Ignore ]   [ # 5 ]
Addict
Avatar
RankRankRankRank
Total Posts:  2900
Joined  2009-02-24

I can’t seem to find shadow sample settings anywhere either in the regular lights or the UberEnvironment ones. Right now I’m rendering an ‘experiment’ using IDL UE lighting to see what pretty effects I can get out of the scene. As you can imagine, it’s chewing my processor up a bit, so I don’t expect it to finish rendering for at least another twenty minutes. That said, I’ve been adding to the scene since the last render so it has even more work to do.

At least it’s looking more like daytime rather than a weird dusky shade.

 Signature 

Find me on DeviantArt
Download my free IBL presets for Luxus
Re-upload of Cresent’s awesome pwToon shaders
Create your own Smart Content

Profile
 
 
Posted: 29 November 2012 09:34 AM   [ Ignore ]   [ # 6 ]
Active Member
Avatar
RankRank
Total Posts:  722
Joined  2012-07-21

Shading rate and shadow samples settings are in your advanced render settings, not in lights parameters.

 Signature 

my freebies at ShareCG
me at DeviantArt

Profile
 
 
Posted: 29 November 2012 09:52 AM   [ Ignore ]   [ # 7 ]
Addict
Avatar
RankRankRankRank
Total Posts:  2900
Joined  2009-02-24

Thanks for that. See, I’m still learning!

That said, so far the IDL render is looking very nice indeed. Good enough, perhaps, for a final image. It’s nice and bright, there is good shadowing and the depth of field really adds a great effect to the whole ensemble. I’m still a ways from producing the incredibly high quality work I’ve seen on some of the promotional renders for Daz products, but it’s a fun path to my goals. I’ll put the render up here if it ever finishes rendering this side of christmas.

 Signature 

Find me on DeviantArt
Download my free IBL presets for Luxus
Re-upload of Cresent’s awesome pwToon shaders
Create your own Smart Content

Profile
 
 
Posted: 29 November 2012 10:20 AM   [ Ignore ]   [ # 8 ]
Active Member
Avatar
RankRank
Total Posts:  722
Joined  2012-07-21
HeraldOfFire - 29 November 2012 09:52 AM

Thanks for that. See, I’m still learning!

Oh, me too. I learned this from Szark not long ago, he really knows a lot bout this stuff. Thought i’d share the knowledge smile

Happy rendering, and please do share your image when finished. Would like to see the final version.

 Signature 

my freebies at ShareCG
me at DeviantArt

Profile
 
 
Posted: 29 November 2012 10:32 AM   [ Ignore ]   [ # 9 ]
Addict
Avatar
RankRankRankRank
Total Posts:  7991
Joined  2009-05-14
BlackFeather1973 - 29 November 2012 10:20 AM
HeraldOfFire - 29 November 2012 09:52 AM

Thanks for that. See, I’m still learning!

Oh, me too. I learned this from Szark not long ago, he really knows a lot bout this stuff.

No I don’t, please stop spreading rumours about me…it’s all lies I tell ya all lies. smile The truth is I only know a fraction. raspberry

Sorry HeraldOfFire yes I should have mentioned the Advanced Render Settings Pane. This is your Quality box for the most part. Some advanced Shaders and Lights can have additional quility settings in either the Parameters Pane or like Area Lighting their light parameters are in the Surfaces Pane.

 Signature 

Pete

Somethings to Consider when starting to learn CG

My Gallery

My Render Thread and Tutorials

Proud member of the Bald Wizards Club and Co-operative

Profile
 
 
Posted: 29 November 2012 10:36 AM   [ Ignore ]   [ # 10 ]
Power Member
Avatar
RankRankRank
Total Posts:  1336
Joined  2006-03-14

Sorry I didn’t read close enough to see that you’d already removed UE2 from the equation.  Depth of Field will cause pixelation as well.  Increasing the X/Y Pixel Samples on the advanced render tab should clean up pixelation from Depth of Field.  Try 12 or so each to start.

 Signature 

My Tutorials and Freebies Index

Profile
 
 
Posted: 29 November 2012 10:37 AM   [ Ignore ]   [ # 11 ]
Addict
Avatar
RankRankRankRank
Total Posts:  2945
Joined  2011-12-10

Guys, is the shading rate and shadow settings the solution to all render artifacts?  I’m getting some very different ones… This is one type.

This is one type of issue I’m seeing (not the only one), sort of shadow lines…

I have UE2, shading rate is 8, Shadow Samples is 16 (on the render settings, I couldn’t find Shadow Samples on the UE2 settings)

Image Attachments
shadowlines.jpg
 Signature 

My DeviantArt Galleries
My ShareCG Gallery
OPENSUBDIV Testing and Discussion
3Delight Surface and Lighting Thread

Profile
 
 
Posted: 29 November 2012 10:44 AM   [ Ignore ]   [ # 12 ]
Addict
Avatar
RankRankRankRank
Total Posts:  2900
Joined  2009-02-24

Okay, well the render finished but there’s a few tweaks which I need. The big thing you’ll note is there’s no directional shadows. Adding another light seems to bleed out the scene, and I’m not sure there’s a way to have raytraced shadows with light illumination turned off.

The UE2 lighting works fine for the giving the scene a nice polished look, but the lack of a good shadow leaves me wondering where the sun vanished to. I’m assuming there’s no way to get the UE light itself to cast raytraced shadows from its origin, so I presume I’ll need a second light for the raytracing. How can I add one without blowing out the entire scene?

Image Attachments
Wrong_Foot.png
 Signature 

Find me on DeviantArt
Download my free IBL presets for Luxus
Re-upload of Cresent’s awesome pwToon shaders
Create your own Smart Content

Profile
 
 
Posted: 29 November 2012 10:59 AM   [ Ignore ]   [ # 13 ]
Addict
Avatar
RankRankRankRank
Total Posts:  2945
Joined  2011-12-10

I’m wondering if there’s ever a way to render a shadow layer… I think that would solve bunch of problems…

 Signature 

My DeviantArt Galleries
My ShareCG Gallery
OPENSUBDIV Testing and Discussion
3Delight Surface and Lighting Thread

Profile
 
 
Posted: 29 November 2012 11:03 AM   [ Ignore ]   [ # 14 ]
Addict
Avatar
RankRankRankRank
Total Posts:  2945
Joined  2011-12-10

While I’m at it, here’s another one I’m seeing, usually, if not always, around anything transparency mapped.  Same Settings as above.

Image Attachments
artifact.jpg
 Signature 

My DeviantArt Galleries
My ShareCG Gallery
OPENSUBDIV Testing and Discussion
3Delight Surface and Lighting Thread

Profile
 
 
Posted: 29 November 2012 11:05 AM   [ Ignore ]   [ # 15 ]
Power Member
Avatar
RankRankRank
Total Posts:  1336
Joined  2006-03-14
HeraldOfFire - 29 November 2012 10:44 AM

The UE2 lighting works fine for the giving the scene a nice polished look, but the lack of a good shadow leaves me wondering where the sun vanished to. I’m assuming there’s no way to get the UE light itself to cast raytraced shadows from its origin, so I presume I’ll need a second light for the raytracing. How can I add one without blowing out the entire scene?

A couple of ways. 

1) Reduce the light intensity of UE2 before adding other lights.

2) Use an HDR Map for a UE2 environment map.  Look at the preset “Set HDR KHPark” for UE2.  You’ll see it is a nice outdoor lighting seen with a clear “sun” indicated.  That’s not all you have to do though, you also have to change the lighting mode for UE2 from the default “Occlusion w/Soft Shadows” to “Occlusion w/Directional Shadows” or “Indirect Light w/Directional Shadows”. 

Hint:  Unlock the all the scale and XYZ translations of the UE2 sample sphere (on the scene tab, expand the UE2 light, select Environment Sphere, switch to parameters tab, use the paramters tab context menu to Show Hidden parameters, remove locks on XYZ Scale and the global scale, as well as the XYZ translation).  You can then change the global scale of the UE2 EnvironmentSphere to, oh, 5%.  Do NOT unlock the rotation settings.  You CAN however, translate the sphere without effect on the render to, say, avoid the sphere being hidden by content in the scene.  Make certain you switch your selection back to the main UE2 light on the scene tab, use the Y-axis rotation to move UE2 around so you can tell where the sunlight is supposed to shine, render and you should have your directional shadows.

 

 Signature 

My Tutorials and Freebies Index

Profile
 
 
   
1 of 2
1