Digital Art Zone

 
     
I can’t make a primitive into a smart prop
Posted: 20 November 2012 02:47 AM   [ Ignore ]
Member
Rank
Total Posts:  47
Joined  2009-10-14

I’ve created a primitive sphere and parented it to the finger bone in V4.

I choose to save it as a prop, and I’m given the option to save it.  There’s a drop down for “Set Content Type” that’s blank so I ignore that.

I set the name and save the file to the directory I’ve created as a subfolder of props.

I then restart DAZ and browse to the folder I’ve created through the Content Library.  There’s nothing there.  I can choose to “browse to the folder location” and the props I’ve created are there. 

So I think what’s going on is that the type of content isn’t recognized because for some reason the system won’t let me set that type.

Is there a limitation to using primitives as props?  Can you not set their content type, or is my installation just broken?

Profile
 
 
Posted: 20 November 2012 04:01 AM   [ Ignore ]   [ # 1 ]
Addict
Avatar
RankRankRankRank
Total Posts:  6947
Joined  2005-08-15
Bongzilla - 20 November 2012 02:47 AM

I’ve created a primitive sphere and parented it to the finger bone in V4.

I choose to save it as a prop, and I’m given the option to save it.  There’s a drop down for “Set Content Type” that’s blank so I ignore that.

I set the name and save the file to the directory I’ve created as a subfolder of props.

I then restart DAZ and browse to the folder I’ve created through the Content Library.  There’s nothing there.  I can choose to “browse to the folder location” and the props I’ve created are there. 

So I think what’s going on is that the type of content isn’t recognized because for some reason the system won’t let me set that type.

Is there a limitation to using primitives as props?  Can you not set their content type, or is my installation just broken?

How are you saving as a Prop, and what version of DAZ Studio are you using (Help > About DAZ Studio).

I am using 4.5.1.6, the latest version, and I parented a sphere to V4 right index finger.  I went to Save As > Wearable(s) Preset…, and I had to select V4 in the Scene tab first.  On the screen that popped up, I selected the parented Sphere, and DS saved it as a .DUF file into my DAZ Studio Formats under Presets > Wearables.

No matter what pose V4 is in, when I load the saved Wearable, it always parents itself to V4’s finger, no matter where that is, so it is a smart prop.  Can you try that, or are you using an older version?

Profile
 
 
Posted: 20 November 2012 07:02 AM   [ Ignore ]   [ # 2 ]
Member
Rank
Total Posts:  47
Joined  2009-10-14

I’m still using 4.0.3.47, and I’d prefer to avoid upgrading since every time I’ve done in the past, it breaks pretty much everything I’ve done.

I mean unless there is some kind of known bug that I’m not seeing,  I don’t see why I should need to upgrade to make something as simple as a prop.

In any case the process SHOULD work as I’m doing it now.  It’s exactly the process described in their own tutorial.

Profile
 
 
Posted: 20 November 2012 08:27 AM   [ Ignore ]   [ # 3 ]
Addict
Avatar
RankRankRankRank
Total Posts:  6947
Joined  2005-08-15

There were several versions after 4.0.3.47 as far as I know, perhaps you could reset your downloads to see if you get a later version.

I haven’t heard much about 4.5 breaking things that were made in DS4.  DS4 Scene files should open without a problem, plugins will need to be upgraded as 4.5 uses the new SDK.

Profile
 
 
Posted: 20 November 2012 10:27 AM   [ Ignore ]   [ # 4 ]
Member
Rank
Total Posts:  47
Joined  2009-10-14

Well I’ve tried it on another machine, with the same version.  On this one it allows me to choose the type of content (prop) but it doesn’t appear to create the icons for the prop within the selected subfolder.  I have to load the prop by doing a File/Merge and loading the prop file individually.  So there MAY be something wrong with the other system but more than anything it just looks like the icons for the prop aren’t being created where they are supposed to be.

Profile
 
 
Posted: 20 November 2012 02:16 PM   [ Ignore ]   [ # 5 ]
Active Member
Avatar
RankRank
Total Posts:  480
Joined  2010-06-18

Hi…

4.0.3.47 was the last released version of DS 4.0 before the switch to 4.5… and it used an incomplete version of DSON and the SDK

I believe, if I remember correctly, that there where some issues with Prop saving… if the files do exist in the proper location, and it is just the icons that are missing, then just render some 91 x 91 icons and name them the same and place them in the same location. Then you should see them in the Content Library…

As for the content type in the save dialog… that is for meta-data and is not required if you don’t use the Smart Content pane….

If the drop down menu is empty or only says none, then that would indicate that the CMS is not running

If your prop is meant to be a wearable accessory on the figure, you might want to try the method that Jimmy suggested as that is what that was made to do and doesn’t have all the extra boxes to fill out… just a suggestion…

Hope this helps… smile

Profile