How do I get Hexagon 2.5.1.79 to produce a crash log

marco75marco75 Posts: 0
edited December 1969 in Hexagon Discussion

On my system, Hexagon crashes on load, during the splash screen.

How can I make it output a crash log so I can troubleshoot the problem?

Thanks for reading.

Windows System Info
================

see attachment

Catalyst Control Center
=================

Driver Packaging Version 9.002-120928m-149042C-ATI
Catalyst Version 12.10
Provider Advanced Micro Devices, Inc.
2D Driver Version 8.01.01.1266
2D Driver File Path /REGISTRY/MACHINE/SYSTEM/ControlSet001/Control/CLASS/{4D36E968-E325-11CE-BFC1-08002BE10318}/0001
Direct3D Version 9.14.10.0926
OpenGL Version 6.14.10.11931
Catalyst Control Center Version 2012.0928.1532.26058

Comments

  • afreaginnameafreaginname Posts: 0
    edited November 2012

    marco75 said:
    On my system, Hexagon crashes on load, during the splash screen. How can I make it output a crash log so I can troubleshoot the problem?

    You just gave us all the info you need. Your problem is right here:


    Catalyst Control Center
    =================

    I've used ATI in my systems for many years, and I've never seen a single advantage that CCC provides.

    And oh BTW, it has a tendency to crash hexagon. :)

    I advise people to remove it completely (I never install it in the first place), but if you're uncomfortable with that there's a tweak you can do on it that apparently stabilizes it for hexagon.

    Unfortunately, I can't remember offhand what that tweak is. It's a simple one, involving turning off one of catalyst's controls. It may be opengl or video acceleration, but I'm just not sure. I'll see if I can find the thread where it was mentioned previously.

    In the meantime, you can either uninstall catalyst, experiment with the settings I gave you or wait to see if someone who knows the specific tweak I'm referring to comes along. :)

    The good news is that it's an easy fix. :)


    ADD:

    Found it! :)

    Turn of "triple buffering".

    This fix was mentioned as a possibility by Laschae in this post: http://www.daz3d.com/forums/viewreply/98146/

    To which the user responded "IT WORKED!!!!!!!!!!!!!! Disabling the “Triple Buffer” in the OpenGL settings of the CCC solved the issue!!!!!!!!!!!!"

    Post edited by afreaginname on
  • marco75marco75 Posts: 0
    edited December 1969

    That did the trick. I created an Application Profile in CCC for hexagon.exe to turn off OpenGL triple buffer.

    Strangely, I have to use a seperate utility (D3DOverrider) to force vsync and triple buffer for Direct3D apps and games.

    "Send to Hexagon" (Studio <-> Hexagon Bridge) works as expected, too.

    Thanks afreaginname!

Sign In or Register to comment.
Rocket Fuel