Digital Art Zone

 
     
Problem with animate2 keyframes
Posted: 01 June 2012 04:35 PM   [ Ignore ]
New Member
Total Posts:  16
Joined  2003-10-09

In Daz Studio 4, I created an aniblock from the timeline for Aiko 3. There are no keyframes on the DS timeline except for frame number 1 and I only have 2 keyframes for her in the aniblock. My problem is that I can’t get rid of the pose that is between the 2 aniblock keyframes.
They are for her hand in a closed pose. In between the two aniblock keyframes, the hand is in an open pose. I had hoped that the two end frames with closed hand poses would cause the in between frames to also be a closed hand.
Since that didn’t work, I tried pasting a closed hand keyframe on the in between frames in the aniblock and it had no effect. I don’t understand why pasting a keyframe that I created (with and without the hand selected) doesn’t change the pose of the hand!
I’ve tried selecting all the in between frames in the aniblock and setting a zero key and that didn’t work either.  I tried clearing all keyframes and starting over. I’ve tried doing the pasting of keyframes in the aniblock on the base layer and level 1 with the hand selected and with just Aiko selected and nothing worked - the inbetween hand remains in an open pose. What am I doing wrong?

Profile
 
 
Posted: 01 June 2012 09:12 PM   [ Ignore ]   [ # 1 ]
Member
Avatar
Rank
Total Posts:  162
Joined  2006-05-14

Have you tried - on the menu at the top left of the Parameters Tab - Clear Animation > Clear Figure Pose? That should clear out all the DAZ Studio Timeline keyframes.

Or what if you save the aniBlock out to disk (right click the aniBlock). Start a new scene and load Aiko 3. Then bring back the aniBlock. Does that work?

Profile
 
 
Posted: 04 June 2012 03:19 PM   [ Ignore ]   [ # 2 ]
New Member
Total Posts:  16
Joined  2003-10-09

Carnite-

Thanks for your reply. I tried your first suggestion to clear the animation and that didn’t help. For the second suggestion, I saved out the aniblock but couldn’t figure out how to bring it back after loading the original Aiko character. And even if I could bring it back, I would have a problem with Aiko because I did all kind of custom stuff with her, so I’d need to be able to load her with my changes.  As a result, I can only try your aniblock suggestion if someone can tell me how to save Aiko with her custom clothes and shading, etc. and then tell me how to bring her and the aniblock back.

Profile
 
 
Posted: 04 June 2012 09:10 PM   [ Ignore ]   [ # 3 ]
Member
Avatar
Rank
Total Posts:  162
Joined  2006-05-14

I tend to do my animation on a plain blank unmorphed figure, as it’s easier and smoother to animate. Then I save out the aniBlock. Then I load my saved scene with the fully clothed morphed figure and load the aniBlock and tweak if necessary.

To save out a custom Aiko, just save the scene - File Menu > Save As > Scene.

To load the custom figure into an existing scene, do File Menu > Merge. Or if you have saved the scene into a Content folder, then you should just be able to find the folder on the Content menu and double click the icon instead of merging.

To save out and restore an aniBlock:

My content folder for DS4 is Documents\DAZ 3D\Studio\My Library. If you have that folder, or one like it, then you should have a subfolder called aniBlocks. Create a subfolder in there for your name, or project name, eg MyAnimals. Then when you save out your aniBlock, save to that folder.

Down at the bottom left of the aniMate2 tab, you should see “aniBlocks” with a little arrow. Click that arrow, and it will show you a little window with your aniBlocks folder, and your folder MyAnimals will appear under one of the plus signs, probably.

You can then click your folder, and your aniBlocks saved in that folder will be arrayed along the bottom of the aniMate2 tab, so you can load them into the scene.

First picture shows my custom folder Caroline with subfolders. Second picture is after I have clicked on the Birds folder.

If you don’t like the window going away all the time, you can right click “aniBlocks” and choose Preferences and untick Auto hide folder picker.

Image Attachments
Screen_Shot_2012-06-05_at_1.08_.30_PM_.png
Screen_Shot_2012-06-05_at_1.08_.07_PM_.png
Profile
 
 
Posted: 04 June 2012 11:46 PM   [ Ignore ]   [ # 4 ]
New Member
Total Posts:  16
Joined  2003-10-09

IT WORKED!  Thank you for the education, carnite. I really appreciate it!

Profile