Digital Art Zone

 
     
export genesis.obj with clothings (or separately) to blender
Posted: 11 November 2012 09:03 AM   [ Ignore ]
Power Member
Avatar
RankRankRank
Total Posts:  1881
Joined  2012-03-24

Hi,,, I seldom use blender,, but I now studying step by step,,
then everytime I failed when I import genesis and figure,,

when I use hexagon,, if I do not use bridge, I can easily adjust setting to export obj as I want,,
but about Blender,,I can export genesis and may make morph ,,if I want,, but I can not import
the clothing obj which saved as obj by daz,,

I select same setting as genesis obj, and clothing obj (both obj are saved from ds ,,)
if I import them as same setting,, the clothing must fit to genesis positon.

but I import them to blender, separately,, the clothing translated to above (blender z axis,,)
and may scale change,,(so far from genesis,, that I have thought there is no obj ,,blender miss
to import obj ^^; try again and again,,  but actually there is clothings far away from genesis,
it fly on the air,,)

so,, please tell me,, what setting do you use for improt obj which saved (expoted) as obj from ds 4.5,,
I have tried again and again to use genesis in blender and make something ,,
but everytime I missed setting just import,,, figures and,, give up TT) 
I have no improved about it,, from May I first touch ds and genesis,, uuuu TT) help please,,

Image Attachments
blehex.JPGble2.JPGble1.JPG
Profile
 
 
Posted: 11 November 2012 11:13 AM   [ Ignore ]   [ # 1 ]
Member
Avatar
Rank
Total Posts:  210
Joined  2011-09-13

I export clothing for Genesis to Blender all the time and I’ve never had this problem. It looks like you are exporting the clothing at a different scale to what you used when you exported Genesis. If you exported both by the same route and method then, unless you change the settings in the DAZ export dialogue, they should match.

Did you perhaps export Genesis earlier by another method? Have you tried exporting Genesis again, by exactly the same method you used for the clothing, immediately after exporting the clothing item so that the settings will be the same?

The only scale setting in Blender on import is Clamp Size and this will only scale downwards. I steer clear of this and leave at 0 as it works in mysterious ways. In your case, I don’t think this is the issue.

Profile
 
 
Posted: 11 November 2012 11:57 AM   [ Ignore ]   [ # 2 ]
Addict
Avatar
RankRankRankRank
Total Posts:  4964
Joined  2008-03-06

Yep.  Looks like you have it set to Poser scale when exporting Genesis but not when you export the clothing.

 Signature 

My store at DAZ.

My Deviantart gallery.

Profile
 
 
Posted: 11 November 2012 12:08 PM   [ Ignore ]   [ # 3 ]
Power Member
Avatar
RankRankRank
Total Posts:  1881
Joined  2012-03-24

yes,,,now I try again,, you are right, though, I did not change setting ,,(I try samethings almost 20 times ^^;
if I missed or change export size,, but everytime,,, I import genesis and clothing , clothings or genesis,
show up strange positon or scale ^^;)

but ,,,,,,,  clamp size zero work !  (picture1)

I everytime export from ds as 100%size,, then change setting of other 3d tools when import obj,,
and when I use clamp size zero, genesis become so big and grid far away,, I tried another scale
eg cramp size 1.00 but genesis become too little,, like been,, so
so may need to more than 10 th scale when improt to blender,, I thought,,,

then I did not try cramp scale 0.00 never,, but it works ,,,
(why,, zero,,,yes it seems defautl value,,, but ,,zero ^^;)

and if I change clamp size eg scale 10 ,
then improt again same obj,, it is same as before,, ^^;  (picture 2)

I imported again same obj as picture 1, just change cramp scale “zero” to “10.00”

now,, I think it is better if export obj as scale 10th or more from ds,,  then import by blender
with clamp size,, zero ^^; (will it work? or not?)

I feel not so good because,, grid is too far away,, so how you change ? or just leave it off as they are?

after load the obj,, if I tweak scale or positon,,,,I think it is difficult when I export and re import to daz ^^;
so how do you set when export from blender??

anyway ,, so thank you red face ,, if you do not tell me about cramp size,, I never try with zero again,,
and may give up ^^; if I can work with genesis in blender,, as same as other user ^^; I hope,,,

================
edited,

and try anothe setting,, export 100% from ds, then cramp size “1.00”,,

so I must need set cramp size “0.00”,,, maybe,,, as for me,,
u,,,uuu,, believe me,, I did not change setting of export from ds,,, TT)

Image Attachments
cramp0.JPGcramp10.JPGcramp1.JPG
Profile
 
 
Posted: 11 November 2012 02:08 PM   [ Ignore ]   [ # 4 ]
Member
Avatar
Rank
Total Posts:  210
Joined  2011-09-13

On the Blender side, keep Clamp Size at 0 when importing and keep Scale at 1 when exporting. Then Blender will not effect the scale. You don’t want two programs affecting the scale!

Choose your scale setting in DAZ obj export and stick to it. Many people say they use Poser scale, which is absolutely fine. Personally I use Lightwave scale which is 1% at export or 1 unit = 1 metre (DAZ scale is big!). The reason I use this is because this is the scale that Blender physics works at (e.g. for cloth simulations). The default cube in Blender is 2 units per side which is 2 metres high, and when you export, say, Genesis at 1% from DAZ and then import into Blender, you will see the default cube is slightly higher than Genesis, which at 2m is what you would expect.

I re-import at 10000% (Lightwave, etc.).

Profile
 
 
Posted: 11 November 2012 06:35 PM   [ Ignore ]   [ # 5 ]
Member
Avatar
Rank
Total Posts:  210
Joined  2011-09-13

The grid is so small because your model is so large! You can make the grid bigger by increasing the viewport display scale. In the viewport press N to bring up the properties panel (press N again to get rid of it when you have finished). Near the bottom of this panel you will see Display. Click the little arrow to open up the display subpanel. In there you will see Scale: set this to 100 for the scale you are using and the grid will be in scale with the model.

With a model at this scale (DAZ 100% export) you will notice that if you scroll too far away it disappears in Blender and I think there are other viewing issues. I think you are better to use a smaller scale, such as Poser (which I think most people use) or Lightwave/Modo, etc. If you change scale, remember to set it to the same scale preset when both exporting and importing with DAZ.

Good luck with morphing with Blender. It works very well (especially with proportional edit) and I find it a lot of fun. You can also use Sculpt mode, which, although is nowhere near ZBrush, is a lot better than it used to be.

 

Profile
 
 
Posted: 11 November 2012 09:55 PM   [ Ignore ]   [ # 6 ]
Power Member
Avatar
RankRankRank
Total Posts:  1881
Joined  2012-03-24

thank you @@; Hiro Protagonist

by your help,,  now I understand clear LOL

I wasted a lot of time to find this,,, ,, TT thank you much,,, )

memorize here,,

(export obj from ds 4.5 to Blender)

In ds 4.5,  set small scale (eg 10% or 2% etc)  and export obj.

in Blender,  must fix the value of clamp size “to zero” then import obj.

======================================================

export obj from Blender to ds,

in Blender, keep Scale at “1.00”  when exporting

in ds , change setting of ds import scale.  (if used 10% export >> 10th scale import,  2% export>> 50th scale import,)

Profile