Digital Art Zone

 
     
DSON performance in Poser on Mac
Posted: 10 November 2012 10:39 PM   [ Ignore ]
New Member
Avatar
Total Posts:  5
Joined  2011-10-13

So, I’ve purchased a bunch of genesis stuff.  I really like how the characters pose/bend much better.  I love the faces I can make with all the morph add-ons.  And the usability of the morphs transferring to all characters is really clutch, as is the automatic match of morphs on clothing is great. but…

I’m having horrific performance troubles.  I have a Mac, OS X 10.8.2 2012 vintage, 16 GB, quad core.  The memory is ample, and the CPU is never being threatened,  but put a couple of pieces of clothing on my character and it grinds to a pathetic, aggravating halt.  Its not being constrained by the hardware - its DSON and Poser.  CPU and Memory is not even being threatened.

For example: 
1) Load M5 character. morph to my heart’s content.  everything appears normal.  Love it, makes me buy more.

Then I start to use it…

2) Run the script to turn sub-divisions off (doesn’t really appear to make a difference, but I do it just in case)
3) Add pants (Bobbie25 Preppy Pants).  Conform to my character.  Run the script to turn off subdivisions again.

so far, so good.  looks good, performance is just a tiny bit off.  Just rotate the camera, or pan a little bit and you see a sub-second drag.

4) add the shirt (Bobbie25 Preppy Shirt).  [slow] conform to my character [really really slow].  run the script to turn off subdivisions again, just in case it is character specific.

now, performance drags unconscionably slow.  all you have to do is rotate the camera. 1. 2. 3. 4. 5. 6. 7. 8. seconds and you can do the next thing.  pan the camera. 1. 2. 3. 4. 5. 6. 7. 8. seconds later you can do the next thing.  Try to turn a dial (bend thigh). 1. 2. 3. 4. 5. 6. 7. 8. seconds later - you’ve only affected the thing by 1 point.  This is aggravating.

So how do you deal with this?  I’m thinking you have to load your character, pose it into a position, load it into a scene, and pray that you got the pose correct, otherwise its another 15 minutes of manipulation!  then take a few minutes I would guess ten at the minimum to load the clothing on it!

Ok, you want more pain?
5) load the vest (Bobbie25 Preppy shirt).  [I gave up keeping time.  It takes a effing long time.]  conform to my character.  [even more effing time]

go ahead, try and move that thigh. just try and slide the dial.  no luck.  spinning circle of pain makes you wait many, many seconds.

So, I’m at a loss.  I love the idea, the usability of genesis and all these really cool morphs - but I can’t give up the performance.  I need my productivity back.  I am ready to ask form my money back, purge these files from my hard drive, and go back to trying to the constraints and drawbacks of M4.

unless….can some one tell me what they did to fix this?  Does this work better on PC/Is this just a Mac issue?

Profile
 
 
Posted: 12 November 2012 09:57 PM   [ Ignore ]   [ # 1 ]
Member
Avatar
Rank
Total Posts:  207
Joined  2004-11-14

I have only problems when applying Clothe to Genesis, it takes AGES before I am ready to conform them.
Other than that , all running with speed.

I have an iMac 64 bit dual Core with 8 Gig Ram.

Profile
 
 
Posted: 14 November 2012 05:10 PM   [ Ignore ]   [ # 2 ]
New Member
Avatar
Total Posts:  5
Joined  2011-10-13

I’ve done some testing and still having problems.  My first tests were with characters i created using the first version of the DSON importer, and they seem to have problems when I clothe them.  Major slow-down with 2/3 pieces of clothing, so that I can’t even move the xyz dials.

So I started with new characters and no morphs, and I can load one and clothe it and it appears to work fine.  There is a little bit of slow-down, but it is less than a second and I can probably deal with it if this is bad as it gets.  But when I add a second character, it slows down again horribly.  6-8 second delay after just moving the camera.  And I can’t even change the xyz dials.

In addition, conforming clothes takes forever.  I can do anything else and come back and still be waiting.  Really, really slow.

Profile
 
 
Posted: 14 November 2012 05:13 PM   [ Ignore ]   [ # 3 ]
Member
Avatar
Rank
Total Posts:  207
Joined  2004-11-14

I wonder if that is a Mac issue only?
I have the dial delays also.

For the time being I shall keep on working with G4 Figures until this problem gets solved.
I love working with Genesis but not for HOURS just to get a few things done.

Profile
 
 
Posted: 24 November 2012 10:48 AM   [ Ignore ]   [ # 4 ]
Member
Avatar
Rank
Total Posts:  35
Joined  2004-04-06

I’m running Poser 2012 on a PC - i7 2600 and 16 Gigs of RAM.  I find that the first time I use a piece of clothing, there is a delay of around 10 seconds for it to load.  After that first time though, it loads as quickly as the non-DSON clothing. 

I’m able to load 4 genesis figures without any slowdown as long as the clothing is simple - a couple of pieces per figure. 

After that I can speed things up again for posing by going to Scripts > DSON Support > Subdivision > Set Subdivision OFF.  Then turn it back on again once I’m finished posing the figures - maybe the subdivision OFF thing might help on the Mac?

Sorry - just re-read your original post and I see that you are turning off the subdivision.  I wonder if this could be associated with your graphics card since your system doesn’t seem that different from mine in terms of hardware.

Profile