Digital Art Zone

 
   
5 of 6
5
DSON Importer for Poser 1.0.0.27 is now available!
Posted: 13 December 2012 07:54 PM   [ Ignore ]   [ # 61 ]
Administrator
Avatar
RankRankRankRank
Total Posts:  9301
Joined  2007-11-06
inspired_art - 13 December 2012 05:21 PM

Traceback (most recent call last):
  File “C:\Program Files (x86)\Smith Micro\Poser 9\Runtime\libraries\Character\DAZ People\Genesis.py”, line 1, in <module>
  import dson.dzdsonimporter
ImportError: No module named dson.dzdsonimporter

Uh, what does this mean?

You should not have content installed under Program Files/Program Files (x86) under Win7 or Vista—the OS protects those folders so the plugin isn’t being allowed to write back to them.

 Signature 

PostgreSQL CMS FAQ
Tutorial: Adding Surfaces in DS
Product Updates: Non-Genesis/G2 DIM Zips
Non-Genesis Items with Metadata
Updated Genesis Products

Profile
 
 
Posted: 13 December 2012 08:05 PM   [ Ignore ]   [ # 62 ]
Power Member
Avatar
RankRankRank
Total Posts:  1720
Joined  2008-11-10
fixmypcmike - 13 December 2012 07:54 PM
inspired_art - 13 December 2012 05:21 PM

Traceback (most recent call last):
  File “C:\Program Files (x86)\Smith Micro\Poser 9\Runtime\libraries\Character\DAZ People\Genesis.py”, line 1, in <module>
  import dson.dzdsonimporter
ImportError: No module named dson.dzdsonimporter

Uh, what does this mean?

You should not have content installed under Program Files/Program Files (x86) under Win7 or Vista—the OS protects those folders so the plugin isn’t being allowed to write back to them.

Also check to see if you have updated to Poser 9/2012 SR3.

Profile
 
 
Posted: 13 December 2012 08:46 PM   [ Ignore ]   [ # 63 ]
Member
Avatar
Rank
Total Posts:  39
Joined  2005-09-19
Male-M3dia - 13 December 2012 08:05 PM
fixmypcmike - 13 December 2012 07:54 PM
inspired_art - 13 December 2012 05:21 PM

Traceback (most recent call last):
  File “C:\Program Files (x86)\Smith Micro\Poser 9\Runtime\libraries\Character\DAZ People\Genesis.py”, line 1, in <module>
  import dson.dzdsonimporter
ImportError: No module named dson.dzdsonimporter

Uh, what does this mean?

You should not have content installed under Program Files/Program Files (x86) under Win7 or Vista—the OS protects those folders so the plugin isn’t being allowed to write back to them.

Also check to see if you have updated to Poser 9/2012 SR3.

Yeah, got it working now. Thanks.

 

Profile
 
 
Posted: 14 December 2012 03:22 AM   [ Ignore ]   [ # 64 ]
Power Member
Avatar
RankRankRank
Total Posts:  2367
Joined  2007-12-13

That’s great,

I usually refer people to the instructions I put in post #49 on the previous page.

CHEERS!

Profile
 
 
Posted: 24 December 2012 07:23 AM   [ Ignore ]   [ # 65 ]
New Member
Total Posts:  5
Joined  0

Hello guys,

Don’t know if anybody succeeded in having DSON working under OSX…

Poser 9 SR3.1, DSON 1.0.013 (currently downloading the latest)
Tested under 10.6.8 and 10.7.2. Different bugs but same nonfunctional result.
Basically the importation fails at some point, generally when “Applying settings to actors”. Poser bombs and quits. Point.
It does work for ONLY ONE character, named Genesis and installed into the DAZ People subdirectory of Poser. Other characters installed at the same place by the same (?) installer just bomb Poser. Other characters installed into other subdirectories bomb too.

I had a lot of troubles so far. Here are some examples:
-The Starter Essentials installer complains “not being able to set 040755 permissions” into the Runtime folder.
I repaired the permissions using the Disk Utility, no changes. I set all the folders and sub-folders to read+write for everybody, no better.

Messing around where DSON is supposed to write the character file, I found several duplicates corresponding to my attempts.
Several were >4MB and seemed complete when opened into a text editor, so I moved them into the Poser Runtime folder.
They do open into Poser, are poseable and etc… but totally invisible in rendering, whatever the settings.

At first I did nothing “by hand”, just following the instructions to install DSON.
So, back to my initial question: anyone having success with DSON and OSX???

Thanks!

—————OOPS, looks like I started another thread instead of adding the message to the right forum———Admins please move it in the right place!!!

Profile
 
 
Posted: 24 December 2012 08:23 AM   [ Ignore ]   [ # 66 ]
Administrator
Avatar
RankRankRankRank
Total Posts:  16747
Joined  2003-10-09

I shall merge it into the DSON importer sticky post. If this was not the thread you meant, please let us know and we can move it again.

 Signature 

Chohole’s Space        NeilV’s Freebies and stuff        Winter Bryce Rendering Challenge        November Freebie Challenge
My DAZ 3D Gallery    11915

Profile
 
 
Posted: 29 December 2012 06:08 AM   [ Ignore ]   [ # 67 ]
Addict
Avatar
RankRankRankRank
Total Posts:  8361
Joined  2009-06-11
Lyel2 - 24 December 2012 07:23 AM

Hello guys,

Don’t know if anybody succeeded in having DSON working under OSX…

Poser 9 SR3.1, DSON 1.0.013 (currently downloading the latest)
Tested under 10.6.8 and 10.7.2. Different bugs but same nonfunctional result.
Basically the importation fails at some point, generally when “Applying settings to actors”. Poser bombs and quits. Point.
It does work for ONLY ONE character, named Genesis and installed into the DAZ People subdirectory of Poser. Other characters installed at the same place by the same (?) installer just bomb Poser. Other characters installed into other subdirectories bomb too.

I had a lot of troubles so far. Here are some examples:
-The Starter Essentials installer complains “not being able to set 040755 permissions” into the Runtime folder.
I repaired the permissions using the Disk Utility, no changes. I set all the folders and sub-folders to read+write for everybody, no better.

Messing around where DSON is supposed to write the character file, I found several duplicates corresponding to my attempts.
Several were >4MB and seemed complete when opened into a text editor, so I moved them into the Poser Runtime folder.
They do open into Poser, are poseable and etc… but totally invisible in rendering, whatever the settings.

At first I did nothing “by hand”, just following the instructions to install DSON.
So, back to my initial question: anyone having success with DSON and OSX???

Thanks!

—————OOPS, looks like I started another thread instead of adding the message to the right forum———Admins please move it in the right place!!!

Yes.  I made a Genesis runtime in users/shared and I’m not having any permissions issues. But everything I’ve done so far ends with a crash.  All dials morphs seem to work for me. Stuff that renders invisible needs the SubD toggled, then it renders. Mac OSX 10.6 PoserPro 2012, although how can the issues be platform specific?

Profile
 
 
Posted: 29 December 2012 11:13 AM   [ Ignore ]   [ # 68 ]
Member
Avatar
Rank
Total Posts:  55
Joined  2007-01-02
ps1borg - 29 December 2012 06:08 AM
Lyel2 - 24 December 2012 07:23 AM

Hello guys,

Don’t know if anybody succeeded in having DSON working under OSX…

Poser 9 SR3.1, DSON 1.0.013 (currently downloading the latest)
Tested under 10.6.8 and 10.7.2. Different bugs but same nonfunctional result.
Basically the importation fails at some point, generally when “Applying settings to actors”. Poser bombs and quits. Point.
It does work for ONLY ONE character, named Genesis and installed into the DAZ People subdirectory of Poser. Other characters installed at the same place by the same (?) installer just bomb Poser. Other characters installed into other subdirectories bomb too.

I had a lot of troubles so far. Here are some examples:
-The Starter Essentials installer complains “not being able to set 040755 permissions” into the Runtime folder.
I repaired the permissions using the Disk Utility, no changes. I set all the folders and sub-folders to read+write for everybody, no better.

Messing around where DSON is supposed to write the character file, I found several duplicates corresponding to my attempts.
Several were >4MB and seemed complete when opened into a text editor, so I moved them into the Poser Runtime folder.
They do open into Poser, are poseable and etc… but totally invisible in rendering, whatever the settings.

At first I did nothing “by hand”, just following the instructions to install DSON.
So, back to my initial question: anyone having success with DSON and OSX???

Thanks!

—————OOPS, looks like I started another thread instead of adding the message to the right forum———Admins please move it in the right place!!!

Yes.  I made a Genesis runtime in users/shared and I’m not having any permissions issues. But everything I’ve done so far ends with a crash.  All dials morphs seem to work for me. Stuff that renders invisible needs the SubD toggled, then it renders. Mac OSX 10.6 PoserPro 2012, although how can the issues be platform specific?

I’m running the DSON script in both P9 and PP2012 under OSX 10.6 on my MacBook Pro with absolutely no problems or crashes at all.  I recognize that my experience may not be the norm, but I did want to say that, at least on my computer, everything works.  If it helps at all, my DAZ Studio content (the My Library path) is located on an external drive (DS4.5 is installed on my local HD, though) and all of the Poser CFs are also installed to the same external My Library path (I don’t have anything but python scripts like the DSON importer installed directly to a Poser folder.  All my runtimes are external).

Good luck and I hope you get it working!

 Signature 

My RDNA Gallery
My DA Gallery

Profile
 
 
Posted: 01 January 2013 06:15 AM   [ Ignore ]   [ # 69 ]
New Member
Total Posts:  5
Joined  0
ps1borg - 29 December 2012 06:08 AM

Yes.  I made a Genesis runtime in users/shared and I’m not having any permissions issues. But everything I’ve done so far ends with a crash.  All dials morphs seem to work for me. Stuff that renders invisible needs the SubD toggled, then it renders. Mac OSX 10.6 PoserPro 2012, although how can the issues be platform specific?

Thanks for the reply… just showing the variety of bugs one can have…

You said “everything I’ve done so far ends with a crash”... meaning it still does not work?

I switched to the latest DSON importer (10.0.0.27) and now the installation seems to work. Though I can’t tell if it is the new importer or any of my fiddling with the folders and installations…
The characters seem to work, and don’t render invisible without having to change any setting.

But… trying to apply any of the “Faces of teens” expressions or “True Love” poses fails with the error message:
NULL (or empty) script name passed to PePythonEngine::DoScript()

On another hand, trying to render ONE Genesis character with just one Pose dynamic hair fails at 4000x2700dpi with some complain about memory… when I have 16GB. This is very likely Poser9 misbehaving.

And eventually, when adding one Genesis character to 5 non-Genesis characters (no clothing, standard-prop hairs except the one for Genesis)... nothing works. Moving a dial or changing its value on the Genesis character just hangs Poser.

The result? BASICALLY NON-WORKING add-on... great value :-(

Profile
 
 
Posted: 01 January 2013 06:23 AM   [ Ignore ]   [ # 70 ]
New Member
Total Posts:  5
Joined  0
Saba Taru - 29 December 2012 11:13 AM

I’m running the DSON script in both P9 and PP2012 under OSX 10.6 on my MacBook Pro with absolutely no problems or crashes at all.  I recognize that my experience may not be the norm, but I did want to say that, at least on my computer, everything works.  If it helps at all, my DAZ Studio content (the My Library path) is located on an external drive (DS4.5 is installed on my local HD, though) and all of the Poser CFs are also installed to the same external My Library path (I don’t have anything but python scripts like the DSON importer installed directly to a Poser folder.  All my runtimes are external).
Good luck and I hope you get it working!

Right, installing on an external HD removes the permissions problem… but most recent installers WON’T offer to install anywhere.
Can you detail exactly what you installed and where? For example, I did not install DS at all…

Profile
 
 
Posted: 01 January 2013 08:18 AM   [ Ignore ]   [ # 71 ]
Member
Rank
Total Posts:  191
Joined  2003-10-09
Lyel2 - 01 January 2013 06:15 AM
ps1borg - 29 December 2012 06:08 AM

Yes.  I made a Genesis runtime in users/shared and I’m not having any permissions issues. But everything I’ve done so far ends with a crash.  All dials morphs seem to work for me. Stuff that renders invisible needs the SubD toggled, then it renders. Mac OSX 10.6 PoserPro 2012, although how can the issues be platform specific?

Thanks for the reply… just showing the variety of bugs one can have…

You said “everything I’ve done so far ends with a crash”... meaning it still does not work?

I switched to the latest DSON importer (10.0.0.27) and now the installation seems to work. Though I can’t tell if it is the new importer or any of my fiddling with the folders and installations…
The characters seem to work, and don’t render invisible without having to change any setting.

But… trying to apply any of the “Faces of teens” expressions or “True Love” poses fails with the error message:
NULL (or empty) script name passed to PePythonEngine::DoScript()

On another hand, trying to render ONE Genesis character with just one Pose dynamic hair fails at 4000x2700dpi with some complain about memory… when I have 16GB. This is very likely Poser9 misbehaving.

And eventually, when adding one Genesis character to 5 non-Genesis characters (no clothing, standard-prop hairs except the one for Genesis)... nothing works. Moving a dial or changing its value on the Genesis character just hangs Poser.

The result? BASICALLY NON-WORKING add-on... great value :-(

This typically sound you are running out of memory. Poser 9 is 32 bit and even with Windows 7/8 64 bit, you will only have access to 4GB - no matter how memory is in your machine. Other OS’s even less. One way to bypass some of this limitation is by rendering in a separate process (can be changed in General Preferences)
If you turn on subdivision with the DSON importer for genesis, it will require LOTS of memory

 

Profile
 
 
Posted: 01 January 2013 04:12 PM   [ Ignore ]   [ # 72 ]
Member
Avatar
Rank
Total Posts:  55
Joined  2007-01-02
Lyel2 - 01 January 2013 06:23 AM
Saba Taru - 29 December 2012 11:13 AM

I’m running the DSON script in both P9 and PP2012 under OSX 10.6 on my MacBook Pro with absolutely no problems or crashes at all.  I recognize that my experience may not be the norm, but I did want to say that, at least on my computer, everything works.  If it helps at all, my DAZ Studio content (the My Library path) is located on an external drive (DS4.5 is installed on my local HD, though) and all of the Poser CFs are also installed to the same external My Library path (I don’t have anything but python scripts like the DSON importer installed directly to a Poser folder.  All my runtimes are external).
Good luck and I hope you get it working!

Right, installing on an external HD removes the permissions problem… but most recent installers WON’T offer to install anywhere.
Can you detail exactly what you installed and where? For example, I did not install DS at all…

I installed DS4.5 Pro on my HD and during the installation process, that installer gives you the option of inputting a path that you want to use for content.  So I left the default for the application (it’s in the Applications folder) and changed the content path to my external HD.  For this reason, I already had a “My Library” folder in which to install other content to.  I didn’t have to designate a new one (although I could have if I wanted to).

For the DSON importer, there are three files.  I’m not sure what you mean by the installers not offering to let you install anywhere, though.  All of the installers I have allow me to customize the installation (which allows me to select the location to install the files to).

The DSON importer for Poser file needs to be installed to the base application folder for Poser (the ones in your Applications folder).  As mentioned, you’ll need to install 32 bit or 64 bit as appropriate.  I’m using PP2012 for my DSON content, so I have the 64 bit app installed.  The DSON Core starter essentials file can go anywhere you’d like, so long as the folder has write permissions enabled (this was my external HD in the already existing My Library folder).  I installed the DSON Poser Companion Files for Genesis starter essentials to the My Library folder just to keep them all in one place and so I only had to add one single new runtime to Poser (my way of keeping things straight, but opinions on where it’s best to install what may vary).  If you put the core files and the CF files in different locations, though, you’ll have to add both to Poser.

It does take a few seconds longer than expected to load the very first DS item (like Genesis) into Poser for me, but after that, it’s just like using native Poser content.  No crashes or other weirdness (so far).  Not sure this helps, but I have my fingers crossed you can get this solved.  smile

 Signature 

My RDNA Gallery
My DA Gallery

Profile
 
 
Posted: 02 January 2013 03:31 AM   [ Ignore ]   [ # 73 ]
New Member
Total Posts:  5
Joined  0
Saba Taru - 01 January 2013 04:12 PM

[

Hi Sabu, thanks for the information. I shall give it a try!

Profile
 
 
Posted: 02 January 2013 03:34 AM   [ Ignore ]   [ # 74 ]
New Member
Total Posts:  5
Joined  0
WimvdB - 01 January 2013 08:18 AM

This typically sound you are running out of memory. Poser 9 is 32 bit and even with Windows 7/8 64 bit, you will only have access to 4GB - no matter how memory is in your machine. Other OS’s even less. One way to bypass some of this limitation is by rendering in a separate process (can be changed in General Preferences)
If you turn on subdivision with the DSON importer for genesis, it will require LOTS of memory

Thank you for the information. Don’t know, however, how this applies to OSX which is 64-bit…

Anyway, it sounds more a bug than anything else.
I tried again (had done it previously) the “render in a separate process”, and the only difference is that Poser does NOT display any messsage… but it just stop rendering :-(
Also checked the memory usage during the process, and both Poser9 and FFRender were just a bit over 1GB each.

Plus I have yet rendered HUGE scenes were Poser used 4GB to 6GB.

Go figure…

Profile
 
 
Posted: 02 January 2013 06:01 AM   [ Ignore ]   [ # 75 ]
Member
Rank
Total Posts:  191
Joined  2003-10-09
Lyel2 - 02 January 2013 03:34 AM
WimvdB - 01 January 2013 08:18 AM

This typically sound you are running out of memory. Poser 9 is 32 bit and even with Windows 7/8 64 bit, you will only have access to 4GB - no matter how memory is in your machine. Other OS’s even less. One way to bypass some of this limitation is by rendering in a separate process (can be changed in General Preferences)
If you turn on subdivision with the DSON importer for genesis, it will require LOTS of memory

Thank you for the information. Don’t know, however, how this applies to OSX which is 64-bit…

Anyway, it sounds more a bug than anything else.
I tried again (had done it previously) the “render in a separate process”, and the only difference is that Poser does NOT display any messsage… but it just stop rendering :-(
Also checked the memory usage during the process, and both Poser9 and FFRender were just a bit over 1GB each.

Plus I have yet rendered HUGE scenes were Poser used 4GB to 6GB.

Go figure…

Poser 9 is 32 bit. That means it can only address 4GB. If you do not have separate process set to On, this needs to be shared with the render engine - even if your OS is 64bit. Genesis takes a LOT of memory when the mesh is subdivided.. If memory usage is indeed far below 4GB total, then there is another problem

 

Profile
 
 
   
5 of 6
5