Digital Art Zone

 
     
DSON Import Error when opening Genesis figure in Poser Pro 2012 64-bit
Posted: 30 October 2012 03:23 PM   [ Ignore ]
New Member
Avatar
Total Posts:  7
Joined  2003-10-09

Followed instructions for installation and have Genesis Content in my DAZ Studio folder and have imported the “new” Runtime into Poser, and have a DSON item under Scripts in Poser pro 2012, but get the follwing error when opening up any Genesis figure. I am running Windows 7 64-bit.

Traceback (most recent call last):
  File “C:\Users\David\Documents\DAZ 3D\Studio\My Library\Runtime\libraries\Character\DAZ People\Basic Female.py”, line 1, in <module>
  import dson.dzdsonimporter
ImportError: No module named dson.dzdsonimporter

Profile
 
 
Posted: 30 October 2012 04:46 PM   [ Ignore ]   [ # 1 ]
Member
Rank
Total Posts:  191
Joined  2003-10-09

First question: Do you have SR3 or SR3.1 installed?
Second question: Do you have the embedded library active? If so, does the problem go away if you use the external library (must be set in the General Preferrences)

Profile
 
 
Posted: 31 October 2012 03:55 AM   [ Ignore ]   [ # 2 ]
New Member
Avatar
Total Posts:  7
Joined  2003-10-09

SR3.

General Prefs in Poser Pro?

Profile
 
 
Posted: 31 October 2012 04:00 AM   [ Ignore ]   [ # 3 ]
Member
Rank
Total Posts:  191
Joined  2003-10-09

Edit Menu, General Preferences, Library tab, Launch behavior
It should be set to external. Internal seems to cause a problem. Not saying, this is problem, but set it to external for now

Other question: What is the location where you installed Poser? (full pathname)

Profile
 
 
Posted: 31 October 2012 10:43 AM   [ Ignore ]   [ # 4 ]
New Member
Avatar
Total Posts:  7
Joined  2003-10-09

Will try that setting…

Current path: C:\Program Files\Smith Micro\Poser Pro 2012

I will also try to see if SP 3.1 does anything to “fix” Poser. The program is on SP 3.0, which is within the DSON prerequisites…

Profile
 
 
Posted: 31 October 2012 11:12 AM   [ Ignore ]   [ # 5 ]
Member
Rank
Total Posts:  191
Joined  2003-10-09

Ok, the install location is default for PoserPro 2012 - that is good
If I look at the error message, you seem to load the Genesis figure from a runtime which is imbedded in DAZ Studio

Now it gets tricky. Let me explain what happens, then you can see where the problem might be
The CR2 file which you load activates a python script. This python script calls the DSON Importer. That last call fails and should not happen
If the DSON Importer is executed (which it isn’t at this point), it will load the DUF file from the same location as the cr2 file and the python script; The importer reads it and gets the actual location of the resource/dsf/object file from this duf file. It then loads the rest of the files and constructs a new CR2. This CR2 file is written to a writeable runtime after it instructs Poser to read the new CR2. So the runtime should be different from program files/Smith Micro/Poser Pro 2012 runtime since that location is not writeable in WIndows 7/.Windows 8/Vista due to user permissions. If I remember correctly the installer asks for a location. The default Poser runtime at users/public/Public Documents/Poser Pro 2012 Content is OK but it could be any other external runtime.

That is how it works.
There are a couple of things you should check: Is the addon in the correct location: Addon should be in program files/Smith Micro/Poser Pro 2012/Runtime/Python/addons and the folder is called dson.
Second thing you should check is if the DSON importer is pointing at the correct writeable runtime location. You can do this by running a python script in Scripts!DSON Support!Importer Preferences. Oncve you run it check if this is NOT located in the program files location. Otherwise change it
Next thing to check is if all of the locations which are being references are connected as external runtimes in Poser. In your case C:\Users\David\Documents\DAZ 3D\Studio\My Library should be mapped - it probably is, since you loaded the CR2 from there
Then we get into unknown territory - the DUF file may reference files outside the this external runtime. This depends on how it is saved. If that is the case, you could try to connect the C:\Users\David\Documents\DAZ 3D\Studio folder as a runtime. If Poser won’t let you, create an empty runtime structure at this location and Poser will let you add it.

There are many variables, so it is difficult to say what is wrong

What I did is the following. I created a new runtime called Posergenesis. This is the location where I install all genesis content. The DSON files and the Poser Companion files (so all the essentials - both of them - you did install both of the did you?), Then I added that runtime to Poser.
I kept my DS installation separate from Poser. I only added the Posergenesis runtime to the browseable locations to Studio

I hope this helps

Profile
 
 
Posted: 01 November 2012 12:45 PM   [ Ignore ]   [ # 6 ]
New Member
Avatar
Total Posts:  7
Joined  2003-10-09

Yes your explanation has been most helpful in *understanding* how the DSON importer works.

Apart from changing the Runtime to external in Poser Pro 2012’a prefs, I did nothing much else and the DSON importer still refused to work, but I installed SP 3.1 and IMMEDIATELY the importer worked, with NO other changes. Perhaps DAZ ought to revise their documentation and change the prerequisites to SP3.1 minimum on Poser Pro 2012 instead of the “SR3 or later” as stated.

Thanks again.

Profile
 
 
Posted: 01 November 2012 01:02 PM   [ Ignore ]   [ # 7 ]
Member
Rank
Total Posts:  191
Joined  2003-10-09

I just upgraded one of my machines to Windows 8. I installed a fresh copy of Windows 2012 on it and then the DSON importer.
I then go an ERROR: DLL not found for DSON. I disabled firewall, AV scanner - no change, Ran Poser and installers as admn - no change
Then I decided to update the DSON installer to the latest version (I still had 1.0.9) and it suddenly worked.

Now - who or what caused the problem? Poser, the installer, WIndows 8 or the DSON module? SInce I tried various things it might very well be a combination. I had the 1.0.9 version running on my Windows 7 system (before the upgrade).
So it is difficult to say what causes the problem. Installing 3.1 will reset some of the preference files, so that might have solved it. Or your version of 3.0 was corrupted somehow or maybe because of the SR update the runtimes are re-ordered.

Glad you have it working now

Profile
 
 
Posted: 05 November 2012 08:30 AM   [ Ignore ]   [ # 8 ]
Member
Avatar
Rank
Total Posts:  205
Joined  2004-11-14
WimvdB - 31 October 2012 04:00 AM

Edit Menu, General Preferences, Library tab, Launch behavior
It should be set to external. Internal seems to cause a problem. Not saying, this is problem, but set it to external for now

Other question: What is the location where you installed Poser? (full pathname)

On my Mac the * external * Librarie * causes crashes all sorts of problems when using Genesis.

Profile