Problem with shaders on imported obj. files...

TechymanTechyman Posts: 61
edited December 1969 in Daz Studio Discussion

Good Morning,

I have created some objects in Sketchup and exported them as obj files. When I import them into DS4 Pro, they come in perfectly (except for having to resize). The main problem is that when I apply a texture or shader, it doesn't seem to work properly. The Sketchup object's surface changes to a pale imitation of the base color of the shader applied, but does not show any detail, bump, or displacement even though the settings and maps in the Surface tab show they are all correct. As an experiment, I imported a simple cube obj and then created one directly in DS. I applied the same shader to both and made sure that the Surface settings were exactly the same. The DS cube looked great, but the obj cube turned light gray (the base color of the shader) but did nothing else. Even rendered, the image didn't change. Can anybody please tell me what I'm missing or doing wrong? I'm trying to post a screen capture, but my system isn't cooperating this morning.

I am using DS 4.0.3.47 Pro.

Thanks...

Comments

  • AscaniaAscania Posts: 280
    edited December 1969

    Do UV map your objects.

  • BejaymacBejaymac Posts: 1,179
    edited December 1969

    You need to make sure that what you export from Sketchup has been UV mapped, otherwise all you get is the color from the top left pixel in your texture.

  • TechymanTechyman Posts: 61
    edited December 1969

    Thanks guys,

    I am currently slapping myself on the forehead and thinking "how could I have missed that?" Too many hours, too much caffine, and too much time away from 3d I guess.

    Thanks again!

  • Same issue with importing from blender - how do I create UV map in Daz3D for imported objects? In Blender export options it already set to "collect UV maps" but result is still the same - no texture of shader is applied, only solid color.

  • jestmartjestmart Posts: 3,159

    You UV map it in Blender.

  • AscaniaAscania Posts: 280

    Create the UV mapping in Blender before you export.

  • ebergerlyebergerly Posts: 662

    In any modelling software, the basic steps you must follow are these:

    1. Do your modelling
    2. Apply materials to selected surfaces
    3. UV Map your object(s)
    4. Export or whatever

    And after doing this for years I still sometimes forget steps 2 and/or 3. But you must do them. I think it's a law or something. 

  • hphoenixhphoenix Posts: 1,053

    Not ALL shaders require UV mapping to work.  Most do, but not all.  Those that don't will work find on a non-UV Mapped OBJ.

Sign In or Register to comment.