NLA Clips Problems

Mosk the ScribeMosk the Scribe Posts: 300
edited December 1969 in Carrara Discussion

Is the NLA editor working okay for people in C8.5 Beta (I had problems with the previous beta and just tried with the new one)

I made a simple vertex object, created a couple of morphs, and added the Vertex Object to an Animation group.

I then select the Animation group., Create a Master clip, say Edit clip, go to the vertex model level, adjust the morphs at different points on the time line, the finish editing clip - and the morph values are Not stored in the clip.

Am I doing something wrong, or is there a bug in the NLA clip stuff at this point that prevents making clips?

The way I stumbled onto this in the first place was that I couldn't save phonemes into NLA clips for use with Mimic for Carrara. On simpler testing, realized it wasn't just a problem with that model; having issues with simple vertex object as well.

Thanks for any help or suggestions.

Comments

  • jcrabbjcrabb Posts: 27
    edited December 1969

    I was having the same problem with vertex objects. I added morphs did a little ani then converted to a NLA clip and made the animation group. I was just right clicking on the block and selecting the edit clip...made changes and click on finish and my edits weren't retained. Then I noticed that on the right menu with animation group highlighted at the very bottom is a button/tab that says convert to editable clip. I push this then right click the clip do my edits and when I push the finish editing clip button my changes are retained. Hope this helps...and works for you...using the 8.5 beta 172.
    Jim

  • Mosk the ScribeMosk the Scribe Posts: 300
    edited August 2012

    Hmm . . . still not working for me.
    (and doesn't make a difference whether I right click clip to Edit it or select clip and then use the NLA panel to select Make Editable Clip)

    Whatever changes I make are not retained - whether morphs or motions. Not working at all right now with 8.5 Pro, Build 172, 64 bit for Windows (7)

    Post edited by Mosk the Scribe on
  • jcrabbjcrabb Posts: 27
    edited December 1969

    I'm using 32bit Vista on a single core machine, could be something there. This place has an amazing number of people who just pop up and help...so I am sure help is on the way.
    Jim

  • RoygeeRoygee Posts: 1,885
    edited December 1969

    Just to help narrow it down, I tested and the morphs worked perfectly after editing the NLA - without converting to editable clip. Even changed the morph values and that worked.

    Windows XP 32 bits.

  • jcrabbjcrabb Posts: 27
    edited December 1969

    I thought I had it right...but I think I understand now. I thought my edited NLA was saving the edits, well, yes and no. Yes in the sense for that period of time a single clip was edited. If I copy n paste to extend my animation I get a copy of the original clip without my edits. I managed to make a new NLA clip with just my new edits and in the process it lost all of the original (I did this in between other things and will have to walk myself (hopefully) back threw the process to remember how I did. So sorry if I confussed things...thanks for tweeking my curosity...really something that would be helpful to know.
    Jim

  • Mosk the ScribeMosk the Scribe Posts: 300
    edited December 1969

    Well, I installed the 32 bit version and creating NLA clips worked fine.
    Then went back to the 64 bit 8.5Beta (latest version), performed the identical steps . . . and that worked fine too.

    Not sure how to explain that, since I'd used the same method before and had opened and closed Carrara periodically.

    Will try a model next to see if can create NLA clips for lip synching.

  • Mosk the ScribeMosk the Scribe Posts: 300
    edited December 1969

    Just tried with a model (which had given me problems earlier) and worked perfectly fine.
    No idea what was going wrong before . . .
    Perhaps it's all part of some DAZ plot to make me lose my mind . . .
    :)

    Thanks for the help.

Sign In or Register to comment.
Rocket Fuel