Can't execute the DAZ exe file in MAC OS

2»

Comments

  • TotteTotte Posts: 7,014
    edited December 1969

    Lupin3 said:
    Totte said:
    dePeyrac said:
    yes thanks, found it in the meantime, but not much I can gather from here:

    28/05/12 23:43:00 com.apple.launchd.peruser.502[242] ([0x0-0x83f83f].com.bitrock.installbuilder[16654]) posix_spawn("/Users/WGA Management/Back-up/Poser Anatomy/ps_mr259_V4MuscleMorphs.app/Contents/MacOS/installbuilder.sh", ...): Permission denied

    Told you, permission problems. Where did you unzip the files? In your "downloaded files" or any other place "under" your home directory or somewhere else? This usually happens if you unzip to a directory where you are not really supposed to write stuff.

    You can fix this manually using the terminal
    Start Terminal.app

    type cd then drag the ds.app to the terminal window, now hit
    now type chmod -R +x Contents/


    Now try run it.

    Thanks Totte, this worked for me. However, it must be done for each file to be extracted. A better way when extracting multiple files is to combine them into a new directory, cd into that directory via Terminal, and chmod -R +x */.

    BTW, I downloaded the files via Safari to the default directory, "Downloads" in my user directory. Obviously, this is a defect that will negatively affect many Mac users. I'm not sure why Daz felt the need to use such an unusual file format, but if the permissions issue can't be resolved by them, they should revert to a less problem prone format.

    Turn off the Safari setting "Automatic detect safe files" or something, so it doesn't extract on download, but unzip the zipfiles yourself. I have no problems on 10.7 with that setting, but I hate when Programs tries to be smart but just shit in the fan, like Safari "smart files detection".

  • edited December 1969

    Turns out that my extraction program was the issue - not Daz, not Safari. Using the Unarchiver worked a charm.

    Thanks again for your help, Totte.

  • TotteTotte Posts: 7,014
    edited December 1969

    You're welcome.

Sign In or Register to comment.
Rocket Fuel