Carrara 8.5.0.172 Beta Now Available for Download

DAZ_bfurnerDAZ_bfurner Posts: 0
edited April 2013 in Carrara Discussion

CARRARA 8.5.0.172 is the latest Beta Build!


We are including the 8.5 Beta in your purchase of Carrara 8 or Carrara 8 Pro. You can run the production build of Carrara 8.1 side by side with this Beta build. Just don't uninstall 8.1 version when you install this beta release.


The purpose of providing this build is for you to see the progress we are making, see how Genesis looks in Carrara, see the new features we've added and provide input on the changes. You can also see the list of bug fixes below. This list identifies issues that were logged in the bug tracker and highlights many of the other fixes in this build.


New in Carrara 8.5:
1. Support for imported Genesis DSF, DUF (best used with DAZ Studio 4.5 RC 3 installed).
2. Character presets can be applied. Go to the Instance Tab, select the 2nd Genesis listed in the tree or the Actor line, and double click the character from the list. If the one of these items is not selected, an additional figure will be loaded with that character applied.
3. New Parameters Pane and user experience
4. Carrara 8.5 Parameter Pane. If you are familiar with the Parameters Tab (with the Genesis figure) in DAZ Studio 4, the equivalent to Carrara 8.5 is the Parameter Pane which is accessed by selecting the second Genesis from the list.
5. Shaping in Parameters Pane. If you are familiar with the Shaping Tab in DAZ Studio 4, the equivalent for Carrara 8.5 can be accessed by selecting the Actor line from the tree in the Instance Pane.
6. Content Management System or CMS connection to utilize the DAZ Studio database (requires DAZ Studio 4.0.3.19 or newer recommended to be installed). We are looking into a project to install the CMS for Carrara without the need of DAZ Studio. So for the Carrara customers not using DAZ Studio they can still take advantage of the new system. More information will be coming.
7. AutoFit is included in Carrara 8.5
8. Fit To (auto generates Genesis morphs) for Genesis designed clothing
9. Restore Figure tools
10. Memorize tools
11. Zero Figure tools
12. Smart Content Tab (shows all the content with meta data organized similarly to DAZ Studio's Smart Content Tab)
13. New SubD / Smoothing tool (display the smoothing slider of smoothed vertex object in the assemble room)
14. Improved Bullet Physics for soft body simulation
15. aniBlock importer has been updated and fixed for Carrara 8.5
16. Mac OSX Lion support has been implemented
17. Geo grafting has been implemented and we continue to work on this feature
18. New Light Icons to better represent the lights, the controls have also been improved.
19. DUF Files from DAZ Studio are now supported in Carrara 8.5


If you are seeing issues please log the bugs in the bug tracker: DAZ BUG Tracker


Changes since the last beta build include:
Browser : Fixed : Fixed crash at exit
Carrara : Fixed #0046823 : Added more decimals to the value shader
Carrara : Fixed #0046989 : Fixed default scene settings when importing a syncar file
Carrara : Fixed #0047073 : Fixed crash with data components
Carrara : Fixed #0047180 : Fixed transform saving issue
Carrara : Fixed #0047156 : Fixed issue with NLA where modifiers are not always in synch
Carrara : Fixed #0044751 : Fixed volumetric rendering alpha issue
Carrara : Fixed : Fixed crash in shading room
Carrara : Fixed #0044751 : Fixed volumetric rendering alpha issue
Carrara : Fixed #0047338 : Fixed crash when saving car file
Carrara : Fixed #0047077 : Fixed active tool issue when open a component option dialog
Carrara : Fixed #0047210 : Fixed issue when in edit mode
Carrara : Fixed #0047341 : Fixed shortcut issue with mouse actions (on Windows)
Carrara : Fixed #0047163 : Fixed image format selection issue in exporters
CR2Importer : Fixed #0047152 : Fixed crash when loading cr2 file into an existing scene
DSF : Fixed #0046799 : Fixed DSF loading problem (M5 genitalia)
DSF : Fixed #0046990 : Fixed skinning issue with some legacy content
DSF : Fixed #0047096 : Fixed crash when refreshing the smart content
DSF : Fixed #0046022 : Fixed dsf pose/preset import when the figure geometry node has children
DSF : Fixed : Fixed light and camera size issues
DSF : Fixed #0047129 : Removed automatically added folder to the content browser
Mimic : fixed #46995 : add genesis.dmc to config files
Mimic : Fixed #0047209 : Fixed text file issue when the user does not have write access to the file
Obj Importer : Fixed : Added support for the alpha and alpha maps
Obj Importer : Fixed : Fixed problem when a material has both color/value and a texture map
Obj Importer : Fixed : Added support for bump amplitude extension (Km) used by Studio
Particles : Fixed #0047016 : Redesigned the UI to make the create instance button clearer


What you need to know about this build:


1. If you get a Duplicate ID error, please reset your download for the content and try reinstalling. If the issue persists please place it in the Content Project of the bug tracker (http://bugs.daz3d.com) as we believe we have fixed all of those.
2. Pz2 material Presets do work on Genesis and Triax Content, to include content that has been auto-fit to Genesis now.
3. PZ2 Poses do apply to Genesis
4. DAZ Studio 4.0.3.47 minimum, (4.5 RC3 recommended) must be installed prior to running Carrara 8.5 in order to use Genesis or the Smart Content Tab.
5. If new content with meta data is installed, DAZ Studio will need to be started in order to get the smart content into the CMS database.
6. V4/M4/K4 shaders will not work on Genesis and will have to be manually built.
7. Our development team is working on the tools to transfer data from DAZ Studio 4 to Carrara using our new file format.
8. Included Tree presets may not look the same as they did in Carrara 7, we are looking into this currently.
9. Adding IK to genesis works correctly and as expected, Genesis doesn't load with IK. (In either DS or Carrara)
10. Mimic fixes have been implemented for Gen 4 and earlier.
11. Mimic and Mimic Pro for Genesis is fixed and will be made available to those who have purchases this.
12. Plugins for the previous builds of 8.0 are expected to work with this version.
13. The CMS service is not embedded in this installer. You will need to have installed DS 4.5 RC3 to be able to use that functionality.


To register the Carrara 8.5 Beta you will need to use the serial code listed here: CDZCPRO-085-0031103-AEM-001-EBTQTTT(Expires 21 April 2013)


About Mimic Pro and this build:
If you own Mimic Pro and want to start using it with Genesis, you'll need to download a build just for Carrara 8.5.0.172. You will NOT want to use this with your 8.1 build of Carrara. It won't work with both builds. However, if you install the new version in a different location, you can continue to have both versions on your machine. The same serial number will continue to work for both builds. The DMC files are also included in this new version of Mimic Pro and will work with Genesis.


To see many of the new features and read the latest news on Carrara 8.5 visit CarraraCafe

Post edited by Chohole on
«13456724

Comments

  • holly wetcircuitholly wetcircuit Posts: 0
    edited August 2012

    Spot render is completely blank white.


    ...kind of like our ability to post a warning in the announcement sticky thread since Blane has locked it. :shut:

    ForumImage.jpg
    489 x 615 - 38K
    Post edited by Richard Haseltine on
  • RichardChaosRichardChaos Posts: 0
    edited December 1969

    What's this all about?

  • RichardChaosRichardChaos Posts: 0
    edited December 1969

    the last build I am aware of is 149????

  • BrianP21361BrianP21361 Posts: 208
    edited December 1969

    Richard,

    Build 172 came out late last week. It looks like they've improved a few things, but they completely broke the area render in the Mac version. All you get is a white square.

  • RichardChaosRichardChaos Posts: 0
    edited December 1969

    Richard,

    Build 172 came out late last week. It looks like they've improved a few things, but they completely broke the area render in the Mac version. All you get is a white square.

    TYPICAL!

  • thoromyrthoromyr Posts: 391
    edited December 1969

    Spot render is completely blank white.


    ...kind of like our ability to post a warning in the announcement sticky thread since Blane has locked it. :shut:

    Too late, I already installed it and am having fun with rendering. Works great here.

  • holly wetcircuitholly wetcircuit Posts: 0
    edited December 1969

    thoromyr said:
    Spot render is completely blank white.


    ...kind of like our ability to post a warning in the announcement sticky thread since Blane has locked it. :shut:

    Too late, I already installed it and am having fun with rendering. Works great here.

    Spot Render works for you? Which os? 64bit?


    It is also too late for me.... So far renders seem ok. Shader room seems ok (along with shader room preview).


    Buyer Beware... :smirk:

  • de3ande3an Posts: 531
    edited July 2012

    Seems to be working OK for me on Mac OS X 10.6.8, 64 bit version.

    area_render.png
    800 x 615 - 379K
    Post edited by de3an on
  • thoromyrthoromyr Posts: 391
    edited December 1969

    thoromyr said:
    Spot render is completely blank white.


    ...kind of like our ability to post a warning in the announcement sticky thread since Blane has locked it. :shut:

    Too late, I already installed it and am having fun with rendering. Works great here.

    Spot Render works for you? Which os? 64bit?


    It is also too late for me.... So far renders seem ok. Shader room seems ok (along with shader room preview).


    Buyer Beware... :smirk:

    Everything works great. Spot render, full render, network render. Shaders work great. I haven't had occasion to use the modeling room yet (though that is up). Only thing that's happened is my laptop didn't like waking up from sleep -- I ssh'd in and it was fine, but the login process was hung. I gave it a signal (via kill) and that restarted -- unfortunately it killed my gui login as well so I lost work in Carrara. But that is hardly Daz's fault.

    Despite the thread title there's no reason I can see for mac users to not install this beta.

  • de3ande3an Posts: 531
    edited December 1969

    Holly, thoromyr, BrianP21361,
    Which Mac OS versions, and Carrara (32 or 64 bit) versions are you using?
    Maybe there's a pattern.

  • RichardChaosRichardChaos Posts: 0
    edited December 1969

    ARE any of you using LION 10.7 or MOUNTAIN LION 10.8?

  • BrianP21361BrianP21361 Posts: 208
    edited December 1969

    I'm running the latest build on Lion and Mountain Lion on an iMac and a new MacBook. Both systems are 64 bit and show the white square when I use the area render.

  • thoromyrthoromyr Posts: 391
    edited December 1969

    OS X 10.7.4 (Lion), Carrara 8.5.-172 64-bit. While I appreciate that Daz is providing support for older macs by making the 32-bit version available those are pretty old at this point.

  • holly wetcircuitholly wetcircuit Posts: 0
    edited December 1969

    Also osX.7.4 Lion. Carrara 8.5 - 172 64bit Mac Mini (early 2009)

    Animation render seems fine. Haven't had a lot of time to test but SPOT RENDER only renders a white square. Although it is clearly thinking hard about it and doing the full light calculation as the Spot Render slowly fills in white...

  • holly wetcircuitholly wetcircuit Posts: 0
    edited December 1969

    Eh, the Shader Room preview *is* effected.... The preview first fills in with white, then the the actual image blinks in. So the process of showing the live preview seems to take longer and is *very* annoying to look at. Rotating a model in the Shader Room preview gives me white flashes like a strobe light.... It's actually really distracting.


    Also you don't appreciate a feature until it's gone, but now I realize I use Spot Render on the Left, Right, and Top views in the Assembly Room..., since there is no actual render camera for those views.

  • de3ande3an Posts: 531
    edited July 2012

    Since thoromyr is not having the problem on his Lion instillation, it must be something besides a purely Mac OS incompatibility.
    Maybe it's an OpenGL thing. If those who are seeing the problem could change their Interactive Renderer setting from "OpenGL" to "Software" and test spot rendering again, it might give another data point for troubleshooting.

    There's also an Open GL setting in the Carrara Preferences called "Use Display Lists" which might have an affect.

    Use_Display_Lists.png
    387 x 353 - 27K
    interactive_renderer.png
    472 x 642 - 104K
    Post edited by de3an on
  • BrianP21361BrianP21361 Posts: 208
    edited December 1969

    Dean,

    I changed to software from OpenGL and tried both settings fro OpenGL in the preferences and I got the same white block.

  • holly wetcircuitholly wetcircuit Posts: 0
    edited July 2012

    Software and OpenGL make no difference. Spot Preview uses Carrara's actual renderer with settings borrowed from the render room.


    The issue is somewhere in the Preview window's redraw function, as if Carrara knows to clear the tile of the OpenGL preview, but doesn't replace it with Carrara's render. Instead filling the tiles with white. Carrara is calculating the render, but not displaying it.


    In the Shader Preview (unlike Spot Render), after the entire preview is filled with white tiles, Carrara's renderer blinks in.... Normally what would happen is the tiles would fill in with Carrara's renderer as each completes.

    Post edited by holly wetcircuit on
  • thoromyrthoromyr Posts: 391
    edited December 1969

    Possibly a graphics driver related issue? I'll have to check my hardware to see just what it is (all I can remember at present is that it is a macbook pro, probably 2009 or 2010)

  • de3ande3an Posts: 531
    edited July 2012

    This thread got merged with the Carrara 8.5.0.172 Beta thread, which is now unlocked. I wonder if we're all still subscribed.
    The images got messed up though. (I fixed mine, Holly will have to edit hers.)

    Post edited by de3an on
  • de3ande3an Posts: 531
    edited December 1969

    I wonder if the type of graphics card installed could be the issue.
    Mine is a ATI Radeon HD 4870.

  • Kendall SearsKendall Sears Posts: 1,885
    edited December 1969

    The issues may not be Carrara. There are lots of sites with complaints about Mountain Lion having OpenGL problems (phoronix and others).


    Could be another Apple screw up.


    Kendall

  • Kendall SearsKendall Sears Posts: 1,885
    edited December 1969

    The issues may not be Carrara. There are lots of sites with complaints about Mountain Lion having OpenGL problems (phoronix and others).


    Could be another Apple screw up.


    EDIT: http://renderingpipeline.com/2012/07/macos-x-opengl-driver-status/ lists some specific bugs related to rendering.


    Kendall

  • de3ande3an Posts: 531
    edited December 1969

    The issues may not be Carrara. There are lots of sites with complaints about Mountain Lion having OpenGL problems (phoronix and others).


    Could be another Apple screw up.


    Kendall

    Holly and Thoromyr are both running Mac OS 10.7.4. Holly is experiencing the problem, while Thoromyr is not.
    If OpenGL is updated as part of the OS then they should both be running the same version. However, if different versions of OpenGL are installed based on which graphics card is installed, maybe that could be it. Or maybe different graphics cards themselves could be a problem.

  • Kendall SearsKendall Sears Posts: 1,885
    edited December 1969

    de3an said:
    The issues may not be Carrara. There are lots of sites with complaints about Mountain Lion having OpenGL problems (phoronix and others).


    Could be another Apple screw up.


    Kendall

    Holly and Thoromyr are both running Mac OS 10.7.4. Holly is experiencing the problem, while Thoromyr is not.
    If OpenGL is updated as part of the OS then they should both be running the same version. However, if different versions of OpenGL are installed based on which graphics card is installed, maybe that could be it. Or maybe different graphics cards themselves could be a problem.


    There are different OpenGL versions for Intel GMA, nVidia, and ATI GPU chipsets. All are layered on the lower level OpenGL subsystem from Apple, for which the major bugs are known (see my followup to myself above for a small list of bugs that exist in both Lion and Mtn Lion for the lower level). Phoronix has kept up on the OpenGL issues for both OSx and Linux and many articles can be found there.


    In this case I was responding specifically about the question about Mtn Lion and Carrara.


    Kendall

  • Dr StupidDr Stupid Posts: 313
    edited December 1969

    I'd like to check out the new beta, but how to aquire it is eluding me at the moment! It says it's a zero dollar store item, like the Studio RC builds, but shows in fact as a 200 dollar store item whenever I follow the link. Does anyone know how I can download this beta without having to pay for Carrara again?!!

    As a member of The Prime Order of Stupids I am naturally assuming that I am the problem here. All help gratefully received :-)

  • namretteknamrettek Posts: 0
    edited December 1969

    Have the M5 and V5 packages received updates so that the preset materials will work in Carrara 8.5?

    It seems like the default Genesis textures are working - they actually showed up in the "my library" and loaded the textures - but I am not sure if those were materials or whole presets (genesis male w textures and genesis female with textures).

    Also it looks as though the genesis poses are working now (I don't think they worked before...)

    Honestly I'm starting to feel senile. It's hard to remember which version could and can do what - with Daz 4.5 beta and Carrara 8.5 in beta.

    Good thing Zbrush 4r4 is keeping me busy...

  • thoromyrthoromyr Posts: 391
    edited December 1969

    de3an said:
    Holly and Thoromyr are both running Mac OS 10.7.4. Holly is experiencing the problem, while Thoromyr is not.
    If OpenGL is updated as part of the OS then they should both be running the same version. However, if different versions of OpenGL are installed based on which graphics card is installed, maybe that could be it. Or maybe different graphics cards themselves could be a problem.

    I'm using a 15" mid 2009 macbook pro with nvidia geforce 9400M. OpenGL Driver Monitor 1.5, OpenGL Profiler 4.2 and OpenGL Shader Builder 2.1 (system information, Software > Applications).

  • Sphinx MagooSphinx Magoo Posts: 312
    edited December 1969

    While rendering a scene with lots of ice, I found I was getting a memory allocation error when Caustics was turned on. Nothing special, just the default settings, but it'd get through about 12% of the render and then crash.

    Using the latest 8.5 update. Currently rendering with Caustics turned off to see if it might be something else. I'll file a bug report.

  • thoromyrthoromyr Posts: 391
    edited December 1969

    SmallFry said:
    While rendering a scene with lots of ice, I found I was getting a memory allocation error when Caustics was turned on. Nothing special, just the default settings, but it'd get through about 12% of the render and then crash.

    Using the latest 8.5 update. Currently rendering with Caustics turned off to see if it might be something else. I'll file a bug report.

    I doubt it is the caustics. I've done several renders with caustics enabled and in fact have one going now. Can't say that I recommend caustics with dynamic hair in the scene (one render took 14.5 days), but it renders for me without crashing.

This discussion has been closed.
Rocket Fuel