DAZ Studio 4.5 RC 3 Is Now Available for Download

245

Comments

  • MassMinionMassMinion Posts: 0
    edited December 1969

    The last version of Dazstudio 4.5 worked great on my PC,a solid experience with no bugs or glitches.........until I saved my work.I basically loaded up an old scene (Daz4x),re-posed a few figures (both Genesis and v4),then saved in the new Daz format.

    When loading the same scene in the new Daz format,it took 10 times longer to load and for some reason the figures in the scene had moved,(example,figure no longer sitting on chair,instead hovers over the chair,hip/legs are no longer in sitting position).........so basically I had to re-pose the figures.

    I pretty much use Dazstudio on an every day basis,so I had no choice other than reverting back to Daz 4.X..........has anyone experienced similar issues with 4.5,is it a known issue,is it fixed,are the new (longer) load times normal?

    I would also like to add that I did not notice any difference in the general running of Dazstudio 4.5.......nothing was faster,better etc.....what are the main improvements of DAZ 4.5????

  • 3Ddreamer3Ddreamer Posts: 280
    edited December 1969

    I played a bit with RC3 last night and it seemed to me that it loaded faster than RC2, which was allot slower than DS4Pro. I didn't experience many bugs on RC1 or 2 but I haven't had allot of time to play with DS these last few months. I have noticed though that if I work on a scene and save a render, close that scene down, open/create another and render - it still has the previous render name in the box. I often tweak things and save multiple renders of one scene and I wouldn't want to overwite the previous render nor use the original render name on the next scene. I can see a use for keeping a name while working on one scene but the next? Or are we supposed to close DS between opening scenes?

  • Kevin SandersonKevin Sanderson Posts: 637
    edited July 2012

    The last version of Dazstudio 4.5 worked great on my PC,a solid experience with no bugs or glitches.........until I saved my work.I basically loaded up an old scene (Daz4x),re-posed a few figures (both Genesis and v4),then saved in the new Daz format.

    When loading the same scene in the new Daz format,it took 10 times longer to load and for some reason the figures in the scene had moved,(example,figure no longer sitting on chair,instead hovers over the chair,hip/legs are no longer in sitting position).........so basically I had to re-pose the figures.

    I pretty much use Dazstudio on an every day basis,so I had no choice other than reverting back to Daz 4.X..........has anyone experienced similar issues with 4.5,is it a known issue,is it fixed,are the new (longer) load times normal?

    I would also like to add that I did not notice any difference in the general running of Dazstudio 4.5.......nothing was faster,better etc.....what are the main improvements of DAZ 4.5????

    Reading the original post and this: http://docs.daz3d.com/doku.php/public/software/dazstudio/4/change_log#release_candidate_3

    it looks like they made tons of fixes and tweaks, big improvements to FBX, Studio now can do motion blur (finally!!!), the 3Delight render engine is now updated (alright!!! - raytracing should be faster now), fixed GLSL rendering on newer OpenGL drivers (great because I use OpenGL to test animations and was hoping GLSL would be improved), and Shader Mixer has been improved. I am now seriously tempted to download and try this. I don't usually participate in beta tests because of the high frustration I have encountered in the past.

    Post edited by Kevin Sanderson on
  • MassMinionMassMinion Posts: 0
    edited July 2012

    3Dreamer........I actually find the previous saved render/image name quite handy.......I do series work,same scene but different poses,same render save name pops up but I just add 01,02,03 to the end..........works well for people like me,with a shockingly poor memory

    Kevin Sanderson.......I've read the updates etc,it sounds impressive but sadly I wiped Daz 4.5 off my hard drive because scenes take to long to load and couldn't save my work as intended.........these are the basics.....and they seem worse than 4X.If you have a solid workflow and need Dazstudio to work then I would not install this version..............if you want to beta test and like to tinker then from my experience the software was quite solid to play with...........I had 3 genesis figures,v4,large prop scene, multiple lights,mesh smoothing,auto fit and it all ran smooth.
    Didn't notice any significant different difference on render times or quality..........my only issues were saving poses and scene load times,which makes the software unusable for my workflow.
    I was hoping to see the inclusion of animation IK,would have been a great feature.

    Post edited by MassMinion on
  • SkirikiSkiriki Posts: 4,738
    edited December 1969

    That's odd, 'cause I found it faster to save and open than in 4.0.* -- are you using 32-bit version or 64-bit version? (Mine's 64-bit version.)

  • RAMWolffRAMWolff Posts: 5,266
    edited December 1969

    Still wish you guys would UP the undo's it's ridiculous to have only 20 undo's .... make it 50 and you got a deal!

  • MassMinionMassMinion Posts: 0
    edited December 1969

    I'm using the 64 bit version.......Dazstudio 4.5 saves at lightning speed.........the odd thing is,importing a scene created with the old Daz file format (4X) loaded far faster than the same scene did in the new daz file format????

  • KlasKKlasK Posts: 18
    edited December 1969

    rbtwhiz said:
    You will be prompted the same as if you had clicked File > Save As > Scene......
    ...
    If a scene has no author, or "you" are not the author, you will be prompted. If however, the name for the author of the scene matches the name you have entered into the Authorship Information dialog, the save action will actually perform a Save rather than a Save As... because it then assumes you know that you are modifying a scene "you" made.
    Thank you for the info!

  • OstadanOstadan Posts: 338
    edited December 1969

    I have a figure based on V4, scaled down with a head-scale morph applied. A version I saved in DS4.5rc2, when reloaded into rc3, did not have the hair correctly fit to it, and I could not fit other hairs to it. A version I saved from 4.0 has the hair right, but the clothing does not fit properly (as it did previously - it's just 'Courageous' tunic), with the upper chest poking through.

    A DS3 version seems OK.

    I will do more experiments in isolation so I can file a sensible bug report. There were a lot of changelog entries about bounding boxes and Y scaling, and I wonder if something got broken.

  • ZilvergrafixZilvergrafix Posts: 417
    edited December 1969

    I had this installation error, twice, I can't install RC3, some advice? maybe a corrupt download?

    erroh.jpg
    674 x 392 - 81K
  • jepegraphicsjepegraphics Posts: 294
    edited July 2012

    Area lights don't work correctly in RC3, also Genesis behaves strange and looks strange while clicking - I don't want to have to look at broken shoulders. I go back to RC2. :(

    Post edited by jepegraphics on
  • genejokegenejoke Posts: 66
    edited December 1969

    For some reason there is no download available and it asks me to check order status.

  • ReDaveReDave Posts: 815
    edited July 2012

    Studio now can do motion blur (finally!!!)
    O_o I was kinda going to sit this one out until I read that! Thanks DAZ!!!

    Post edited by ReDave on
  • ReDaveReDave Posts: 815
    edited December 1969

    OK, my first test of 3Delight 10 was about the massive gains in speed of AO through transparency. I did a scene in RC2 with Genesis and the A4 Long Hair and rendered at decent render settings with UE2. The gain on two test renders at different angles is around 5%. Hopefully the small gain is due non-recompilation of the shader, but we'll see.
    Second test was motion blur, which I'm loving already! But beware of the cubic spline interpolation, at half between a keyframe and the next the motion blur will be highest, as in the duck below.

    Duck_MotionBlur.png
    600 x 600 - 419K
  • Kevin SandersonKevin Sanderson Posts: 637
    edited July 2012

    That motion blur is great!!

    For the speed increase in the newer version of 3Delight, some highlights from the change log at 3Delight: "

    "Improved startup performance of the raytracer for some particular scenes. An example scene for which this optimization will work is a single big curves primitive (containing a very large amount of curves)."

    "Shaders with light methods which have too many required parameters to be run from illuminance loops are now cleanly skipped."

    "Improved multithreading with textures and point clouds."

    "Faster startup of the ray tracer with subdivision surfaces." & "Faster handling of subdivision surfaces."

    "Improved ray tracing performance of some transparent curves. Very dense fur patches which necessitate shader evaluation for ray-tracing will benefit the most from this optimization (we experience a maximum speed increase of 300%)."

    "Improved memory management for large scenes. Resulting memory savings can reach 25%."

    "Ray tracing subdivision surfaces now uses significantly less memory and is slightly faster. On our test scenes, memory usage is halved on scenes with a lot of subdivision surfaces."

    Post edited by Kevin Sanderson on
  • genejokegenejoke Posts: 66
    edited December 1969

    genejoke said:
    For some reason there is no download available and it asks me to check order status.

    Well that's sorted now but...

    Anyone else having trouble with saved scenes opening with genesis being a stretched mess and completely unusable? It seems to be when using files saved in the old format, which presents a BIG problem for me unless there is some kind of work around.

    dfdfd.png
    833 x 435 - 546K
  • MassMinionMassMinion Posts: 0
    edited December 1969

    Thank you to the guy's posting images,a very effective way to highlight results.

  • WoolyloachWoolyloach Posts: 0
    edited December 1969

    RC3 is working pretty well here (64-bit version).


    I don't use Genesis, and all my old 4.5 RC2 scenes load and render without issue. Continued experimentation with older content is going well, no horribly broken figures on loading so far. The various pw* plugins work just fine in early testing. Sure wish I had my Atmopheric Camera.. sigh. It can wait.


    I do get the "This program has stopped operating" when I exit DS4.5 RC3 64-bit, ut this is about 30-45 seconds after I've closed the app and there's no data loss/file corruption so I consider it an annoyance, I guess I should go file a bug even though it's just "nuisance level".


    I feel pretty warm and fuzzy about RC3 for my purposes. :coolsmile: SO FAR (heh)!

  • SkirikiSkiriki Posts: 4,738
    edited July 2012

    I pretty much use nothing but Genesis when it comes to humanoid figures, and I haven't had those sorts of problems myself. Sadly, I have no idea why this might be so, and why others have a problem. Check the log file for errors? :(

    Edit: oh wait! Could you show the scene list, to show how items are parented?

    Post edited by Skiriki on
  • ReDaveReDave Posts: 815
    edited July 2012

    That motion blur is great!!Thanks!

    For the speed increase in the newer version of 3Delight, some highlights from the change log at 3Delight: "
    "Improved ray tracing performance of some transparent curves. Very dense fur patches which necessitate shader evaluation for ray-tracing will benefit the most from this optimization (we experience a maximum speed increase of 300%)."
    I think this one was what caught my eye, but i didn't notice it only applied to curves. :-S I guess we have one more reason to wait for LAMH!

    Motion Blur doesn't work on (just) camera movements, though.

    And I have some daz scenes that do not render fine (missing bucket on one eye). I'll try again later.

    Motion blur on rotation in place:

    Rotation_MotionBlur_Plushie.png
    600 x 600 - 465K
    Post edited by ReDave on
  • rbtwhizrbtwhiz Posts: 436
    edited December 1969

    RE: #40

    I had this installation error, twice, I can't install RC3, some advice? maybe a corrupt download?


    Unfortunately, there seems to be a bug with the installers produced by the version of BitRock InstallBuilder used to build the previous installers, which causes the uninstaller that is created by the installer to be invalid (0 bytes). When the new installer attempts to run the uninstaller created by the previous installer, it fails - which also causes the new installer to fail and the message that you are seeing to be displayed. Luckily, in this scenario the number/names of files in the new installer are the same... so to work around the issue, you can go to the path indicated by the dialog (in your case: "C:\Program Files\DAZ 3D\DAZStudio4\Uninstallers\") and delete the uninstaller (in your case: "Remove-DAZStudio4_Win64.exe"), which should have a size of 0 bytes if it is the same issue we've become aware of. You should then be able to run the new installer without it failing and it should create a new uninstaller that isn't 0 bytes.

    FWIW, the change log for 4.5.0.95, in the Pending Release section, indicates...
    Updated Bitrock InstallBuilder to version 8.3.0; addresses bugs in the installers being generated by previous versions


    ... so we are aware of the issue and we want it fixed too - as much as, if not more than, you do.

    -Rob

  • Kendall SearsKendall Sears Posts: 1,882
    edited December 1969

    Anyone else having problems setting DS4rc3 to render? I've having a problem where DS4 loops over the same 4 textures infinitely and chews up all disk.

    Loaded image GSuit_GenLeatherDiffuse.jpg
    Loaded image MrIncredulousTemplate.png
    Loaded image SallyMaeHairTex07B_DC.jpg
    Loaded image SallyMaeHairTex07_DC.jpg
    Ran tdlmake on image C:/users/krsears/Application Data/DAZ 3D/Studio4/temp/d4.tif
    Ran tdlmake on image C:/users/krsears/Application Data/DAZ 3D/Studio4/temp/d3.tif
    Ran tdlmake on image C:/users/krsears/Application Data/DAZ 3D/Studio4/temp/d2.tif
    Loaded image GSuit_GenLeatherDiffuse.jpg
    Loaded image MrIncredulousTemplate.png
    Loaded image SallyMaeHairTex07B_DC.jpg
    Loaded image SallyMaeHairTex07_DC.jpg
    Ran tdlmake on image C:/users/krsears/Application Data/DAZ 3D/Studio4/temp/d4.tif
    Ran tdlmake on image C:/users/krsears/Application Data/DAZ 3D/Studio4/temp/d3.tif
    Ran tdlmake on image C:/users/krsears/Application Data/DAZ 3D/Studio4/temp/d2.tif
    Loaded image GSuit_GenLeatherDiffuse.jpg
    Loaded image MrIncredulousTemplate.png
    Loaded image SallyMaeHairTex07B_DC.jpg
    Loaded image SallyMaeHairTex07_DC.jpg
    Ran tdlmake on image C:/users/krsears/Application Data/DAZ 3D/Studio4/temp/d4.tif
    Ran tdlmake on image C:/users/krsears/Application Data/DAZ 3D/Studio4/temp/d3.tif
    Ran tdlmake on image C:/users/krsears/Application Data/DAZ 3D/Studio4/temp/d2.tif
    Loaded image GSuit_GenLeatherDiffuse.jpg
    Loaded image MrIncredulousTemplate.png
    Loaded image SallyMaeHairTex07B_DC.jpg
    Loaded image SallyMaeHairTex07_DC.jpg


    Repeated in the log.txt file hundreds of times. I stopped the render but it had already created 500G of .tdl files in a very short period of time.


    Kendall

  • SkirikiSkiriki Posts: 4,738
    edited December 1969

    ...okay, wow. o_O

  • Kendall SearsKendall Sears Posts: 1,882
    edited July 2012

    OK. Are we limited in "Images"? I restarted the render. It gets to 98/99 at 99% on the Render Dialog then drops back to 95% and 95/99.


    In 9 minutes it chewed up over 10G of disk. This happens whether rendering to Image, Window, or RIB. Here is a quick capture from the render dialog's memo area.


    Optimizing Images - 80/99
    Optimizing Images - 81/99
    Optimizing Images - 80/99
    Optimizing Images - 81/99
    Optimizing Images - 80/99
    Optimizing Images - 81/99
    Optimizing Images - 82/99
    Optimizing Images - 83/99
    Optimizing Images - 82/99
    Optimizing Images - 83/99
    Optimizing Images - 84/99
    Optimizing Images - 85/99
    Optimizing Images - 86/99
    Optimizing Images - 87/99
    Optimizing Images - 86/99
    Optimizing Images - 87/99
    Optimizing Images - 88/99
    Optimizing Images - 89/99
    Optimizing Images - 90/99
    Optimizing Images - 89/99
    Optimizing Images - 90/99
    Optimizing Images - 91/99
    Optimizing Images - 92/99
    Optimizing Images - 93/99
    Optimizing Images - 92/99
    Optimizing Images - 93/99
    Optimizing Images - 94/99
    Optimizing Images - 95/99
    Optimizing Images - 96/99
    Optimizing Images - 94/99
    Optimizing Images - 95/99
    Optimizing Images - 96/99
    Optimizing Images - 97/99
    Optimizing Images - 95/99
    Optimizing Images - 96/99
    Optimizing Images - 97/99
    Optimizing Images - 98/99
    Optimizing Images - 95/99
    Optimizing Images - 96/99
    Optimizing Images - 97/99
    Optimizing Images - 98/99
    Optimizing Images - 95/99
    Optimizing Images - 96/99
    Optimizing Images - 97/99
    Optimizing Images - 95/99
    Optimizing Images - 96/99
    Optimizing Images - 97/99
    Optimizing Images - 98/99
    Optimizing Images - 95/99
    Optimizing Images - 96/99
    Optimizing Images - 97/99
    Optimizing Images - 95/99
    Optimizing Images - 96/99
    Optimizing Images - 97/99
    Optimizing Images - 95/99
    Optimizing Images - 96/99
    Optimizing Images - 97/99
    Optimizing Images - 98/99
    Optimizing Images - 95/99
    Optimizing Images - 96/99
    Optimizing Images - 97/99
    Optimizing Images - 95/99
    Optimizing Images - 96/99
    Optimizing Images - 97/99
    Optimizing Images - 95/99
    Optimizing Images - 96/99
    Optimizing Images - 97/99
    Optimizing Images - 95/99
    Optimizing Images - 96/99
    Optimizing Images - 97/99
    Optimizing Images - 95/99
    Optimizing Images - 96/99
    Optimizing Images - 97/99
    Optimizing Images - 95/99
    Optimizing Images - 96/99
    Optimizing Images - 97/99
    Optimizing Images - 98/99
    Optimizing Images - 96/99
    Optimizing Images - 95/99
    Optimizing Images - 96/99
    Optimizing Images - 97/99
    Optimizing Images - 95/99
    Optimizing Images - 96/99
    Optimizing Images - 97/99
    Optimizing Images - 98/99
    Optimizing Images - 95/99
    Optimizing Images - 96/99
    Optimizing Images - 97/99
    Optimizing Images - 98/99
    Optimizing Images - 95/99
    Optimizing Images - 96/99
    Optimizing Images - 97/99
    Optimizing Images - 98/99
    Optimizing Images - 95/99
    Optimizing Images - 96/99
    Optimizing Images - 97/99
    Optimizing Images - 95/99
    Optimizing Images - 96/99
    Optimizing Images - 97/99
    Optimizing Images - 98/99


    Kendall

    Post edited by Kendall Sears on
  • SighmanSighman Posts: 37
    edited December 1969

    In case anyone was wondering, the DS4.5 rc3 installer now works properly on Windows 8 (at least for me). You may need to delete the default content uninstaller first though.

  • Kendall SearsKendall Sears Posts: 1,882
    edited December 1969

    Getting weirder... Different scene, getting negative numbers. XP, Windows 32 bit. DS4.5rc3

    Rendering in 3Delight
    Optimizing Images - 0/2
    Optimizing Images - 1/2
    Optimizing Images - -2/2 <----
    Optimizing Images - -1/2 <----
    Optimizing Images - 0/2
    Optimizing Images - -2/2 <----
    Optimizing Images - -1/2 <----
    Optimizing Images - 0/2
    Optimizing Images - 1/2
    Optimizing Images - -2/2 <----
    Optimizing Images - -1/2 <----
    Optimizing Images - 1/2


    Kendall

  • JeanLuc AjrarnJeanLuc Ajrarn Posts: 3
    edited December 1969

    Thank you! :)

    That is great to be able to use GoZ again! :)

  • WiseavatarWiseavatar Posts: 24
    edited December 1969

    Any information when Ubersoft and Uberspot lights will be recompiled for the RC3 onwards version and what sort of effect using the existing versions has on performance?

    I tend to rely on ubersoft lights rather than Uberenvironment due to the environment sphere and the effect not matching up.

  • DAZ_SpookyDAZ_Spooky Posts: 1,898
    edited December 1969

    genejoke said:
    genejoke said:
    For some reason there is no download available and it asks me to check order status.

    Well that's sorted now but...

    Anyone else having trouble with saved scenes opening with genesis being a stretched mess and completely unusable? It seems to be when using files saved in the old format, which presents a BIG problem for me unless there is some kind of work around.

    I have seen this one during a fairly early build of 4.5. I did it by applying a V4 pose to Genesis that changed the rotation order and broke the binding of the figure. This was done with a DUF save and load. It looked like Genesis turned to liquid, which looks similar to your image.

    That has been fixed. Without more information I can't be sure but what it looks like is you saved a .daz file in some version of DAZ Studio before RC1, which had genesis posed using a previous generation pose. Upon loading the .daz file the binding, like my pose, broke.

    There is a work around, though it is time consuming. Reinstall the old version of DS, save out character presets for your saved characters, (Note a character preset does not carry the pose.) then you can apply those presets to Genesis in the current version and quickly recreate your scene as poses will not break the binding anymore.

  • WayOfTheSwordWayOfTheSword Posts: 19
    edited December 1969

    Can we assume that since 4.5.0.90 is getting perilously close to 4.5.1 that this is going to be an official stable release very soon?

This discussion has been closed.
Rocket Fuel