Measure Metrics is not a valid plugin ?

I just installed this thing and it doesn't work at all, the plugin is red and says it's not a valid plugin... I'm using DS 4.6.1.17

Plug-in failed to load!
Filename:
C:/Program Files/DAZ 3D/DAZStudio4/plugins/dzmeasuremetrics.dll
Plug-in:
dzmeasuremetrics
Author:
Unknown
Version:
0.0.0.0
Reason:
Library could not be loaded. File is not a valid DAZ Studio plug-in, or was made for a different version of DAZ Studio.

Unknown

Comments

  • LeanaLeana Posts: 791
    edited December 1969

    Current version of DS4 is 4.6.2.118, that's probably the version the plugin needs.

  • edited December 1969

    That's a refund then, thanks.

  • jestmartjestmart Posts: 1,813
    edited December 1969

    You can upgrade to DS 4.6.2.118 for free, in fact it should already be the version in your Product Library.

  • edited December 1969

    You haven't lost many hours of work, scenes and models going from 3 to 4, 4 to 4.5, and 4.5 to 4.6 it seems. Unfortunately for me, I have. DS software is a ticking time bomb, I only upgrade if a major thing like Genesis comes out and if I really want to risk loosing everything, so no way in hell for this measure stuff

    If the plugin requires a specific version they should clearly state so on the product page, I wouldn't have bought it if I had known before hand.

  • VaskaniaVaskania Posts: 5,113
    edited December 1969

    awz4158 said:
    You haven't lost many hours of work, scenes and models going from 3 to 4, 4 to 4.5, and 4.5 to 4.6 it seems. Unfortunately for me, I have. DS software is a ticking time bomb, I only upgrade if a major thing like Genesis comes out and if I really want to risk loosing everything, so no way in hell for this measure stuff

    If the plugin requires a specific version they should clearly state so on the product page, I wouldn't have bought it if I had known before hand.


    What you're describing are all major upgrades. 4.6.1.17 to the newest isn't a major upgrade since both are 4.6 versions.

  • frank0314frank0314 Posts: 8,739
    edited March 2014

    awz4158 said:
    You haven't lost many hours of work, scenes and models going from 3 to 4, 4 to 4.5, and 4.5 to 4.6 it seems. Unfortunately for me, I have. DS software is a ticking time bomb, I only upgrade if a major thing like Genesis comes out and if I really want to risk loosing everything, so no way in hell for this measure stuff

    If the plugin requires a specific version they should clearly state so on the product page, I wouldn't have bought it if I had known before hand.

    DAZ does have a no questions asked 30 day return policy. It does say it requires DAZ Studio 4.6

    MM.jpg
    824 x 823 - 102K
    Post edited by frank0314 on
  • GhostofMacbethGhostofMacbeth Posts: 639
    edited December 1969

    And he has 4.6. That isn't specific enough. I am having the same issue I think. It didn't work for me either.

  • warderiewarderie Posts: 1
    edited December 1969

    In order for the plugin to work I had to download the installer (instead of using content manager).
    Then after it installed, I started up daz and went to help/about installed plugins and pasted my measure metrics serial code that I got from my account area on this website. now it works fine.
    I hope this helps. warderie

  • frank0314frank0314 Posts: 8,739
    edited December 1969

    I'm not entirely sure if it requires the current version or the stated version of 4.6 If I had to guess it would be the current 4.6.2.118.

  • ChoholeChohole Posts: 19,849
    edited March 2014

    It certainly has been strongly stated that it really does need to be installed using DIM, as a manual install is pretty complicated

    I will see if I can find the posts about it

    In the meantime there is this
    http://wiki.daz3d.com/doku.php/public/software/dazstudio/4/referenceguide/plugins/measure_metrics/start

    And found this post

    The best user experience is definitely for customers to use DIM to download and manage their content.

    However, this particular product is broken up into several pieces... the plugin itself, a script, and "wearables" or presets that would be considered "content".
    DIM easily installs all of these pieces to the correct places. But because of the way the product is packaged, all of those pieces don't show up in the product library.

    In order to alleviate this in the short term, the ZIP file is going to be made available so that anyone not using DIM can get all of the pieces.

    The downside is that anyone not using DIM will need to be careful about where the respective pieces are installed.

    And another post here which may be helpful

    ref. DAZ_BHowell post above. Yes the figure metrics is available in a zip file from your account. You still have to run the appropriate measures metrics installer first. Then you must manually install the figure metrics directories/files to their rightful paths: For Windows 8 & probably Win 7; sorry no idea on MAC:

    From the figure metrics zip:

    1. Copy All files and directories in the Appdata directory (not the directory itself) to your user profile's appdata/roaming directory. The Appdata is a hidden directory so you ill need admin permissions to unhide it by selecting "view hidden directories" in the windows file manager.

    2. Extract the content, manifest.dsx, and supplement.dsx folder to the root directory of your DS4.6.2.xx folder.

    At least this is how I did it and it seems to be working fine.


    Post edited by Chohole on
  • frank0314frank0314 Posts: 8,739
    edited December 1969

    Oh yeah, I totally forgot about that. If manually you need to move the files yourself which is why they want people to install it with DIM cause it will put it in the proper place hassle free.

  • mjc1016mjc1016 Posts: 7,823
    edited December 1969

    First are you 100/% sure the bit count is correct...it does say there are separate 32 and 64 bit versions...so they will need to match the version of DS installed...

    Next...Windows or Mac?

    Thirdly...if there is a problem, then it is most likely because of a newer build of the SDK than anything else.

    Incremented the current/maximum SDK version to 4.6.2.107 to reflect additions made to the API since the General Release of 4.6.1.39. The minimum SDK version has not changed and remains at 4.5.0.100. Plugins compiled against the Public SDK should continue to load/function without need for re-compiling/re-publishing. Plugins compiled against the current SDK will not load in older versions of DAZ Studio.
    (4.6.2.107 build)

    Basically, it looks like this plugin was probably compiled with the most recent SDK...because it's an 'in house' plugin, not a third-party one. So yeah, an update would be needed. It probably should have been compiled with the Public SDK instead...

  • frank0314frank0314 Posts: 8,739
    edited December 1969

    I'm sure you know this already but worth saying again. Be sure your not trying to install the "Public Build" unless you have the beta of DS installed

  • edited December 1969

    Frank0314 said:
    awz4158 said:
    You haven't lost many hours of work, scenes and models going from 3 to 4, 4 to 4.5, and 4.5 to 4.6 it seems. Unfortunately for me, I have. DS software is a ticking time bomb, I only upgrade if a major thing like Genesis comes out and if I really want to risk loosing everything, so no way in hell for this measure stuff

    If the plugin requires a specific version they should clearly state so on the product page, I wouldn't have bought it if I had known before hand.

    DAZ does have a no questions asked 30 day return policy. It does say it requires DAZ Studio 4.6

    I have 4.6.1.17, which meets the stated requirement of 4.6 --if it requires a specific version above 4.6.1.17 there is no mention of it, and it's therefore misleading.

    Regardless I've already asked for a refund, but if there's people trying to figure out how to "properly install" with or without DIM, having to make experiments, and that sort of stuff, then it means IMHO the item was certainly not ready for a public availability release.

  • ChoholeChohole Posts: 19,849
    edited March 2014

    The Official thread about the product release did have a lot of discussion about this. It is worth reading official release threads and posting your queries to them, rather than starting separate threads. most of your questions and queries have already been answered there, including the reasons for why the plug in is somewhat difficult to install manually, as it is very specific as to where the various files need to be.

    Post edited by Chohole on
  • GhostofMacbethGhostofMacbeth Posts: 639
    edited December 1969

    Where is the official thread so I can see if I can get it to work?

  • Richard HaseltineRichard Haseltine Posts: 19,925
    edited December 1969

    Where is the official thread so I can see if I can get it to work?

    http://www.daz3d.com/forums/discussion/38008/

  • GhostofMacbethGhostofMacbeth Posts: 639
    edited December 1969

    Thanks for the link Richard.

Sign In or Register to comment.
Rocket Fuel