Argh! Weird green overlay on renders!!

spearcarrierspearcarrier Posts: 313
edited December 1969 in Technical Help (nuts n bolts)

What once rendered like example 1 is now rendering like example 2.

I have no idea why!

The scene is one I have saved that has made many good comic pages with no weirdness in the past. Only two things have happened. the usual updates and I upgraded my Daz4 to the latest. Just. Argh!!


Anybody got any clues on this mess? Please? (whine)

Comments

  • spearcarrierspearcarrier Posts: 313
    edited December 1969

    Okay it's not a green lay. It's blue. It's like it's putting blue everywhere. I've tweaked, prodded, rebooted, and I don't know what else to do. It does it with both the cartoon render engine and 3delight. Anybody??

    sample2.jpg
    800 x 809 - 363K
  • JaderailJaderail Posts: 0
    edited December 1969

    If that happens only with the Toon shader it is the shader picking up the blue as the shadowing color when it does the color reduction. No Idea how to get around that as I do not toon shade at all. Should be able to fix that I would think.

  • spearcarrierspearcarrier Posts: 313
    edited December 1969

    Well, I thought it was my video card at first. (Scarey!) But after some testing, yes. It only happens with pwtoon shader. This is the first time I've tried to toon shade since going to the latest DAZ, so my conclusion is it is no longer compatible with DAZ. I've tried all sorts of settings using pwtoon. I've reinstalled pwtoon. No matter what, the minute I apply it the blue weirdness returns. Which is a disaster for me! One of my comics *depends* on it.

    I need to somehow uninstall this latest DAZ and go back to the old one that works. Or something.

  • JaderailJaderail Posts: 0
    edited December 1969

    Which version of pwToon you using? If its the Updated version for DAZ Studio 4.5+ I can test it.. I have it just never used it...

    Capture-001.png
    368 x 342 - 28K
  • spearcarrierspearcarrier Posts: 313
    edited December 1969

    Yes, that's the one. It's on sale and everything right now. Heh. =^-^=

    Basically I just apply, tell it to ignore map settings, then set the exterior line to 50 and the interior off. Then I use the default cartoon shader. Currently I'm experimenting with Crescent's pw addons with no success.

    But the DZ cartoon shaders that are free work fine. I just don't understand them well enough to get them to do shadows.

  • JaderailJaderail Posts: 0
    edited December 1969

    I just tested it on my PC using your settings with two different light sets and I did not get the blue colored shading... I have no idea what is causing that in your renders.

  • spearcarrierspearcarrier Posts: 313
    edited December 1969

    I reinstalled an older version of DAZ and still the blue shading. So. Me neither. With no clue what to do I'm in a big pickle.

  • JaderailJaderail Posts: 0
    edited December 1969

    First things first have you had a GPU Driver up-date from the time you last used the Shader? If so you can try a roll back on the driver and see if that clears it up. If not... I'm out of good ideas or any really.

  • spearcarrierspearcarrier Posts: 313
    edited December 1969

    The only updates I have had are those bloody enforced Windows updates they foist on you even when you tell the system not to update, like, ever. -_- So. Yeah. I guess I'll have to call my comic quits.

  • JaderailJaderail Posts: 0
    edited December 1969

    Still would not hurt to check the GPU Driver date Windows will install them as well if allowed.

  • spearcarrierspearcarrier Posts: 313
    edited December 1969

    This is going to have to be a job for super husband, I'm afraid. I'm sitting here going "gpu drive what???" And I'll refrain from ranting on how these problems are continuous. -_-

  • JaderailJaderail Posts: 0
    edited March 2014

    GPU is short hand for Graphic Processor Unit or your Graphic Card. The Driver would be the first thing to check to see it it changed in the last bit. If it did putting the Older one back that did work would not hurt anything except software that might need the new one in the future. And to me Renders come before games so I would not care if it the old one allowed me to render again.

    Post edited by Jaderail on
  • spearcarrierspearcarrier Posts: 313
    edited December 1969

    Oh, see, if you'd said graphic card... husband looked into that today and didn't see anything. The computer has been put through stress tests and all sorts of things today. My husband is researching how to roll back updates now, in the hopes we can fix things that way.

    Thank you for piping up to try to help.

  • Herald of FireHerald of Fire Posts: 3,384
    edited December 1969

    Graphics card should not be an issue here. 3Delight uses software rendering, so it won't matter what graphics card you have as it simply won't use it. The only thing it will affect is what is visible in the viewport (and thus, how fast DS runs while you're manipulating figures).

    Due to where those green and blue areas are appearing, I think the issue is more likely something to do with your scene specifically. Either the lighting or the surface materials. What are your render settings (are you using pwToon as well as the 'cartoon shader' option?) and how are your scenes composed. If you give us some information on the scenes which are the worst offenders, we might be able to shed some light on the source of these problems.

  • MattymanxMattymanx Posts: 3,479
    edited December 1969

    Have a look at the online readme for pwToon

    http://www.poseworks.com/shaders/pwtoon/index.html

    It may ofer some quick insight as to what you need to change cause it sounds more like a setting issue then anything.

  • JaderailJaderail Posts: 0
    edited December 1969

    I completely spaced on this being a shader only issue. I had a friend that just went through heck because the new GPU Driver killed or error-ed almost every program they were using. It just stuck in my head I guess. It has to be in the shader itself I agree...

  • spearcarrierspearcarrier Posts: 313
    edited December 1969

    Hi guys. Thanks for responding!

    The scenes are set up very simply. Everything is given the pwtoon shader as a base. outline of 80 t0 120. No inner line. bump off, things like that. uberenvironment, ambience only or directional shadows. One distant light and then a spotlight from the camera, wherever the camera may be. When rending, I put the render engine to cartoon under 3delight. It just used to render better that way.

    I should reiterate that this particular scene is the same scene I've been using a while. The first example is how it USED to render. The second sample is what I'm getting now with no settings changed at all aside from a DAZ upgrade. I've been having to carry on anyway with these godawful blue splotches and my pages look TERRIBLE. Those blue lines create postwork messes I can't correct without just throwing DAZ out the window and going back to drawing by hand.

    I also built a whole new scene from scratch. Everything renders fine... until I put in the pwshader.

    I use other toon shaders, and results are nice. Interestingly if I use the pwcomic shader, no blue splotches. It seems to be pretty specific to the settings I've been using all this time that never were an issue before.

    So although I'd like to say, sure, setting issue. There's this history of my settings being perfect.... (sighs) And I've poked and prodded, played, rebuilt, and have run out of time.

  • JaderailJaderail Posts: 0
    edited December 1969

    Well that says to me it is in the pwToon shader but I did a pwToon with your settings and the DS Toon render option and still did not get the blue error... I admit I used a light set and not the default camera head lamp. Maybe that is the cause...I'll check it on my PC now using just the head lamp.

  • JaderailJaderail Posts: 0
    edited December 1969

    I might be missing a step... But doing pwToon then the Default pwToon Neutral so I can set the inner edges off and then the DS Toon Render option I'm still not getting a blue shadow thing.
    Could you walk me through your steps... I did the Ignore maps and all that...

  • spearcarrierspearcarrier Posts: 313
    edited December 1969

    WEll before I walk you through, I can say frustratingly (and interestingly) when I set it to render to a window as opposed to a file *and* I only have one or two objects in the picture the blue usually goes away. Which swings me to a hardware issue. Pwtoon makes my computer really think. Maybe I have a bad ram chip or even (gulp) a virus that's eating things in the background. Or, it really could have been those stupid unwanted updates. Time for some serious computer maintenance if work will let me.

    In the meantime, this is how I do it.

    I get my character in.
    Select, surface, pswtoon base, ignore maps.
    In surface settings, all I change are:
    bump and displace to 0
    scroll to bottom: interior line off
    outline color 000, width 80 or more. The width doesn't matter, really. I just like to try to have thick lines.
    rim color mode: difference, which is default. colors I leave at default. I've noticed when I change the rim color mode (I change it to add for black clothing) the blue will go away in those areas sometimes.

    Lighting:
    uberenvironment2, ambiance only or directional shadows.
    1 lonely sun. 80%. shadows raytraced.
    1 spotlight with your camera, 30% or so. Diffuse only. Or on, but no shadows.

    And that's it.

    This may be a blessing in disguise. This has shoved me into experimenting with the free acdztoon shaders (what with me wanting to get this done and all). They do a much crisper toon look, although the shadows leave a little to be desired right now. If I can get the shadows dark I may not use pwtoon as much anymore. Pwtoon is great for some things but there are times I've found it too shiny. But! One thing atta time.

  • JaderailJaderail Posts: 0
    edited December 1969

    KK. Will follow this and see what we see...

  • JaderailJaderail Posts: 0
    edited December 1969

    Okay Got it. I get the BLUE green effect now. And guess what adds it? UE2. Any setting, Ambient or other... No UE2 light and no bad shadow effect... I hope this helps you some...

  • spearcarrierspearcarrier Posts: 313
    edited December 1969

    I never knew you replied. I'm sorry. I didn't get a notice.

    I've found that when I add too many lights I get the effect, but if I have only one light I don't.

    Except I used to be able to have all sorts of complex lighting.

    I just reinstalled my Windows from scratch as I was having other problems, however, and now I must start a whole new thread on a whole new problem. I'm beginning to think me and DAZ are never going to see eye to eye.

Sign In or Register to comment.
Rocket Fuel