Deleting files for unwanted complete Scenes

fruitwortfruitwort Posts: 0
edited December 1969 in Daz Studio Discussion

Ever since I started using DAZ in 2009 I have been deleting unwanted scenes by deleting the .daz/.duf and accompanying .png using the file deletion facilty in Windows Explorer. I have been unable to locate a more effective method!

This procedure appears to have left me with a plethora of related "files" which I cannot delete. These appear in the Smart Content tab under Files. Those marked with a blap(!) cannot be deleted.

If I try to load said files I get the message, e.g.:

Resource Error - Could not open file :G:/DAZ3D...............................daz/duf - file does not exist!

How do I get rid of these records and what is the correct way to delete all the files relating to an unwanted scene?

Comments

  • frank0314frank0314 Posts: 8,796
    edited February 2014

    Right click on them within the content library/Smart content and select remove orphan if I'm understanding you correctly

    Post edited by frank0314 on
  • fruitwortfruitwort Posts: 0
    edited December 1969

    Thanks for replying, Frank!

    I am using Hollywood Blvd under DAZ 4.5.

    I have two separate tabs Smart Content and Content Library. The erring files are only in the Smart Content tab. Right clicking does not include Remove Orphan option.

  • frank0314frank0314 Posts: 8,796
    edited December 1969

    To do it you need to switch over to City Limits for the option. Once removed you can switch back

  • JaderailJaderail Posts: 0
    edited February 2014

    Use the Content Library Or Smart Content mini menu (four lines) to Open the Content DB Maintenance menu then do Remove Orphans from its options.

    Post edited by Jaderail on
  • frank0314frank0314 Posts: 8,796
    edited December 1969

    TY Jaderail. I use City Limits and I've only ever used the right click option. Wasn't sure if there was another method or not

  • cm152335cm152335 Posts: 110
    edited February 2014

    fruitwort said:
    Thanks for replying, Frank!

    I am using Hollywood Blvd under DAZ 4.5.

    I have two separate tabs Smart Content and Content Library. The erring files are only in the Smart Content tab. Right clicking does not include Remove Orphan option.

    check the "Content library" and navigate to "SCENES"
    on rigth clcik mouse select "DELETE"

    once you delete from there, they removed from "smart content - unasisgned"

    Post edited by cm152335 on
  • fruitwortfruitwort Posts: 0
    edited December 1969

    Just for the record, I've managed to remove the erring files, within Hollywood Blvd, as below:-

    1. Load DAZ (4.5 for me) in your usual way.
    2. Select the Smart Content and Content Library tabs.
    3. In the Smart Content tab, select Files in the top left-hand corner, then Unassigned in the left-hand column (the last item in the list for me). This should display all your .duf files, regardless of their location - I put my scene files in a suite of Render folders in my Content folder. You can tell which are your target files for deletion as they have a strident blap symbol displayed and/or a faded blue icon (what it is escapes me!).
    4. If you are uncertain as to whether any file is an orphan, then attempt to Merge it into your blank scene pane. If it merges, then this is not an orphan file; if DAZ tells you that it can't find a .duf file then this one is an orphan for deletion. Press OK to remove the warning message. If it wasn't marked with that strident blap, then it will be now!
    5. Now go to the Content Library tab. Shift the slider to the far left to where DAZ Studio Formats is high-lighted.
    6. From your Smart Content tab, note the title of your first scene marked with a blap, and enter that title in the "Enter text to filter by..." box. Press Enter.
    7. A magnifying glass symbol followed Search: Title of the scene should now be displayed and, in the pane below, the icon for the file you want to delete. If it isn't there, then you did not enter the EXACT title from Smart Content tab ... or, like me, you need a new pair of specs!
    8. If it is there, then right click it. "Remove Orphaned Reference" should be included in the options displayed.
    9. Click it. It will seem as though nothing has happened, as the orphan will still be displayed in the Smart Content. To remove it you must either re-start DAZ or, for a less drastic option, select another set displayed in the Smart Content tab, e.g. Lights and then reselect Unassigned. The orphan will now be gone.


    Now, how do we correctly remove an unwanted scene without leaving an orphan behind?

  • JaderailJaderail Posts: 0
    edited December 1969

    For me IF the file is saved into the Default Scene folder in my Content folder I just Right Click and Delete scene files. It is a FULL OS delete so the full file is just gone forever. It has never once caused a orphan on my system. Not sure why it is on others if it is.

  • jodycourjodycour Posts: 64
    edited December 1969

    Thank you! That was really helpful!

Sign In or Register to comment.
Rocket Fuel