Major Cache For M4

edited December 1969 in The Commons

I purchased this package some time ago. It's been a while since I've really cracked out my M4. I went to do so tonight, and wanted to use this set. Well, it loads the bodysuit completely missing the buttock areas, nor does it seem to conform correctly to the M4.

I have uninstalled the package, gone back to my downloads, reset the download, re-downloaded the package, reinstalled it.

I get the exact same problem. Suit does not conform properly to M4, and it loads missing the buttock portions.

I have tried closing Poser down and re-opening it, in case it was just a lack of memory (I only had a single M4 and the body suit in the scene...), and I still get the same error. Body suit fails to conform correctly and the buttocks are completely gone from the suit.

What gives?


  • chriscoxchriscox Posts: 18
    edited July 2012

    Major Cache for M4 loaded fine for me using PoserPro 2012. You mentioned that the buttocks were missing, which is really weird because M4 and my copy of the Major Cache Bodysuit do not have buttocks (M3 has buttocks but M4 doesn't) Makes me think that the OBJ for the M3 Major Cache Bodysuit is getting mixed in with the M4 file (Which would also explain why it doesn't conform properly as well)

    If you already redownloaded and installed the file, then possible the files were screwed up when they were updated at some point by DAZ

    Post edited by chriscox on
  • edited July 2012

    Hi Chris,

    I know the M4 figure does not itself contain separate 'buttocks', but I was referring to that section of the suit which seems to be missing. See the attached image in my original post.

    I do not believe this was a file getting mixed up during an update, as I had this problem with the originally downloaded file (months and months ago), and I actually downloaded the current files from my purchase history tonight in an attempt to ensure that maybe something didn't get botched up in the zip file i had on my hard drive.

    I do suspect it is somehow getting mixed with the M3 OBJ's, but I have no clue how to prevent that or fix that - and I cannot uninstall the M3 version because it gets used on a daily basis. This would as well, if I could get it to work! LOL.

    Post edited by Seliah (Childe of Fyre) on
  • KeryaKerya Posts: 9,391
    edited December 1969

    Do you feel comfortable opening a cr2 in a text editor?
    You could open in MS editor and search for the paths to the obj file ...
    Just an idea that went through my head, I can't verify at the moment.

  • edited December 1969

    Yep, it was confusing the M4 object with the M3 object... got it solved. LOL.

    This is what the call line for the OBJ file looks like inside the .CR2 :

    figureResFile ":Runtime:Geometries:DAZClothing:MilMan:M4:MajorCache:MC_Suit.obj"

    Note that the MC_Suit is the same OBJ name as the M3 object. Different file path and folder, but the object name itself is identical, so... yeah. I think it was just confusing the two objects together.

    Just to test things, I changed the name of the OBJ file and all of it's corresponding OBJ call lines in the .CR2 to this :
    figureResFile ":Runtime:Geometries:DAZClothing:MilMan:M4:MajorCache:MC_Suit_M4.obj"

    And it works. Loaded the suit in fine, conformed fine, etc.

  • KeryaKerya Posts: 9,391
    edited December 1969

    I thought so ... Poser has a tendency to use the first obj with a given name it finds, independent on the thread path it is told ...
    I had problems with IC3, because the ground.obj is called just ground.obj like the Poser default ground. It just loaded invisible, until I renamed it to ic3ground and changed the cr2.

  • edited December 1969

    You know, I've run into it before with some other items I have (a freebie pair of boots for M3 and the RDNA Shadow Ops boots for M3...)

    I fixed it before doing this, I don't know why I didn't think to do it with this one (or at least check for it!) Ugh! LOL.

  • KeryaKerya Posts: 9,391
    edited December 1969

    You did it so I had a small "Hooray, I know something and can help instead of asking for help" moment. ;)

  • decibeldecibel Posts: 65
    edited December 1969

    Just went through the similar problems. MC_Suit refuesed to conform to M4.
    Sure enough inspection of scene revealed Poser Pro 2012 had loaded Uzilite M3 MCache obj.
    While I don't know the how the coding of could disregard a specific path, I do know that once I forced it to call the M4 version that all other MC objs began to come into scene file. Bizarre!

    At first, I thought it might have something to do with the quotation marks enclosing the geometry path. None of the other cr2s in other libraries contain quotes surrounding a path. I would have removed them to see if that solved the problem but for the moment it would appear that Poser has "learned" where to look, for today.

    For quite sometime I have been skeptical of this myth; Poser choosing to disregard file paths. I must grumpily include myself as having experienced it.

    Bump for the next poor slob who wastes a few hours of their lives before searching the Forums for this welcome solution.


Sign In or Register to comment.