Best way to increase stop daz slowing?

ToobisToobis Posts: 175
edited December 1969 in The Commons

when I typically put more than around 6 characters in a daz scene it will often slow to the point where is it hard and sluggish to make scenes. If I put more it is almost un useable.

What is the best way to increase the speed on your computer for use with daz? is it a case of increasing the memory or the ram or? which is better? thx.

Comments

  • Kulay WolfKulay Wolf Posts: 11,060
    edited December 1969

    what are the specs of your computer? is it 64 bit or 32 bit? how much ram?

  • JaderailJaderail Posts: 0
    edited July 2012

    That is really a good question. Ram (memory) controls how much you can put into a scene and still have it render properly. As for the Viewport display I'm pretty sure it is controlled by your Video Card and drivers. A card with just 1Mb video ram will slow down much faster than a 2Mb card will. So what is your PC spec's, Ram, OS and bit wise. Like 8Gb Ram , Win7 64bit. Also check which video card you have and its spec's. Sometimes just updating the Video Cards drivers will help.

    Post edited by Jaderail on
  • frank0314frank0314 Posts: 8,782
    edited December 1969

    Yes the viewport is controlled by your video card. Once you hit render then you processor takes over.

  • kyoto kidkyoto kid Posts: 16,153
    edited December 1969

    ...figures are not the only elements that affect response. Props, clothing, and sets with high poly counts and large large/highly detailed texture maps also impact working in OGL mode (which is what you are in while working on a scene).


    As you are noticing this with 6 figures in the scene, most likely you are in working 64 bit as I am in 32 and just one Vicky plus one Mike can slow things down to a crawl for me. If some of the figures are in the background you could reduce the Level of Detail a few steps.


    I also often work in wireframe when I do have a large scene. It's tricky but it saves memory and I'm already used to it because that is Bryce's default view mode.


    For rendering I usually render to a file rather than the viewport or separate window and set the viewport to bounding box mode to conserve as much memory as possible since in 32 bit there, is a finite amount of RAM available (usually 2GB).

  • nitehawk_ltdnitehawk_ltd Posts: 260
    edited March 2013

    The fastest way to speed up the view-port is to make everything that you are not working on invisible.
    If you look on the scene tab you will find a list of everything in the scene.
    On the right side of the tab you will see an eyeball icon for each item.
    Click the icon to make the item invisible. If you are not working on it, hide it. The view port speeds up a lot.
    Do your test renders with most items hidden. Especially trans-mapped hair.
    When you are ready to render the whole scene, unhide everything & render.
    .
    Speeding up rendering is a little harder.
    On 32 bit XP systems, all programs are normally allocated only 2gig of ram total, irregardless of how much ram is in the system.
    You have to tell 32 bit XP at boot up to allocate more ram, to do this you have to edit the boot.ini file on your system.
    This only works on systems with 4 gigs or more ram.
    After using this trick my render times were cut drastically. Renders that took an hour before, now take about 20 minutes or so.
    .
    Now as far as I know, 64 bit XP systems and win 7 systems don't have this problem. - I could be wrong. :)

    //EDIT: 03.14.13
    An easier way to speed up your posing window is to switch to flat shading, the switch is on the camera bar. No need to hide anything.
    When you switch to the posing window, everything will look as it should.
    For the memory switch, you must add the /3GB command to the boot.ini file. Google it for more info.

    Post edited by nitehawk_ltd on
  • kyoto kidkyoto kid Posts: 16,153
    edited July 2012

    ...actually XP 32 allocates 2G to any one application by default. To go beyond this limit requires activating a switch in the config.ini that will open an additional 1G (provided the system has a minimum of 4G). However, this is only available if you are running with XP32 Pro, not XP32 Home or XP32 Media Edition (the latter which my notebook has).


    To upgrade to XP32 Pro costs more than Win7 64 Home Edition which allows up to 16G to be allocated.


    Daz Studio also does not take advantage of a a system's virtual RAM partition (like Carrara does) so you are basically stuck with whatever your system and/or version/configuration of XP32 allows.


    Hence, the options available for 32 bit users are very limited.

    Post edited by kyoto kid on
  • McG.McG. Posts: 204
    edited December 1969

    Toobis said:
    when I typically put more than around 6 characters in a daz scene it will often slow to the point where is it hard and sluggish to make scenes. If I put more it is almost un useable.

    What is the best way to increase the speed on your computer for use with daz? is it a case of increasing the memory or the ram or? which is better? thx.

    Your issue(s) may be related to 32 bit vs 64 bit, or memory or CPU or all these.
    Run only on a true 64 bit itanium* based rig with maximum amount of highest speed RAM running Win 7 Pro 64 bits. Then run ONLY a 64 bit application such as Poser Pro 2012 or D|S4 Pro 64 bits. You can forget using D|S 3 Advanced 64 bits for this purpose as they never fixed the complications of memory OR file management in v. 3.x and never will now they've pushed DS 4 out the door.

    * reason for this is this CPU runs 64 bits, 4 cores AND uses hyper-threading. Yields 8 practical cores.

    McG.

Sign In or Register to comment.
Rocket Fuel