Carrara 8.5 not using all system resources?

patrickgobelspatrickgobels Posts: 477
edited December 1969 in Carrara Discussion

Hello!

Could it be that Carrara 8.5 does not use all system resources on an I7 with Windows 8?

The CPU is only at 18% and the rendering process takes a long time if I use particles.

Did I not configurate well my Carrara settings?

Comments

  • FractalDimensiaFractalDimensia Posts: 0
    edited December 1969

    I have been experiencing this situation occasionally as well. It depends (as I have discovered so far) on what is being rendered. I posted elsewhere that while attempting to render a replicated set of clouds, it was running at about 15-18% CPU utilization. I posted this to DAZ but have not heard back.

    You will also likely experience some garbage collection problems. I have loaded large scenes, rendered them, and then closed the scenes. Then discovered Carrara doesn't always release its memory back to the system. I have to monitor this and close Carrara completely and then reopen it to get it to go away.

  • FenricFenric Posts: 350
    edited December 1969

    You need to turn off texture spooling on 64-bit systems if you are using any of the Global Illumination options, or Carrara spends too much time fiddling with spooling textures instead of rendering.

  • SileneUKSileneUK Posts: 1,583
    edited September 2013


    You will also likely experience some garbage collection problems. I have loaded large scenes, rendered them, and then closed the scenes. Then discovered Carrara doesn't always release its memory back to the system. I have to monitor this and close Carrara completely and then reopen it to get it to go away.

    I've been doing that myself, knowing it's a weird workaround but am desperate to finish this project.

    I have 4gb memory, but I don't think it's adequate at all for C 8.5 Pro 64-bit. If I don't render I can get through making several sessions in my scene which is 135mb now doing a bit of this and that, adding, morphing, modelling. But then I need to save/close and reopen otherwise it reads zero physical free memory and I get that Error Occured While Executing Save thingy. If I've sucked it dry during scene work, and I try to render, I get the An Error Has Occured.

    Fenric, thanks for saying that. I did that and it helped a lot...but doesn't cure the problem. I think I am going to have to get a meatier CPU. I can't even have Photoshop running when Carrara is running or I run dry.

    I did load up the 32-bit version and left it bare bones to use just for rendering as I have no special Carrara Content loaded into to it and did not copy over the Genesis figures I've saved to the browser. Scenes load fine and It seems to use less memory, but limits me to tweaking things vs creating.

    :( SileneUK

    Post edited by SileneUK on
  • EyosEyos Posts: 114
    edited December 1969

    Fenric said:
    You need to turn off texture spooling on 64-bit systems if you are using any of the Global Illumination options, or Carrara spends too much time fiddling with spooling textures instead of rendering.

    Where do you turn off texture spooling? I can't seem to find it.
    Thanks.

  • FenricFenric Posts: 350
    edited December 1969

    You find the preferences in the file menu, then go to the "Imagine, Scratch Disk" tab.

    Untitled-1.jpg
    405 x 668 - 43K
  • evilproducerevilproducer Posts: 9,021
    edited December 1969

    Also, I believe some calculations aren't multi-threaded. I don't recall exactly which ones, but for some reason the old physics engine, maybe the particles and some post render effects, such as DOF seem to come to mind.

  • patrickgobelspatrickgobels Posts: 477
    edited December 1969

    Does rendering work faster in the RenderNode on a single computer?

  • FractalDimensiaFractalDimensia Posts: 0
    edited December 1969

    Also, I believe some calculations aren't multi-threaded. I don't recall exactly which ones, but for some reason the old physics engine, maybe the particles and some post render effects, such as DOF seem to come to mind.

    I was just running "Simulate Physics" earlier today and noted this (15-18% use on my 8 thread i7).

  • patrickgobelspatrickgobels Posts: 477
    edited December 1969

    @FractalDimensia: DAZ is informed about this? What about a patch?

  • evilproducerevilproducer Posts: 9,021
    edited December 1969

    Does rendering work faster in the RenderNode on a single computer?

    The render node is a client for Carrara that is to be installed only on other computers that you have on your LAN. It should not be installed on your main computer.

    A render node can help significantly with render times, because your main (or host) computer is running Carrara to render your image or animation, and the render node(s) are helping by rendering portions of it as well. It works best if your main computer and the node computers are similar in speed.

    As to the CPU usage, there has been some good information posted by Fenric and others. As to functions in Carrara that are not multi-threaded, there have been feature requests to update them to be multi-threaded in the past. I don't think that it would be classified as a bug since they are working as they were written. If it's important to you that they are multi-threaded, use the new Zen-desk thingy to place a feature request to update all the features to make them multi-threaded.

Sign In or Register to comment.