New products... should I go with .duf or .dsf?

SloshSlosh Posts: 1,599
edited December 1969 in DAZ PA Commercial Products

I am on the cusp of submitting a new product to DAZ, but it occurred to me that not everyone uses 4.5 or 4.6 so I wonder if I should submit my files in .duf or .dsf, or both? And, if both, can I simply extract the .dsf from the .duf? Or should I save out each material setting and/or prop as a .dsf?

I would really like this to be accessible to as many DAZ users as possible. It is for Genesis, and I don't have Poser 9+, so I have no way to see if it works via DSON. I will ask someone to beta that for me, but I also don't know how to make it DSON compatible.

Any tips or suggestions?

Comments

  • JaderailJaderail Posts: 0
    edited December 1969

    You can do Save As>Deprecated and choose the format. DS4.6 will also Create PoserCF's but I forget how that is done.

  • SloshSlosh Posts: 1,599
    edited December 1969

    Jaderail said:
    You can do Save As>Deprecated and choose the format. DS4.6 will also Create PoserCF's but I forget how that is done.

    So you think it's necessary for me to do the .dsf files? I don't mind, but I think it would make the download bigger.

  • Male-M3diaMale-M3dia Posts: 1,976
    edited December 1969

    Slosh said:
    Jaderail said:
    You can do Save As>Deprecated and choose the format. DS4.6 will also Create PoserCF's but I forget how that is done.

    So you think it's necessary for me to do the .dsf files? I don't mind, but I think it would make the download bigger.

    Do DUF and make it easy on yourself, especially if you item only loads in 4.5 or higher.

  • Male-M3diaMale-M3dia Posts: 1,976
    edited December 1969

    Jaderail said:
    You can do Save As>Deprecated and choose the format. DS4.6 will also Create PoserCF's but I forget how that is done.

    Poser companion files only work with DUFs.

  • JaderailJaderail Posts: 0
    edited December 1969

    I miss understood the question, thought it was a how not a why. I red faced now.

  • SloshSlosh Posts: 1,599
    edited December 1969

    Jaderail, every answer is helpful. There was a "how" in my original post as well, so you didn't waste your breath. I don't know if this can be used in anything other than DS 4.5/4.6 since I don't have the older versions installed. And as for Poser, well, I don't see how it would be useful there. Maybe I will release it with .duf and then if someone asks why no .dsf, I will address it then.

  • Richard HaseltineRichard Haseltine Posts: 19,421
    edited December 1969

    File>Save as>Deprecated gives access to the old script-based presets (.dsa etc.) but not to .dsf.

  • SloshSlosh Posts: 1,599
    edited December 1969

    File>Save as>Deprecated gives access to the old script-based presets (.dsa etc.) but not to .dsf.

    So, Richard, what do you think the best way to submit the product is? Will I get a lot of complaints about only being compatible in DS 4.5 and up? Or do .dufs work in 4.0? I'm corn-fused... When I think about it, most of the stuff I've bought only contains the duf files.

  • WilmapWilmap Posts: 2,132
    edited December 1969

    Dufs won't work in DS4.

  • Richard HaseltineRichard Haseltine Posts: 19,421
    edited December 1969

    It's a hard call - there are still people using 4.0, but 4.6 has added new features and fixed bugs. It's a judgement call, which has to include things like how easily you can set up both versions of DS (requires a dual-boot PC or two machines; you will certainly want to be able to test in 4.6, even if you use files from 4.0 instead or as well) and whether you want to include Poser Companion Files.

Sign In or Register to comment.
Rocket Fuel