Cannnot see through windows of object

I created a set using Sweet Home 3D. My goal was to create an office wall with windows, through which the audience could see buildings in a city. I created the walls, and added the windows, then exported the set as an OBJ.
I imported the OBJ into Daz Studio 4. Everything looked fine. The windows are transparent.
I wanted a large backdrop, and the backdrop function of Studio 4 would not allow me to create a panoramic view of a city with a wide jpeg image. So I created a plane and used the jpeg image as its diffuse texture.
The plane looks good. I placed it just outside the windows of the office set. I can see it just fine through the windows of the office.
Here is the problem: When I render, the background turns opaque grey. Nothing can be seen.
Any ideas?
Files attached.




Edited to remove over-sized images http://www.daz3d.com/forums/discussion/510_98/

Post edited by Richard Haseltine on

Comments

  • Oom FooyatOom Fooyat Posts: 0
    edited June 2012

    Possibly no light on the backdrop, turn up Ambient on the backdrop surface and see what happens. Also check that you use the 3Delight render engine, under Show Advanced Settings in the render tab. Some graphic cards mess up shadows in hardware assisted renders.

    Oh.. and no picks wider that 800pixel.

    Post edited by Oom Fooyat on
  • Richard HaseltineRichard Haseltine Posts: 19,421
    edited December 1969

    Could you post a wireframe view of the model - it's possible you have polygons with more than 4 vertices around the window and those are causing render errrors.

  • Kendall SearsKendall Sears Posts: 1,883
    edited June 2012

    Many "modeling" packages simulate thickness with 2 polygons spaced apart. For Glass like objects you will need to delete one of the polygons that make up the window glass.


    This can be done in DS4 using the Polygon Group Editor Tool. Select the "Extra" polygon and select "Hide Selected" NOTE: This setting WILL NOT save. Therefore, you will have to re-hide the extra Polygon each time the project is loaded.


    EDIT: I've attached a model with the problem. I've deleted part of the 2nd pane from the front window so that you can see the effect. The side window is using the same glass shader as the front window. Where there are 2 panes, the window is opaque.


    Kendall

    example.jpg
    600 x 491 - 115K
    Post edited by Kendall Sears on
  • Oom FooyatOom Fooyat Posts: 0
    edited December 1969

    Many "modeling" packages simulate thickness with 2 polygons spaced apart. For Glass like objects you will need to delete one of the polygons that make up the window glass.


    This can be done in DS4 using the Polygon Group Editor Tool. Select the "Extra" polygon and select "Hide Selected" NOTE: This setting WILL NOT save. Therefore, you will have to re-hide the extra Polygon each time the project is loaded.


    EDIT: I've attached a model with the problem. I've deleted part of the 2nd pane from the front window so that you can see the effect. The side window is using the same glass shader as the front window. Where there are 2 panes, the window is opaque.


    Kendall

    I have used models with double planes for windows and did not have this problem. it gave a more realistic glass.
    With what render/surface settings will this occur?

    Cheers! Oom

  • PhoneyBaloneyPhoneyBaloney Posts: 0
    edited December 1969

    Here are the resized (below 800 pixels) and reposted photos:
    One is of the perspective view, showing the clear scene.
    One is called Background invisible.png, showing the occlusion.
    I inserted a light between the building and the cityscape, and you can see the cityscape better in this render, filename Background visible.png. Nevertheless, you can still barely see out of the windows.
    For the windows, I used a Sketchup figure that I exported to DAE format for import into Sweet Home. The Google Sketchup warehouse filename is ICA3755 3W.skp. I am unable to attach this kind of file to a post in this forum.

    Background_visible.png
    720 x 540 - 283K
    Background_invisible.png
    720 x 540 - 213K
    Screen_shot_2012-06-12_at_1.38_.56_PM_.jpg
    800 x 553 - 59K
  • adamr001adamr001 Posts: 0
    edited December 1969

    What are the surface settings for your glass material? Also what are your advanced render settings? Specifically Raytrace Depth?

  • Kendall SearsKendall Sears Posts: 1,883
    edited December 1969

    Many "modeling" packages simulate thickness with 2 polygons spaced apart. For Glass like objects you will need to delete one of the polygons that make up the window glass.


    This can be done in DS4 using the Polygon Group Editor Tool. Select the "Extra" polygon and select "Hide Selected" NOTE: This setting WILL NOT save. Therefore, you will have to re-hide the extra Polygon each time the project is loaded.


    EDIT: I've attached a model with the problem. I've deleted part of the 2nd pane from the front window so that you can see the effect. The side window is using the same glass shader as the front window. Where there are 2 panes, the window is opaque.


    Kendall

    I have used models with double planes for windows and did not have this problem. it gave a more realistic glass.
    With what render/surface settings will this occur?

    Cheers! Oom


    I guess I should qualify my statement... "At the default render settings..." I should have been more clear. I made an assumption of the use of the default settings when I made my statements.


    Kendall

  • SzarkSzark Posts: 8,765
    edited December 1969

    adamr001 said:
    What are the surface settings for your glass material? Also what are your advanced render settings? Specifically Raytrace Depth?


    Yes I would be looking at Raytrace Depth as well. Looks like the light isn't getting all the way through the windows hence the grey.

  • adamr001adamr001 Posts: 0
    edited June 2012

    Szark said:
    Yes I would be looking at Raytrace Depth as well. Looks like the light isn't getting all the way through the windows hence the grey.
    Could also be specular values including multiply through opacity being off, diffuse strength, ambient values, etc. Lots of things going into making glass look like glass, but I'm definitely thinking Raytrace Depth... ^_^

    Post edited by adamr001 on
  • SzarkSzark Posts: 8,765
    edited December 1969

    adamr001 said:
    Szark said:
    Yes I would be looking at Raytrace Depth as well. Looks like the light isn't getting all the way through the windows hence the grey.
    Could also be specular values including multiply through opacity being off, diffuse strength, ambient values, etc. Lots of things going into making glass look like glass, but I'm definitely thinking Raytrace Depth... ^_^
    Agreed but from my expereince most of the time it is due to not having a high enough raytrace depth. But yes all those above should be chcked anyway.

  • Richard HaseltineRichard Haseltine Posts: 19,421
    edited June 2012

    Ray trace depth shouldn't affect surfaces that aren't set to reflect or refract, surely?

    Post edited by Richard Haseltine on
  • adamr001adamr001 Posts: 0
    edited December 1969

    Ray trace depth shouldn't affect surfaces that aren't set to reflect or refract, surely?
    Raytrace Depth affects the ability of light to penetrate transparent items. You need [Layers of Transparency] + 1 as your raytrace depth for those items to pass light and cast a shadow. Just like you need [Number of Reflections] * 2 = Raytrace depth to do reflections of reflections style renders.

  • PhoneyBaloneyPhoneyBaloney Posts: 0
    edited December 1969

    Regarding the properties of the glass, the set is all one piece, so I had to use properties for the glass that I use for the rest of the wall.
    Regarding "raytrace depth," how do I adjust that?

  • Kendall SearsKendall Sears Posts: 1,883
    edited December 1969

    Regarding the properties of the glass, the set is all one piece, so I had to use properties for the glass that I use for the rest of the wall.
    Regarding "raytrace depth," how do I adjust that?

    In DS4 you can use the Polygon Group Editor to select polys and assign them to your own shading groups. So you could assign the window glass to a group called "glass" and then use a glass shader on that group.


    The raytrace depth is in the Render Settings tab.


    Kendall

  • adamr001adamr001 Posts: 0
    edited December 1969

    Eh, I just did some testing because of what Richard said and he's right. It looks like somewhere since the last time I tested this (back in DS2 or even DS1.8 days) things have changed.


    I created four planes, a ground plane, and three others. The three others were raised on the Y-axis and each given their own transmap (the numbers 1, 2 and 3 in pure white, the rest pure black). Specular strength and ambient strength were set to zero. A distant light was added and rotated -90 on X-axis and raytraced shadows set. Raytrace depth was left at 2.


    Works fine. (see attached)


    Makes me think my other possibilities earlier were correct. Specular and/or Ambient settings.

    transtest123.png
    800 x 800 - 37K
  • SzarkSzark Posts: 8,765
    edited December 1969

    Ray trace depth shouldn't affect surfaces that aren't set to reflect or refract, surely?
    Makes sense now. With little rendering of glass filled windows I have done I have used reflect and refract and had to increase the raytrace to get the desired results. I try to avoid these types of raytracing until I get a more powerful computer with tons of ram. :)

    I also remembered what adam said above, a while back on the old forums and couldn't work out why I was getting a shadow from hair that use transmaps with no reflection or refraction...now I know thanks Richard.

  • PhoneyBaloneyPhoneyBaloney Posts: 0
    edited December 1969

    Just as a follow up for all of you helpful people, I just created a new set and eliminated the glass from the windows. I then used the D-flector to bend my 2D cityscape to give it depth. Attached is the result.

    Backdrop.png
    720 x 540 - 369K
Sign In or Register to comment.
Rocket Fuel