Multiple runtimes in C8 beta?

Salem2007Salem2007 Posts: 387
edited December 1969 in Carrara Discussion

I have several runtime libraries...mainly to seperate things out into stuff I use frequentlry and stuff I use rarely, and runtimes with stuff for vendors that I tend to use a lot.

In the C8 betas, these runtimes are duplicated, but one of the two are empty. For examle, I have a V4, M4, and Weapons runtimes. In C8 beta, I see:

V4 runtime
M4 runtime
Weapons runtime
V4
M4
Weapons

The folders with "runtime" have content (and the subfolders). The other folder don't have any subfolders. In C8 (the release version) I only see the "runtime" folders. I deleted the non-runtime folders, but they came back the next time I loaded C8 beta. Any one see this, or am I doing something wrong?

Comments

  • GarstorGarstor Posts: 1,411
    edited December 1969

    Where is Dartanbeck when you need him? ;-)

    He helped me tremendously with sorting out my C8.1 runtimes. I'm not sure about C8.5 behaviour; I have not tried the beta code.

  • Salem2007Salem2007 Posts: 387
    edited December 1969

    I suspect it has somehting to do with the way I added the runtimes to the Beta the first time (or the way I added them to DS4). I tried to delete one of the runtimes (both the M4 runtime and the M4) last night, but the beta added them both back....

    I may uninstall DS4, Carrara 8 and the C8 beta to see if that fixes it.

  • 3DAGE3DAGE Posts: 2,003
    edited June 2012

    Hi Salem2007 :)

    It's worth remembering that C8.5 is still in Beta, not a final product yet, so the browser / runtime / smart content area's may still be in development.

    I'd hold off, un-installing / re-installing everything to try to fix this right now in a beta.

    :)

    Post edited by 3DAGE on
  • Salem2007Salem2007 Posts: 387
    edited December 1969

    Thanks 3DAGE, I won't do anything to drastic! I just wondered if anyone else had the same problem--I guess I could put in a bug report just in case, but if it's only me having the problem it's not a bug (it's me!).

  • holly wetcircuitholly wetcircuit Posts: 0
    edited December 1969

    Salem2007 said:
    I suspect it has somehting to do with the way I added the runtimes to the Beta the first time (or the way I added them to DS4). I tried to delete one of the runtimes (both the M4 runtime and the M4) last night, but the beta added them both back....

    I may uninstall DS4, Carrara 8 and the C8 beta to see if that fixes it.

    There is a text file somewhere (on Mac it is in the Library folder I think) that is basically all the browser and directories.... It also holds Carrara's preferences. If you can edit that with a simple text editor it might save time.

  • Salem2007Salem2007 Posts: 387
    edited December 1969

    I thought there would be a text file somewhere that controlled the directories fo runtimes and prefs--I just haven't found it, yet.

  • Frank__Frank__ Posts: 233
    edited December 1969

    This was a problem in the first beta. I thought it was solved with further iterations?

    The text-file you're looking for is called "Preferences.txt" located on a newer Windows-system in c [or your root-drive]:\users\[your account-name]\AppData\Roaming\DAZ 3D\Carrara. When switching between C 8.1 and C 8.5 Beta you could save the the "Preferences.txt" into something like "Preferences81.txt" and "Preferences85.txt", then copying the saved file to the actual "Preferences.txt" before starting either C8.1 or C8.5. (At least that was the work-around with the first betas; I had some more information in the old forum and some batch files to automate the switch process.)

  • Salem2007Salem2007 Posts: 387
    edited December 1969

    ok--I found the prefrences.txt file and tried making changes...everything stays the same. It looks like it adds things back that I delete.

    I even deleted he entire prefrences.txt from the 8.5 beta folder--C8 beta asked if I wanted to search form runtimes and I chose "no"---all my old runtimes were there (including the empty folders). Very odd.....

  • 3DAGE3DAGE Posts: 2,003
    edited December 1969

    Hi Frank :)

    This was a problem in the first beta. I thought it was solved with further iteration


    This is a different problem,..
    The issue in the First beta was that Carrara 8.5 Changed the display of Runtime folders in Carrara 8.0, or 8.1, (because they both shared the same preferences file).

    As far as I remember, they were also displayed as "Runtime folder" which wasn't very helpful, especially with multiple runtime folders.

    The issue now is that Carrara is displaying the Runtime folder,. and also displaying a separate entry for the "root folder" for that runtime.
    So,.. For example: I see (Poser 6 runtime) and I see (Poser 6)

    The second part of this issue is that "if the user removes these folders" then that should be saved in the preferences file, and that's not happening right now.
    The folders are being replaced...

    My though is that it's connected to the DS CMS list of available content folders, since carrara need to know where those are to display the smart content. so they also show up in the display of "normal" content

    I've reported this as a Bug. so hopefully the developers will have a look at it.

  • Frank__Frank__ Posts: 233
    edited December 1969

    3DAGE said:
    Hi Frank :)

    This was a problem in the first beta. I thought it was solved with further iteration


    This is a different problem,..

    I've reported this as a Bug. so hopefully the developers will have a look at it.

    Thanks Andy.

    I stand corrected, but I was just thinking, that sometimes a solved bug is re-introduced in some future version. I know this has happened to my own programs sometimes ... :)

  • Salem2007Salem2007 Posts: 387
    edited December 1969

    Ahh--at least I know it's not just me having the problem. I looked through the bug list, but I couldn't find one that matched what I was seeing---3DAGE's description of the problem was much clearer.

Sign In or Register to comment.
Rocket Fuel