DSON Importer for Poser 1.0.0.56 is now available!

2

Comments

  • edited December 1969

    There is one thing you could try: Delete the following folder: C:\Users\Public\Poser 9 Content\Runtime\DSON\auto_adapted
    This folder is where genesis is loaded from if you do not have a separate runtime for the genesis content.
    In one of your installation attempts (now or previously) this content may have been created at this location and may now interfere with the new installation.

    Explanation:
    The location where the intermediate genesis content is stored is called the "writable runtime" and can be changed with the python scripts. When Poser gets a relative path for a resource, it uses the runtime order to find the actual resource. In your case it may find the wrong one

  • SarunaSaruna Posts: 45
    edited December 1969

    Yes 3 times - I have even downloaded the files again.

  • edited December 1969

    Saruna said:
    Yes 3 times - I have even downloaded the files again.

    You have to explictly delete them, they won't be uninstalled. They are generated the first time when DSON is loading genesis unless they already exist.

    But if you have done that and it did not help, then it is another problem
    .

  • SarunaSaruna Posts: 45
    edited December 1969

    Thank you for your help.

    I have tried with deleting an reinstalling Dsonimporter.
    I even have started Poser as an administrator - allways the same failure message.

  • Satira CapriccioSatira Capriccio Posts: 522
    edited December 1969

    Um ... My eyes hurt now! Color coding is absolutely evil!

    Apparently, since I was logged into the Zen desk to respond to the ticket I'd opened there, I was already logged in to the Mantis Bug tracker when I went there.

    Frank0314 said:
    https://bugs.daz3d.com You will need to sign up for an account

    On another note, after installing the latest DSON Installer for Poser, my Library froze within a few minutes of loading Genesis. I closed Poser and and started a new scene after launching Poser again. Within a few minutes of loading Genesis, my Library froze again.

    The first time, I loaded Genesis, dialed Julia, located and applied a texture, loaded a clothing item, then ran the Transfer Active Morphs. When I went to switch to Poses, the Library no longer responded.

    The second time, I loaded V5, loaded the Elven Dress, Cape, and Hood, loaded a Pose, ran the Transfer Active Morphs. Then I deleted the clothing because the dress was going to require too much fiddling to work with the pose. But when I went to switch to Characters, the Library no longer responded.

    Both times, the Library froze shortly after Transferring Active Morphs. Since I've been able to work on scenes with Genesis for much longer than these two times, I got a little suspicious. I don't always Transfer Active Morphs immediately since the results are so inconsistent.

    The third time, I loaded M5, clothing, hair, textures, and posed M5. Then I loaded V5, clothing, hair, textures, and posed V5. This took about a half hour, and my Library was still responsive. So ... I Transferred Active Morphs.

    Immediately, the Library no longer responded.

    Quite interesting indeed.

  • Richard HaseltineRichard Haseltine Posts: 19,387
    edited December 1969

    Did you get a progress bar with the transfer process?

  • beckywlmsbeckywlms Posts: 0
    edited December 1969

    Can someone please tell me how to use this or where I can find instructions on how to use it, Please.
    :red:

  • Satira CapriccioSatira Capriccio Posts: 522
    edited December 1969

    I see a list of morphs scrolling by as they are being transferred to all the clothing in the scene. Whether or not that was as a "Progress Bar," I don't remember.

    Did you get a progress bar with the transfer process?

  • RogerbeeRogerbee Posts: 3,599
    edited January 2013

    Yes, I think that's what he meant, right from the earlier releases you were supposed to disable this. It was known to cause freezes, but, they still kept it in.

    Just out of interest, where is your main Poser library installed? Since I moved mine to my Documents library, the same one as the DSON'ed Genesis content is installed in, it seems to be much more stable. I just checked to see what happened with my library and the current DSON and nothing did. As per the usual library location for PP2012 you do need a dummy Poser.exe in there or the Daz installers get lost.

    CHEERS!

    Post edited by Rogerbee on
  • WandWWandW Posts: 1,257
    edited December 1969

    beckywlms said:
    Can someone please tell me how to use this or where I can find instructions on how to use it, Please.
    :red:

    http://docs.daz3d.com/doku.php/public/software/dson_importer/poser/userguide/start

    :)

  • Satira CapriccioSatira Capriccio Posts: 522
    edited December 1969

    There is no progress bar when loading Genesis. The DSON Importer Preference to Show Progress On Load is unchecked. It's when the Active Morphs are transferred that I see indications of morphs being transferred to the clothing. Quite strange to see head morphs being transferred to pants and shoes.

    I keep Genesis content out of main Poser runtimes. I don't like the additional folders that are created with DS content and they aren't used by Poser.

    So Genesis is in DAZ 3D/Studio/My Library/Runtime.

    Rogerbee said:
    Yes, I think that's what he meant, right from the earlier releases you were supposed to disable this. It was known to cause freezes, but, they still kept it in.

    Just out of interest, where is your main Poser library installed? Since I moved mine to my Documents library, the same one as the DSON'ed Genesis content is installed in, it seems to be much more stable. I just checked to see what happened with my library and the current DSON and nothing did. As per the usual library location for PP2012 you do need a dummy Poser.exe in there or the Daz installers get lost.

    CHEERS!

  • RogerbeeRogerbee Posts: 3,599
    edited December 1969

    Are you still having problems?

    I can't really remember what's what with DSON now. I've switched back to DS itself and am actually beginning to enjoy it. Genesis makes more sense in its natural habitat and Autofit is a doddle, well, it is when you have the right body shapes installed! It's certainly better than Transfer Active Morphs will ever be. DSON will only ever be a compromise, I can see that now.

    CHEERS!

  • TheWheelManTheWheelMan Posts: 983
    edited December 1969

    Rogerbee said:

    Are you still having problems?

    I can't really remember what's what with DSON now. I've switched back to DS itself and am actually beginning to enjoy it. Genesis makes more sense in its natural habitat and Autofit is a doddle, well, it is when you have the right body shapes installed! It's certainly better than Transfer Active Morphs will ever be. DSON will only ever be a compromise, I can see that now.

    CHEERS!

    I think that now that Genesis is finally in Poser, they will eventually make things work even better. Maybe not until the next version of Poser, however.

  • RogerbeeRogerbee Posts: 3,599
    edited December 1969

    I doubt I'll be bothering with a new version of Poser, any new version of DS will be free!

    CHEERS!

  • yannosByannosB Posts: 3
    edited December 1969

    Saruna said:
    Hi,

    .............
    Do you have any ideas?

    I have seen from others that after installing DSON, if this happens try installing the SR3 update for Poser again, each I read that did so eleminated this 'call problem'

  • icprncssicprncss Posts: 3,444
    edited December 1969

    I found that I had to uninstall DSON and remove all traces the auto generated files. Then, I reinstalled SR2, SR3 and SR3.1. Then I re-installed DSON and the support files (support files are in their own runtime).

    This seems to have fixed the library problem in P9. I don't know about Pro 2012 (the company owns that copy and I'd have to fight with them to add it...don't ask it's too complicated).

    I haven't added anything to the DSON runtime outside of the basic files. Base Genesis and basic content are working fine and library is running smoothly. I don't know what effect adding other morph packs or trying to add active morphs to clothing will do. I haven't gotten that far yet. Deadlines tend to interfere with such things.

  • TheWheelManTheWheelMan Posts: 983
    edited December 1969

    icprncss said:
    I found that I had to uninstall DSON and remove all traces the auto generated files. Then, I reinstalled SR2, SR3 and SR3.1. Then I re-installed DSON and the support files (support files are in their own runtime).

    This seems to have fixed the library problem in P9. I don't know about Pro 2012 (the company owns that copy and I'd have to fight with them to add it...don't ask it's too complicated).

    I haven't added anything to the DSON runtime outside of the basic files. Base Genesis and basic content are working fine and library is running smoothly. I don't know what effect adding other morph packs or trying to add active morphs to clothing will do. I haven't gotten that far yet. Deadlines tend to interfere with such things.

    You only had to install the latest stable release (SR3.1). The each release always includes the previous releases.

  • McG.McG. Posts: 177
    edited December 1969

    Just an FYI to all; the DSON importer had NOT been working for me at all, until Richard Haseltine let me know in simplest terms that only the DSON Importer is to be installed to the Poser program folders. EVERYTHING else goes to the Runtime. With that done, I finally got GENESIS to load.
    Now; ALL that severely misplaced content the 400+ meg installer puts in, I want to further organize it by dropping *ALL* of it into the folder named Content. Is that going to foul up operation of DSON if I do that?

    The green hilighted folders are what I need to move into Content.

    Folders_1.jpg
    692 x 733 - 109K
  • FixmypcmikeFixmypcmike Posts: 11,647
    edited December 1969

    No, the Data and Runtime folders have to be at the same level. If you're only using Poser, I don't think you need any of the other folders. You only need those for DS or Carrara.

  • McG.McG. Posts: 177
    edited December 1969

    Thanks! I didn't know that about the 'data' folder. Since I try to use D|S and Carrara occasionally, I'll keep those folders. I guess I should move the older 'data' folder out of Content up alongside Runtime. That one is older and a lot bigger. Might be why D|S 4.5 didn't want to load anything.

  • Jeanne MJeanne M Posts: 543
    edited March 2013

    No, the Data and Runtime folders have to be at the same level. If you're only using Poser, I don't think you need any of the other folders. You only need those for DS or Carrara.

    That's correct. I made an external runtime, named it "PoserGenesis" and therein I have the data and runtime folders. No need for the others. When you buy new Genesis-Poser stuff, make sure you also move the textures folder to the Poserruntime. You won't need the support folder either.

    Love, Jeanne

    Post edited by Jeanne M on
  • edited December 1969

    Hmmm,
    since I installed this update, using Genesis with DSON in Poser has really slowed down to crawl

  • reiperreiper Posts: 1
    edited December 1969

    I have an issue and I was wondering if I could get help with it.

    I followed the DSON instructions (first time user), DSON support shows up under scripts.

    When I do attempt to load it anything, lets say Genesis, I get the following error:

    Traceback (most recent call last):
    File "C:\Program Files (x86)\Smith Micro\Poser Pro 2012\Runtime\libraries\Character\DAZ People\Genesis.py", line 1, in
    import dson.dzdsonimporter
    ImportError: No module named dson.dzdsonimporter


    I'm betting I missed something really simple, or this is a newbie mistake, but just seeing if I can get some help from the experts.

  • TheWheelManTheWheelMan Posts: 983
    edited December 1969

    Since you appear to be using Poser Pro 2012, is your computer 32 or 64 bit, and did you install the correct DSON Importer script for your system?

  • SarunaSaruna Posts: 45
    edited December 1969

    For me the Dson runs finally, after I followed the tip by Richard to uninstall Dson Once again, the Poser 9 SR 3.1 to install again and again in the current version Dson.

    The Essentials, I first have to install the DIM, but when that did not work again on the exe installation files. Then also ran the back.

    I got the impression that if you dim the only Poser 9 and Dson selects, not all the necessary files to be made available, because all those things are not running. I had created for myself Dson extra a new download folder for dim, and the content is installed in an external Poser Runtime - likewise stored in the DIM.

    Has anyone had similar experiences and any advice for me?
    As situation now I would have to leave the files reset because I had not canceled the executable files.

  • FixmypcmikeFixmypcmike Posts: 11,647
    edited December 1969

    reiper said:
    I have an issue and I was wondering if I could get help with it.

    I followed the DSON instructions (first time user), DSON support shows up under scripts.

    When I do attempt to load it anything, lets say Genesis, I get the following error:

    Traceback (most recent call last):
    File "C:\Program Files (x86)\Smith Micro\Poser Pro 2012\Runtime\libraries\Character\DAZ People\Genesis.py", line 1, in
    import dson.dzdsonimporter
    ImportError: No module named dson.dzdsonimporter


    I'm betting I missed something really simple, or this is a newbie mistake, but just seeing if I can get some help from the experts.

    The content should not be installed under Program Files/Program Files (x86). Only the plugin itself goes in the application folder.

  • RAMWolffRAMWolff Posts: 5,300
    edited December 1969

    Do folks know about the FREE DAZ Studio plugin being offered over at RDNA? Since this is free I would hope it will be OK to post this hear for those that want a bit more stream lined solution: http://www.runtimedna.com/LM2-DAZ-Studio-plugin.html Watch the video, it's quite helpful in understanding what this plugin does.

  • Escutcheon7DEscutcheon7D Posts: 0
    edited December 1969

    does this work on MAC computers?

  • KeryaKerya Posts: 7,186
    edited December 1969

    RAMWolff said:
    Do folks know about the FREE DAZ Studio plugin being offered over at RDNA? Since this is free I would hope it will be OK to post this hear for those that want a bit more stream lined solution: http://www.runtimedna.com/LM2-DAZ-Studio-plugin.html Watch the video, it's quite helpful in understanding what this plugin does.

    And remember that you need Library Manager 2.6 for it to work.
    http://www.runtimedna.com/ShaderWorks-Library-Manager-2.6.html


    Another free script by Dimension3D
    http://d3d.sesseler.de/index.php?software=poserpython&product=dson_loader

  • WandWWandW Posts: 1,257
    edited December 1969

    does this work on MAC computers?

    I don't have a Mac, but there are Mac installers in my downloads... :)

Sign In or Register to comment.
Rocket Fuel