UberEnvironment Grainy Shadows

Freelancer604Freelancer604 Posts: 0
edited December 1969 in The Commons

Hey all. I was wondering if anyone can help me out with the grainy shading that Uberenvironment produces? I think it might be the ambient occlusion thats doing it (could be wrong) but the shading in many of my uberenvironement renders are coming out super grainy and messy.. how do I fix this?

I have tied turning the ambient occlusion samples up beyond 120, but it does not seem to eliminate the problem? Heres a cropped piece of something Im in the middle of postworking. The grainy shading Im talking about is pretty noticable along the jaw and on the dark side of the neck.

Comments

  • mjc1016mjc1016 Posts: 7,751
    edited December 1969

    Screenshot of the UberEnvironment Settings and a screenshot of Advanced Render settings would be the easiest way to figure out what needs to be changed...

  • Zev0Zev0 Posts: 3,637
    edited December 1969

    I also want to know how to eliminate the noise when using the uber-environment.

  • MachieltjeMachieltje Posts: 0
    edited December 1969

    Lower the shading rate on UE2; you can go as low as 1 (you could go even lower but I'm not sure it would help) Of course there's a down side to this as your render times will go up quite a bit...

  • MachieltjeMachieltje Posts: 0
    edited December 1969

    Aslo, Freelancer I see you have at least one light set up to use deep shadow maps (the colourful render errors are a dead give away) set it to ray traced to get rid of those. ( adding even more to your render time :P)

  • Freelancer604Freelancer604 Posts: 0
    edited December 2012

    Aslo, Freelancer I see you have at least one light set up to use deep shadow maps (the colourful render errors are a dead give away) set it to ray traced to get rid of those. ( adding even more to your render time :P)

    Ooh so thats what causes those color dots. Its actually an issue thats been bothering me for a long while thanks!

    As for the UE shading, I have the rate set to 0.2 for the image light and 1.0 for the overall render. Shadow samples at 128 for UE and 35 for the render...

    Post edited by Freelancer604 on
  • timnaas_202ce12143timnaas_202ce12143 Posts: 77
    edited December 1969

    To eliminate or lower the :sharp shadow" in raytrace, you increase the shadow softness as well! I usually have my UE2 set on the 3Hi settings, with shadow samples set at 90-100, shade rate set at 2-3. Set the Environment Mode to Occlusion with soft shadows. My render shade rate is .5. My render times are usually 1-2 hour. Under the 4XHi settings with shadow samples set at 128, shade rate 1-2, Then render time increased to 8+ hours. At least that's what I have learned anyways! Might not be photo realistic, but a lot better results compared to some renders I have seen!

  • scorpioscorpio Posts: 3,835
    edited December 1969

    Reduce your overall shading rate to 0.1 and see if that helps.

  • rpm45rpm45 Posts: 0
    edited December 1969

    A thought occurred to me, but I haven't had time to try it yet: Have you looked at the Subsurface Shading Rate setting on your skin surface? That might be responsible for some of the grain, too, I imagine. (I see the same thing when I use UE, but I've been rendering a human figure with SSS all over the place. Like I said, haven't tried changing it.)

    I suppose the quickest way to see if it'd make a difference would be to turn SSS off entirely, wouldn't it? I'll have to try that too.

  • SzarkSzark Posts: 8,782
    edited December 1969

    Yes increasing the SSS Shading Rate to 128 will reduce the need to max out the Shading Rate in the advanced render settings when using Uber Environment 2 and in my expereince it doesn't increase render times that much.

Sign In or Register to comment.
Rocket Fuel